summaryrefslogtreecommitdiff
path: root/x11-apps/xauth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-14 11:04:34 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-14 11:04:34 +0100
commitdd762ff83c330186ee2ede002e08b2f780cddd51 (patch)
tree63198edcc3ad5df8e2566c28ff9bd8af50cc2174 /x11-apps/xauth
parent51af5f0eb4cddbe6aa7953717873691d77aae9ff (diff)
gentoo resync : 14.07.2019
Diffstat (limited to 'x11-apps/xauth')
-rw-r--r--x11-apps/xauth/Manifest4
-rw-r--r--x11-apps/xauth/xauth-1.1.ebuild34
-rw-r--r--x11-apps/xauth/xauth-9999.ebuild23
3 files changed, 50 insertions, 11 deletions
diff --git a/x11-apps/xauth/Manifest b/x11-apps/xauth/Manifest
index 7f19696ea884..f53246c1221a 100644
--- a/x11-apps/xauth/Manifest
+++ b/x11-apps/xauth/Manifest
@@ -1,4 +1,6 @@
DIST xauth-1.0.10.tar.bz2 162176 BLAKE2B 0a3a70360357f0f1a36a72e54b404526e62ddabbdc8b2e6ed992ceb56847fa983b9cec1ba23aab92f4b2fe0712f097a8721d7c50a4b4ead217a5704cda76ea82 SHA512 1ddcd80848c4efffc6d0a576177f92a3ce47eb871a6c7e2097d96491aec027404d437e0bd792714ef423989153a9644f5ff179bde4dfeb4b340636d642d5849f
+DIST xauth-1.1.tar.bz2 163510 BLAKE2B 0b55ee9ec35ca436c36effe2ba4eee55f76a311a5482d1d72e80e5afea30c682de3f686b2956d17278721e190dd9bec4d93db6507853841a633c931312df745d SHA512 b6ecd59a853a491ef45bf8cfbff63bed36645f81cb79ae9d18458b57f7502bccf92f0d979d3337578518646f680ad379e67b1dac15a927cbb11372733e7a3a0c
EBUILD xauth-1.0.10.ebuild 663 BLAKE2B 6776d89fede43d9b6d57328444c4a1ba9d261f4170cf1007c6b79af501b5c67cb46a361682a6046b23ccfed496a27f34f637f60a126fe4aad545abaf89b5d97c SHA512 0fd029a3cfe03e4a08da9147e1b856bedf8407c21299339fbd151038c5de3920c1ec305dc58ff720575e5c0e3de484fd169f3c3bf811d62c4d7ea34217e8b6f7
-EBUILD xauth-9999.ebuild 545 BLAKE2B 4b97293aa97ef5d05644508ab8bd6c055fb65d5c484981fa1cb786e5012e45e378d393b39c76d0744680e1385c36bc2da55a35192fdea22ff2e4b4ed18b23412 SHA512 99b1c10111900c48a7debdef3020905899018844fcc9b52b72e304e6a7f9702145565e2363bc8a7908cb7feb13e2bba0a62fd9afe64616ad14400e8e9c3c4c81
+EBUILD xauth-1.1.ebuild 659 BLAKE2B 2aff9ff901ca6c2cff8e73acad3a4112873774b430d4c6bad930154a07fd5b8d57f2d2b2dc28e80bd12cf8a45fb8ae82b5a6480fc0fe5f5564e9a4e52f41263e SHA512 2a2a9107b480b777bacae80da61a3c5035846f681c627547f492fc9c1117c31efa0eef99b10f32d3fd8add3d06e6965af6e6a0648234d11d6d7dd45b3c693c1f
+EBUILD xauth-9999.ebuild 659 BLAKE2B 2aff9ff901ca6c2cff8e73acad3a4112873774b430d4c6bad930154a07fd5b8d57f2d2b2dc28e80bd12cf8a45fb8ae82b5a6480fc0fe5f5564e9a4e52f41263e SHA512 2a2a9107b480b777bacae80da61a3c5035846f681c627547f492fc9c1117c31efa0eef99b10f32d3fd8add3d06e6965af6e6a0648234d11d6d7dd45b3c693c1f
MISC metadata.xml 234 BLAKE2B b45f6795dbd73dfcee2a68f93ec5460509b15a69401467bc8f4af9505eeb04a2aa35a2b144eb88781df4abd4e15d2b88fc728daf033c6d646762170ffb00b1a7 SHA512 fabcd59aeede4ac93d66552746edacc44fd565551aafaca67185aff7f8e6a4c0fa21f3d54e4fccd7def948ec57b90489631bd779fb992cd9322132b0a3aa503b
diff --git a/x11-apps/xauth/xauth-1.1.ebuild b/x11-apps/xauth/xauth-1.1.ebuild
new file mode 100644
index 000000000000..057d3ed2a71e
--- /dev/null
+++ b/x11-apps/xauth/xauth-1.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xorg-3
+
+if [[ ${PV} == 9999* ]]; then
+ SRC_URI=""
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="X authority file utility"
+IUSE="ipv6 test"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXext
+ x11-libs/libXmu"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="test? ( dev-util/cmdtest )"
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable ipv6)
+ )
+}
+
+src_test() {
+ addwrite /proc/self/comm
+ emake check
+}
diff --git a/x11-apps/xauth/xauth-9999.ebuild b/x11-apps/xauth/xauth-9999.ebuild
index aa5cc700c661..057d3ed2a71e 100644
--- a/x11-apps/xauth/xauth-9999.ebuild
+++ b/x11-apps/xauth/xauth-9999.ebuild
@@ -1,13 +1,17 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit autotools-utils xorg-2
+inherit xorg-3
-DESCRIPTION="X authority file utility"
+if [[ ${PV} == 9999* ]]; then
+ SRC_URI=""
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~amd64-linux ~x86-linux"
+fi
-KEYWORDS=""
+DESCRIPTION="X authority file utility"
IUSE="ipv6 test"
RDEPEND="x11-libs/libX11
@@ -15,17 +19,16 @@ RDEPEND="x11-libs/libX11
x11-libs/libXext
x11-libs/libXmu"
DEPEND="${RDEPEND}
- test? ( dev-util/cmdtest )"
+ x11-base/xorg-proto"
+BDEPEND="test? ( dev-util/cmdtest )"
-src_configure() {
+pkg_setup() {
XORG_CONFIGURE_OPTIONS=(
$(use_enable ipv6)
)
- xorg-2_src_configure
}
src_test() {
- # Address sandbox failure, bug #527574
addwrite /proc/self/comm
- autotools-utils_src_test
+ emake check
}