summaryrefslogtreecommitdiff
path: root/x11-apps/mkfontscale/mkfontscale-1.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
commitdc7cbdfa65fd814b3b9aa3c56257da201109e807 (patch)
treec85d72f6f31f21f178069c9d41d41a7c1ff4b362 /x11-apps/mkfontscale/mkfontscale-1.2.1.ebuild
parent0706fc6986773f4e4d391deff4ad5143c464ea4e (diff)
gentoo resync : 05.04.2019
Diffstat (limited to 'x11-apps/mkfontscale/mkfontscale-1.2.1.ebuild')
-rw-r--r--x11-apps/mkfontscale/mkfontscale-1.2.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/x11-apps/mkfontscale/mkfontscale-1.2.1.ebuild b/x11-apps/mkfontscale/mkfontscale-1.2.1.ebuild
new file mode 100644
index 000000000000..60b075e59724
--- /dev/null
+++ b/x11-apps/mkfontscale/mkfontscale-1.2.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xorg-3
+
+DESCRIPTION="create an index of scalable font files for X"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+COMMON_DEPEND="
+ x11-libs/libfontenc
+ media-libs/freetype:2
+ sys-libs/zlib
+ app-arch/bzip2"
+DEPEND="${COMMON_DEPEND}
+ x11-base/xorg-proto"
+RDEPEND="${COMMON_DEPEND}
+ !<x11-apps/mkfontdir-1.2.0"
+
+XORG_CONFIGURE_OPTIONS=(
+ --with-bzip2
+)