summaryrefslogtreecommitdiff
path: root/www-servers
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-12 20:22:37 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-12 20:22:37 +0100
commitf8ca23f9f6e4a55e4195e553ca2f3e7dd425f51c (patch)
tree8268a378f27e1940a5a76b3c55abf6e4ee0fc256 /www-servers
parent7c68db06bb531670c1261374c0133d652b476bd7 (diff)
gentoo auto-resync : 12:08:2022 - 20:22:37
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/Manifest.gzbin5024 -> 5027 bytes
-rw-r--r--www-servers/varnish/Manifest2
-rw-r--r--www-servers/varnish/varnish-7.1.1.ebuild102
3 files changed, 104 insertions, 0 deletions
diff --git a/www-servers/Manifest.gz b/www-servers/Manifest.gz
index ddf5959671d7..16289130224b 100644
--- a/www-servers/Manifest.gz
+++ b/www-servers/Manifest.gz
Binary files differ
diff --git a/www-servers/varnish/Manifest b/www-servers/varnish/Manifest
index 4e1d8e74b8f2..31603c385a69 100644
--- a/www-servers/varnish/Manifest
+++ b/www-servers/varnish/Manifest
@@ -7,5 +7,7 @@ AUX varnishlog.initd 707 BLAKE2B 90e75e267a2ad8688ace41d4eff20e8601e0b20abc9b73e
AUX varnishncsa.confd 84 BLAKE2B fbb338ec2163562d7679a7371cda3cd297449186bfcaa668e3924d944dc78eae8d8bf5c60230202fee4093119ccc74d67ad8f3e6774091c6c2b5c9b184d4b5eb SHA512 a5426ff66b89d2afb6273f05e4117b3eec5ce0162a624d52c92b418960f72e58bd01224165613221af76ec241bd98e1eb985b2ef7b83a5b615e9ece67234dcc8
AUX varnishncsa.initd 716 BLAKE2B 33fd6b044ab50aef629fa4501eb4a78bd3d690db52b86a33d1d4e87c1da28088b9f25ce917d16a9ed777b1d6e1ece5a916af0c4ff293db82b94d264fd5baafa9 SHA512 1d0c781675ecba5adce02c37a02c431c4b44d64310a0945bff4f6f57f7d0c87cb7dda874311e44d667317d5beda113b62f4ba49c81534a0c078314b3fa15a512
DIST varnish-7.1.0.tgz 3787588 BLAKE2B 1a019b140c467063861460b529c253361975826cee797c304c7c096645c315b67ad20400467ecf11711abae5354134ac29a934793691283e12e3fbe29921943b SHA512 ad9ce0cdc759976fcb7044914d28863edd197167f583fab2d1bc57f4e5b86c224b7c948faf1f7364a2a16bde9c415375d011462bdc43026c5f7a60e65bd21f73
+DIST varnish-7.1.1.tgz 3742869 BLAKE2B d41e7214c3b51ac18b1a89012b48d3db58f4f777df675fa93d6ac75d3cf14b78af23f9d6e8b8686fdfa82add70a1a42e5e54f382506444ec81ad6d121a99e447 SHA512 7c3c081bd37c63b429337a25ebc0c14d780b0c4fd235d18b9ac1004e0bb2f65e70664c5bd25c5d941deeb6bc078f344fa2629cf0d641a0149fe29dcfa07ffcd2
EBUILD varnish-7.1.0.ebuild 2234 BLAKE2B 751a1ee4b19575d5965b507f20318b6fd203030cf0dd6a19090ee4989871bff9bd5f2a1fc6af5f0d4e36dccb57603bf446bd45ac0e82411a4dfdc4c6679ae5b8 SHA512 6c10b0d06a27c735c886de7545e0df562ba17b0880c710ca9ea569c1eef61893e4d1808639e21633d6a6962b5e8538ac8318beb6f0e917e27752a09760839ebf
+EBUILD varnish-7.1.1.ebuild 2236 BLAKE2B c469af8f3fbd4569a8021074d8a5731993f18becec637c26716c4b3e9aec1065108b46ecb418c6fb83595e4cda32f50fc96070057dd6b5d87e06fbed3bf78de9 SHA512 8da3030f1a7c916a2ced77857944c9a66e35e0c7501ad23c0a207d40dc1a7532971f54e0ff5e2c901502b0880343cad21ab222e80cedfb12cc5b5d0c12eb8240
MISC metadata.xml 1155 BLAKE2B 84875f3204cf314d1cb22e323ae8edb4e439e11d165c019bdf959925236ee4df671a9dbfd5a98d4c8841f8ec19cf8e602b703052d9a864d7e3c652ffe40054f0 SHA512 34bad8011b4530abc02f35b1bacb3d632ea5d57da41162a246d5601d766f192448efb31445536e02485fa195ab5f5eb564b4a1886632d0fd32626184d1173db7
diff --git a/www-servers/varnish/varnish-7.1.1.ebuild b/www-servers/varnish/varnish-7.1.1.ebuild
new file mode 100644
index 000000000000..e96a88314f50
--- /dev/null
+++ b/www-servers/varnish/varnish-7.1.1.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+PYTHON_COMPAT=( python3_{9..10} )
+
+inherit autotools systemd python-r1
+
+DESCRIPTION="Varnish is a state-of-the-art, high-performance HTTP accelerator"
+HOMEPAGE="https://varnish-cache.org/"
+SRC_URI="http://varnish-cache.org/_downloads/${P}.tgz"
+
+LICENSE="BSD-2 GPL-2"
+SLOT="0/2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="jemalloc jit static-libs"
+
+CDEPEND="
+ sys-libs/readline:0=
+ dev-libs/libedit
+ dev-libs/libpcre[jit?]
+ jemalloc? ( dev-libs/jemalloc )
+ sys-libs/ncurses:0="
+
+#varnish compiles stuff at run time
+RDEPEND="
+ ${PYTHON_DEPS}
+ ${CDEPEND}
+ acct-user/varnish
+ acct-group/varnish
+ sys-devel/gcc"
+
+DEPEND="
+ ${CDEPEND}
+ dev-python/docutils
+ dev-python/sphinx
+ virtual/pkgconfig"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RESTRICT="test" #315725
+
+src_prepare() {
+ # Remove -Werror bug #528354
+ sed -i -e 's/-Werror\([^=]\)/\1/g' configure.ac
+
+ # Upstream doesn't put varnish.m4 in the m4/ directory
+ # We link because the Makefiles look for the file in
+ # the original location
+ ln -sf ../varnish.m4 m4/varnish.m4
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ $(use_enable jit pcre2-jit)
+ $(use_with jemalloc)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ python_replicate_script "${D}/usr/share/varnish/vmodtool.py"
+
+ newinitd "${FILESDIR}"/varnishlog.initd varnishlog
+ newconfd "${FILESDIR}"/varnishlog.confd varnishlog
+
+ newinitd "${FILESDIR}"/varnishncsa.initd varnishncsa
+ newconfd "${FILESDIR}"/varnishncsa.confd varnishncsa
+
+ newinitd "${FILESDIR}"/varnishd.initd-r4 varnishd
+ newconfd "${FILESDIR}"/varnishd.confd-r4 varnishd
+
+ insinto /etc/logrotate.d/
+ newins "${FILESDIR}/varnishd.logrotate-r2" varnishd
+
+ diropts -m750
+
+ keepdir /var/lib/varnish
+ keepdir /var/log/varnish
+
+ systemd_dounit "${FILESDIR}/${PN}d.service"
+
+ insinto /etc/varnish/
+ doins vmod/vmod_*.vcc
+ doins etc/example.vcl
+
+ dodoc README.rst
+ dodoc doc/changes.rst
+
+ fowners root:varnish /etc/varnish/
+ fowners varnish:varnish /var/lib/varnish/
+ fperms 0750 /var/lib/varnish/ /etc/varnish/
+
+ find "${ED}" -name "*.la" -delete || die
+}