summaryrefslogtreecommitdiff
path: root/www-servers
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-08 19:07:58 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-08 19:07:58 +0000
commit8edd4a48a39640822abe6ddb7b2a1d5b2da4ea70 (patch)
treedd40a3ea9cdcc06c8c63bd2ee71c2c2c0ea11549 /www-servers
parent7825305c5ddf11fffe24fa30453c4e8468f64305 (diff)
gentoo auto-resync : 08:03:2024 - 19:07:58
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/Manifest.gzbin4704 -> 4707 bytes
-rw-r--r--www-servers/gatling/Manifest1
-rw-r--r--www-servers/gatling/gatling-0.16-r5.ebuild65
3 files changed, 66 insertions, 0 deletions
diff --git a/www-servers/Manifest.gz b/www-servers/Manifest.gz
index 142ee0d743ea..19368e663223 100644
--- a/www-servers/Manifest.gz
+++ b/www-servers/Manifest.gz
Binary files differ
diff --git a/www-servers/gatling/Manifest b/www-servers/gatling/Manifest
index ec4b0191aaca..7c5113903656 100644
--- a/www-servers/gatling/Manifest
+++ b/www-servers/gatling/Manifest
@@ -6,4 +6,5 @@ AUX gatling.initd-3 1970 BLAKE2B ba48e796b4fca2cd165756b3ef781feb47be18e43043d83
DIST gatling-0.16.tar.xz 126844 BLAKE2B 33dd2e93833b216ffadae4dbd5650af87b23ed5d62caf181d8005acb4dce889b86d1afb711676377ba2b7c4fe08b8f2350a32965cf6292a268281b28c4310c27 SHA512 9446ea0ae862509b1a892e5bdef14d3a2320c3c3e846362b4679c0834aa906ab5b16ef54e4a7c8e7ee839d30317436dd411e891e3105035a9ee31b0facc0b8c1
EBUILD gatling-0.16-r3.ebuild 1216 BLAKE2B ea0aba72dca0263f120aeb368738c37d2346606c799de4e43d5c6e278577b05ca60525743171cabdfd60e6e1fb600ee0119cde207838b2c9063b5b22c51ec8e3 SHA512 1620007437c598b6ad2255b3e1cc5101343e074091032486889e8c4834825523adaa670d608a84a390d72eb3baa8e66ba8c932d0410409419985185b9f8fe6e1
EBUILD gatling-0.16-r4.ebuild 1292 BLAKE2B 2225cd826ed76ea4b81166e0d4370d7506862fbd87dd56ed87fc8e2f63f7bc16291e30f0a3a903d4274c7befd3670e5ec6a730f63ce0e3389f4d2e76bfe2a6aa SHA512 dfc21f2dab94206d4e92a050cf2d1058036232dc8a45d13998c8f390483da64924db935c88472194a46d64002ac7dfc8cd75683bc699ac159535c98f24359694
+EBUILD gatling-0.16-r5.ebuild 1307 BLAKE2B d41cbcf8531ca127feb0195de78ac4399ba1920b9ba669098e142ce01fcc6c12d3d839dee5d2349324aec15cbb8f4b5243ccb8f30ea8396300ad555d7c2aaf58 SHA512 5f3eb2060794b10c4176490ae4f6cf8faf52e2a2a92c19de91a8146353e2d187e10355c995600a3beb3ca11257b6737a7c366ebaa7ae202d540f06584dea412b
MISC metadata.xml 445 BLAKE2B 66d2b1d256580432d05780ee9fa5cf06cf625328d8ab27dde762ea751e9bfd05072e7cf4741e63f40e9a5ffa2ecbcc8df7d30ca028113228d6639e1f408727cd SHA512 aad21bae4417b07c1313ec31d903dbf6d190704aa3f41f363320d97b67da81b4062195213cb4591059b679b2579a1d2a0c34c4c6befa0549a5eec1f7ea798f07
diff --git a/www-servers/gatling/gatling-0.16-r5.ebuild b/www-servers/gatling/gatling-0.16-r5.ebuild
new file mode 100644
index 000000000000..795c4d890c67
--- /dev/null
+++ b/www-servers/gatling/gatling-0.16-r5.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs
+
+DESCRIPTION="High performance web server"
+HOMEPAGE="https://www.fefe.de/gatling/"
+SRC_URI="https://www.fefe.de/gatling/${P}.tar.xz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="ssl diet"
+REQUIRED_USE="ssl? ( !diet )"
+
+DEPEND=">=dev-libs/libowfat-0.32-r2[diet=]
+ sys-libs/zlib
+ virtual/libcrypt:=
+ diet? ( dev-libs/dietlibc )
+ ssl? (
+ dev-libs/openssl:0=
+ )"
+RDEPEND="${DEPEND}
+ acct-group/gatling
+ acct-user/gatling
+ "
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.13-compile.patch"
+ "${FILESDIR}/${PN}-0.15-ar.patch"
+ "${FILESDIR}/${PN}-0.16-r4-0001-try-alloca-socket-fix-Wimplicit-int.patch"
+)
+
+src_prepare() {
+ default
+ rm Makefile # leaves us with GNUmakefile
+}
+
+src_compile() {
+ local DIET=
+ use diet && DIET='/usr/bin/diet'
+
+ local targets='gatling'
+ use ssl && targets+=' tlsgatling'
+
+ emake DIET="${DIET}" CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -I${ESYSROOT}/usr/include/libowfat" \
+ LDFLAGS="${LDFLAGS}" prefix=/usr ${targets}
+}
+
+src_install() {
+ doman gatling.1
+
+ newconfd "${FILESDIR}/gatling.confd" gatling
+ newinitd "${FILESDIR}/gatling.initd-3" gatling
+ dodoc README.{ftp,http}
+
+ dobin gatling
+ use ssl && {
+ dodoc README.tls
+ dobin tlsgatling
+ }
+}