summaryrefslogtreecommitdiff
path: root/www-servers
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-03 02:14:04 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-03 02:14:04 +0100
commit75abd8d3830449158bdd27f9c4701bcbadc55080 (patch)
tree70eef286ee181bdb3dde05ac97165f09da34e08e /www-servers
parentdd955a48d88d9b98d49a61f10ab4b52f53cf83a0 (diff)
gentoo auto-resync : 03:04:2024 - 02:14:03
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/Manifest.gzbin4697 -> 4702 bytes
-rw-r--r--www-servers/nginx-unit/Manifest2
-rw-r--r--www-servers/nginx-unit/nginx-unit-1.32.1.ebuild102
3 files changed, 104 insertions, 0 deletions
diff --git a/www-servers/Manifest.gz b/www-servers/Manifest.gz
index 05582580b22d..d00bdde4ddf9 100644
--- a/www-servers/Manifest.gz
+++ b/www-servers/Manifest.gz
Binary files differ
diff --git a/www-servers/nginx-unit/Manifest b/www-servers/nginx-unit/Manifest
index 6f6a74350b6e..f079a759d72d 100644
--- a/www-servers/nginx-unit/Manifest
+++ b/www-servers/nginx-unit/Manifest
@@ -2,5 +2,7 @@ AUX nginx-unit.confd 510 BLAKE2B 03cb328cbeef1baa1cf1590b11e8019efae98729ffd44fd
AUX nginx-unit.initd-r2 808 BLAKE2B efb9c3f33c5fd3070333ddb224ff0bcd4e7f8e1147b426193a006f3b880f547d168179199d8cbedcec2f0a0a517650c5ceeccf812170a9f85eef896f2940dab2 SHA512 408e7e73b74ce9371e78f2113617b4627b430b19ccb2881d310aa9a33b7e1fc7a30051e558fb524af42bcbed7a76da4a494b0b931839d614e83b9ffa0a3ea0b6
AUX nginx-unit.service 237 BLAKE2B 7e8b373372b7908bee80f4a57718a6b9ef7fd99872057006377284fb3bda088a0b6720b0246e5a27b6853d6351244432482f12afe5758b0f36dbdd1c04cce118 SHA512 fdf7ec12f58064c9a9fbd431fc4f56699563ff6bbf8124195810ca7a2e0ed813dbfdc41e6e1455b12960bd8d96fcf0eb2b632243d71d6a3b74d93a263c11596d
DIST nginx-unit-1.32.0.tar.gz 937300 BLAKE2B e603e76ed1d5838eed60675d922bc60a5c6d2bdb34eb98a2198a161c1743efc55c8f4249f4d734d1356089fc14c494d686b043ccedbd5c80b0a1a74d3bb03483 SHA512 52b1c8d6d07db927a4836e854a1372f27230b03ddb09bc8203c4c8433e8391e4bf35d62de3f37e91cde3680d19c183e3f871d5e22fba20343548946b44be466c
+DIST nginx-unit-1.32.1.tar.gz 937669 BLAKE2B ea3110dcc8ab95bc04fee891ade5fd19b069d6ef29da8c6aa6784fba87c9a8dd07ce0f4374b01696080097fd338839bd9819cded0461681673dadb4fa85b1207 SHA512 159b36f7afb8857188c9b64ee192e18d6990da3733caafcfb684b98e3f5182a7589ed2439f32af0cd3c763a3fa73f061f5a73ef01894182b1c12a4cd324c528a
EBUILD nginx-unit-1.32.0.ebuild 2298 BLAKE2B 9b3faf520ca8ea87663fa1bc14a96a28bd9f2650ea7fb81040fd4a456bf760de9bd23e590fdfe60d64d6be542d062787a516e21c5a33d3e6149916c3eebd5b0d SHA512 521ffbb0778013b1aa6790fd0f913da98da4452aa0c675a118875de9b2fc08f9acc4c709917e73634fcbb1b95aef0758db7f2bd027bad40df5477e4b9e9d2f43
+EBUILD nginx-unit-1.32.1.ebuild 2299 BLAKE2B 3c2750df2a3541463e07c54d90ca84cd0a881ca53fc04165e743734a70a16f06dfa8d74c177db261f6b19a69b8ecfb1860ccf30a19e5e9db2a8a50a597f5c597 SHA512 540c0ccedd3469ae0dbd7a2fce2d84ecc48a58c625aacbda0c14b0f8fdd7467acd43032e1dde8771ba87d3975b4b95e35c6a2dc3bc3d39960f6ee2ca9a19c50f
MISC metadata.xml 781 BLAKE2B f1ecaa8dee982424963fc9e13bc397a11926e7d10b89a0cec8b3c69b73ff877eac83e479d83dbbdcd4da97af5f664949f99e88c5fd195d13ffb7e9bdb41603d6 SHA512 b721b7b61e9033483dc81fd1cd8b2b836ad132b48089e9ab5c78c56bc8c44a11e8fd672d99cbd4ffd37f37226c0e795da4ee3e14996f972f5c74a50f9aef37ec
diff --git a/www-servers/nginx-unit/nginx-unit-1.32.1.ebuild b/www-servers/nginx-unit/nginx-unit-1.32.1.ebuild
new file mode 100644
index 000000000000..03dfb25af77e
--- /dev/null
+++ b/www-servers/nginx-unit/nginx-unit-1.32.1.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit flag-o-matic python-single-r1 systemd toolchain-funcs
+
+MY_P="unit-${PV}"
+DESCRIPTION="Dynamic web and application server"
+HOMEPAGE="https://unit.nginx.org"
+SRC_URI="https://unit.nginx.org/download/${MY_P}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+MY_USE="perl python ruby"
+MY_USE_PHP="php8-1 php8-2"
+IUSE="${MY_USE} ${MY_USE_PHP} perl ssl"
+REQUIRED_USE="|| ( ${IUSE} )
+ python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="perl? ( dev-lang/perl:= )
+ php8-1? ( dev-lang/php:8.1[embed] )
+ php8-2? ( dev-lang/php:8.2[embed] )
+ python? ( ${PYTHON_DEPS} )
+ ruby? (
+ dev-lang/ruby:=
+ dev-ruby/rubygems:=
+ )
+ ssl? ( dev-libs/openssl:0= )
+ virtual/libcrypt:0="
+RDEPEND="${DEPEND}
+ acct-user/nginx-unit
+ acct-group/nginx-unit"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ eapply_user
+ sed -i '/^CFLAGS/d' auto/make || die
+ default
+}
+
+src_configure() {
+ local opt=(
+ --control=unix:/run/${PN}.sock
+ --log=/var/log/${PN}
+ --modules=/usr/$(get_libdir)/${PN}
+ --pid=/run/${PN}.pid
+ --prefix=/usr
+ --state=/var/lib/${PN}
+ --user=${PN}
+ --group=${PN}
+ )
+
+ use ssl && opt+=( --openssl )
+ export AR="$(tc-getAR)"
+ export CC="$(tc-getCC)"
+ ./configure ${opt[@]} --ld-opt="${LDFLAGS}" || die "Core configuration failed"
+
+ # Modules require position-independent code
+ append-cflags $(test-flags-CC -fPIC)
+
+ for flag in ${MY_USE} ; do
+ if use ${flag} ; then
+ ./configure ${flag} || die "Module configuration failed: ${flag}"
+ fi
+ done
+
+ for flag in ${MY_USE_PHP} ; do
+ if use ${flag} ; then
+ local php_slot="/usr/$(get_libdir)/${flag/-/.}"
+ ./configure php \
+ --module=${flag} \
+ --config=${php_slot}/bin/php-config \
+ --lib-path=${php_slot}/$(get_libdir) || die "Module configuration failed: ${flag}"
+ fi
+ done
+}
+
+src_install() {
+ default
+
+ if use perl ; then
+ echo "1"
+ echo "D is ${D}"
+ emake DESTDIR="${D}/" perl-install
+ fi
+
+ rm -rf "${ED}"/usr/var
+
+ diropts -m 0770
+ keepdir /var/lib/${PN}
+ newinitd "${FILESDIR}/${PN}.initd-r2" ${PN}
+ newconfd "${FILESDIR}"/nginx-unit.confd nginx-unit
+ systemd_newunit "${FILESDIR}"/${PN}.service ${PN}.service
+}