summaryrefslogtreecommitdiff
path: root/www-servers
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-24 03:02:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-24 03:02:55 +0000
commit530a5a826feeb71085fb8a01927f4d775a0b131b (patch)
treeb7669c45ea3f2a3a37b2437817a370226bb1c819 /www-servers
parent71dd9d29cdaf7cc0ecdb9ea37d128726a941c630 (diff)
gentoo auto-resync : 24:11:2024 - 03:02:54
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/Manifest.gzbin4538 -> 4535 bytes
-rw-r--r--www-servers/puma/Manifest2
-rw-r--r--www-servers/puma/puma-6.5.0.ebuild82
3 files changed, 84 insertions, 0 deletions
diff --git a/www-servers/Manifest.gz b/www-servers/Manifest.gz
index bb931efd9c9d..920fa92f5b9f 100644
--- a/www-servers/Manifest.gz
+++ b/www-servers/Manifest.gz
Binary files differ
diff --git a/www-servers/puma/Manifest b/www-servers/puma/Manifest
index 4fa1c1c576d9..9c823b1d2822 100644
--- a/www-servers/puma/Manifest
+++ b/www-servers/puma/Manifest
@@ -1,3 +1,5 @@
DIST puma-6.4.3.tar.gz 388095 BLAKE2B 010009c5c87f4e5f28b6f2b12c65ba447e3d2e1444718df7631a191546096167676b1dab2611fc3aacd4b89a2ec873c0da6a58681b4884acc2dca0e3ec825268 SHA512 20e5800dd978dd681ed4e8dd10c2558d7d4c0cadf79ad25b7974997884cbc8797211761fb5db5303bf7a8e04907634ce9e82ad3e362ae1fff24cc7d770eb5e44
+DIST puma-6.5.0.tar.gz 402405 BLAKE2B f389674e9da7249491f8610137e23229d403c13420b2ce92a8be7d4caa1c100e4f5bd6de478f31b3f45c04e10e6b8c98af699f70e28945c3e609e53026ebd75e SHA512 6ce1e911a866bee69ad6e98919fe156be986aac8783da5dc3ce42b9abbdb6125fe5fd7fcf15f88a98825da7bcb773ccfd319bbd4be26fd608708379f9d406db8
EBUILD puma-6.4.3.ebuild 3078 BLAKE2B 56c94d6608c7503f7b96d9ea0799f0beeef2f42bf6aa511135d43e70c7590ae7e89166809e0d3eaef72a0630181c834ab61775d3faca22afcd0715170cd73d3d SHA512 f52d36d298644a209513ecbf2ced3254ddcd02e46bdcd67137abbcbba12c60af064d02abd1d27a2255a9ca206b82cec52118c71063c706e278d81cb2fb5e3350
+EBUILD puma-6.5.0.ebuild 2728 BLAKE2B 8b2cb18aba751a0231497f8afc8752ceb86e20e5ac1d4559085e28a94bb20226237d9fde9878b1597ad3f2aa881e3e212f8bed75ac3dea052989a6f20303fe3b SHA512 e731b577fa7f19d3c654e9a7882fed7cb1f76bb78fc47c4cc8d03f4c03581a358a1ff839493682e1e38c591969859b78f536b775ca6eb53fb982ede2e4bd4ca3
MISC metadata.xml 710 BLAKE2B bf109653812999e453fb414a83bf404786d16df301ba9dff87c123e0f1dbff8e3024109e96b7f36a3d9e1ebe57eb7aecc7acfd923f0de1bc8c4f358a87b32379 SHA512 894c677c61b3c7f8081b1511c64c274497c4ea85171f5b19d9606a19e4dff33df00d169653e3aede3eee07737b1cf9faadb812eebcf67292be68150c026b7f8e
diff --git a/www-servers/puma/puma-6.5.0.ebuild b/www-servers/puma/puma-6.5.0.ebuild
new file mode 100644
index 000000000000..6c9ad836c512
--- /dev/null
+++ b/www-servers/puma/puma-6.5.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_GEMSPEC="puma.gemspec"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/puma_http11/extconf.rb)
+RUBY_FAKEGEM_EXTENSION_LIBDIR=lib/puma
+
+inherit ruby-fakegem
+
+DESCRIPTION="a simple, fast, threaded, and highly concurrent HTTP 1.1 server for Ruby/Rack"
+HOMEPAGE="https://puma.io/"
+SRC_URI="https://github.com/puma/puma/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+DEPEND="dev-libs/openssl:0 test? ( net-misc/curl )"
+RDEPEND="dev-libs/openssl:0="
+
+ruby_add_bdepend "virtual/ruby-ssl
+ test? (
+ dev-ruby/concurrent-ruby
+ dev-ruby/localhost
+ dev-ruby/rack:3.0
+ dev-ruby/rackup
+ >=dev-ruby/minitest-5.9:5
+ >=dev-ruby/test-unit-3.0:2
+ )"
+
+ruby_add_rdepend "dev-ruby/nio4r:2"
+
+all_ruby_prepare() {
+ sed -e '/\(pride\|prove\|stub_const\)/ s:^:#:' \
+ -e '/require_relative.*verbose/ s:^:#:' \
+ -e '/securerandom/arequire "rack/handler"' \
+ -i test/helper.rb || die
+
+ # Avoid tests failing inconsistently
+ #sed -i -e '/test_bad_client/askip "inconsistent results"' test/test_web_server.rb || die
+
+ # Avoid tests depending on specific encoding
+ #sed -i -e '/test_lowlevel_error_handler_response/askip "specific encoding required"' test/test_puma_server.rb || die
+
+ # Avoid launcher tests since they make assumptions about bundler use
+ rm -f test/test_launcher.rb test/test_worker_gem_independence.rb test/test_bundle_pruner.rb || die
+ sed -e '/test_web_concurrency_with_concurrent_ruby_unavailable/askip "Cannot provide environment for this"' \
+ -i test/test_web_concurrency_auto.rb || die
+
+ # Skip integration tests since they make a lot of assumptions about
+ # the environment
+ rm -f test/test_integration_* test/test_preserve_bundler_env.rb|| die
+
+ # Avoid test that uses unpackaged stub_const
+ sed -i -e '/test_shutdown_with_grace/,/^ end/ s:^:#:' test/test_thread_pool.rb || die
+
+ # Avoid test that fails, most likely due to how we run the test suite
+ rm -f test/test_url_map.rb || die
+
+ # Avoid test that fails sometimes, possibly due to timing
+ # constraints or a race condition.
+ #sed -e '/test_systemd_notify_usr1_phased_restart_cluster/askip "Flaky test"' \
+ # -i test/test_plugin_systemd.rb || die
+
+ # Tries to call 'rackup' directly
+ sed -i -e '/def test_bin/,/^ end/ s:^:#:' test/test_rack_handler.rb || die
+
+ sed -e 's/git ls-files --/find/' \
+ -e 's:_relative ": "./:' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ einfo "Running test suite"
+ MT_NO_PLUGINS=true ${RUBY} -Ilib:.:test \
+ -e "require 'minitest/autorun'; Dir['test/**/*test_*.rb'].each{require _1}" || die
+}