summaryrefslogtreecommitdiff
path: root/www-servers/varnish
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-20 00:10:57 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-20 00:10:57 +0100
commitd6ca4e4f90cb75c323b5988eefa96a04c0d36908 (patch)
tree8197fc88451976470c871e991b75a9d40c240270 /www-servers/varnish
parente8df704cf9b5e9e517317b8912377c0a8ca0d11e (diff)
gentoo auto-resync : 20:06:2024 - 00:10:56
Diffstat (limited to 'www-servers/varnish')
-rw-r--r--www-servers/varnish/Manifest2
-rw-r--r--www-servers/varnish/varnish-7.5.0.ebuild111
2 files changed, 113 insertions, 0 deletions
diff --git a/www-servers/varnish/Manifest b/www-servers/varnish/Manifest
index 631bb1dd97d4..33a5f3161ddd 100644
--- a/www-servers/varnish/Manifest
+++ b/www-servers/varnish/Manifest
@@ -8,5 +8,7 @@ AUX varnishlog.initd 707 BLAKE2B 90e75e267a2ad8688ace41d4eff20e8601e0b20abc9b73e
AUX varnishncsa.confd 84 BLAKE2B fbb338ec2163562d7679a7371cda3cd297449186bfcaa668e3924d944dc78eae8d8bf5c60230202fee4093119ccc74d67ad8f3e6774091c6c2b5c9b184d4b5eb SHA512 a5426ff66b89d2afb6273f05e4117b3eec5ce0162a624d52c92b418960f72e58bd01224165613221af76ec241bd98e1eb985b2ef7b83a5b615e9ece67234dcc8
AUX varnishncsa.initd 716 BLAKE2B 33fd6b044ab50aef629fa4501eb4a78bd3d690db52b86a33d1d4e87c1da28088b9f25ce917d16a9ed777b1d6e1ece5a916af0c4ff293db82b94d264fd5baafa9 SHA512 1d0c781675ecba5adce02c37a02c431c4b44d64310a0945bff4f6f57f7d0c87cb7dda874311e44d667317d5beda113b62f4ba49c81534a0c078314b3fa15a512
DIST varnish-7.1.2.tgz 3758689 BLAKE2B a5c05d9dd7c5f0cd4dc0cae8cc365b658a15d017c7fb19cbe17088f009304375eb123f35935045c35c61ec3dfd7d8858774c2bbc918cc436415bd50b8894bb3b SHA512 e16a4b75ede25f3812dfc4e95545e39a80022835b9155a4e42118f911e41b691cbedd296db48d307ba4a4d0d01df1149306d752de07cabe459ccbf5bcdd49238
+DIST varnish-7.5.0.tgz 4033962 BLAKE2B c53500d1b95b4af1b43f3d2ffa5b12592bbd1e446f03d90a8147fe37c4d602af743369629f8a1423455a3c4de6867fb5fe19d6028fd1ea457d35622e85dcbc9c SHA512 ca77abcb21299942b2bfd433e5f964d2e974cdae92d6a8889217fcd81933a3b7bc1e70ba87d7e842a4f90b59d7948242155380054d67ad49aab8dcea343055a2
EBUILD varnish-7.1.2-r2.ebuild 2404 BLAKE2B 6777c80efc4ae1c65a16747aca2f057efc67e9c51b20703b8290a576784fe14beab81a8c849c3e99e411059785ab677ea6f5499c41bc9f5c125a958c76fc115a SHA512 470d4816739ff48bad51d07959f3dc5843f1e98f24ad4f251e3864822820a68d783e0bec5885dd84dc390f0d1d477f65720ffedd434f0abc7271137a76dd7c74
+EBUILD varnish-7.5.0.ebuild 2494 BLAKE2B cd6c2d400eb94b3143ef1536c939f3a46fa1dbd4cc87617cb353b383180e2a305899675fb47842cb3ec9b96464beca65c17d0618ddb3d70f1b4e2e31a1021871 SHA512 a6ac99902d3fb4761fed45230dd21199311c206cccfde2d2b6c42fc599b7162eed090bdc0747c99cfef8810f6b5bd328ec60f27f631dd6be24865d7c07642fa8
MISC metadata.xml 1161 BLAKE2B 994fcc5ff9cba689e7f7c8df067edd32159259032e58af1231466e0f9ed4a6a45a3d4cdd58cf79b89f2a72fcd99387934de20201d27aec86dadd2196dc07b249 SHA512 fd479350fa942242780e401a26a6c409fb2ec69cc69df1aee0fed31fa0ba8c2934b4c386eae5de33b470fb3ca23402b10d328feae39f215d4a1e634e4f22f827
diff --git a/www-servers/varnish/varnish-7.5.0.ebuild b/www-servers/varnish/varnish-7.5.0.ebuild
new file mode 100644
index 000000000000..d69f660e374f
--- /dev/null
+++ b/www-servers/varnish/varnish-7.5.0.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit autotools systemd python-r1
+
+DESCRIPTION="Varnish is a state-of-the-art, high-performance HTTP accelerator"
+HOMEPAGE="https://varnish-cache.org/"
+SRC_URI="http://varnish-cache.org/_downloads/${P}.tgz"
+
+LICENSE="BSD-2 GPL-2"
+SLOT="0/2"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv x86"
+# From Fedora:
+# Default: Use jemalloc, as adviced by upstream project
+IUSE="+jemalloc jit selinux static-libs unwind"
+
+CDEPEND="
+ sys-libs/readline:=
+ dev-libs/libedit
+ dev-libs/libpcre2[jit?]
+ sys-libs/ncurses:=
+ jemalloc? ( dev-libs/jemalloc:= )
+ unwind? ( sys-libs/libunwind:= )
+"
+
+# varnish compiles stuff at run time
+RDEPEND="
+ ${PYTHON_DEPS}
+ ${CDEPEND}
+ acct-user/varnish
+ acct-group/varnish
+ sys-devel/gcc
+ selinux? ( sec-policy/selinux-varnishd )
+"
+DEPEND="
+ ${CDEPEND}
+ dev-python/docutils
+ dev-python/sphinx
+ virtual/pkgconfig
+"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+PATCHES=( "${FILESDIR}/${PN}-7.1.2-disable-tests.patch" )
+
+src_prepare() {
+ default
+
+ # Remove -Werror bug #528354
+ sed -i -e 's/-Werror\([^=]\)/\1/g' configure.ac || die
+
+ # Upstream doesn't put varnish.m4 in the m4/ directory
+ # We link because the Makefiles look for the file in
+ # the original location
+ ln -sf ../varnish.m4 m4/varnish.m4 || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-contrib
+ $(use_enable static-libs static)
+ $(use_enable jit pcre2-jit)
+ $(use_with jemalloc)
+ $(use_with unwind)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ python_replicate_script "${D}/usr/share/varnish/vmodtool.py"
+
+ newinitd "${FILESDIR}"/varnishlog.initd varnishlog
+ newconfd "${FILESDIR}"/varnishlog.confd varnishlog
+
+ newinitd "${FILESDIR}"/varnishncsa.initd varnishncsa
+ newconfd "${FILESDIR}"/varnishncsa.confd varnishncsa
+
+ newinitd "${FILESDIR}"/varnishd.initd-r4 varnishd
+ newconfd "${FILESDIR}"/varnishd.confd-r4 varnishd
+
+ insinto /etc/logrotate.d/
+ newins "${FILESDIR}/varnishd.logrotate-r2" varnishd
+
+ diropts -m750
+
+ keepdir /var/lib/varnish
+ keepdir /var/log/varnish
+
+ systemd_dounit "${FILESDIR}/${PN}d.service"
+
+ insinto /etc/varnish/
+ doins vmod/vmod_*.vcc
+ doins etc/example.vcl
+
+ dodoc README.rst
+ dodoc doc/changes.rst
+
+ fowners root:varnish /etc/varnish/
+ fowners varnish:varnish /var/lib/varnish/
+ fperms 0750 /var/lib/varnish/ /etc/varnish/
+
+ find "${ED}" -name "*.la" -delete || die
+}