summaryrefslogtreecommitdiff
path: root/www-servers/thin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-23 12:45:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-23 12:45:14 +0000
commitc8c3804588db08dae281504dd79ef71741cd8dc3 (patch)
treec0dc730627dd25f276c533a00e6b763b8eef1f56 /www-servers/thin
parentdd5b71d2ad69f1887985ee1ca67b254e04157f73 (diff)
gentoo auto-resync : 23:03:2023 - 12:45:13
Diffstat (limited to 'www-servers/thin')
-rw-r--r--www-servers/thin/Manifest1
-rw-r--r--www-servers/thin/thin-1.8.1-r2.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/www-servers/thin/Manifest b/www-servers/thin/Manifest
index cee8e86af4de..0585a42102d4 100644
--- a/www-servers/thin/Manifest
+++ b/www-servers/thin/Manifest
@@ -2,5 +2,6 @@ AUX thin.confd-2 1335 BLAKE2B c6821353bbf2dd35d7161394247c4c3d88237c94f976a693ef
AUX thin.initd-r4 1841 BLAKE2B 4cdf853cb536011d582c729d3c48d7335cd3fa508c5281139220d624c204fae1460d4d1c0252d42ff3d277eaaaedfe1259e895335fcf9c8b9134d3f288f2ba44 SHA512 08d06627bf61737837af40fc4253afbecf753e3c74edacb038e59e66b95ef6bb56d55065e7d02d393ba2df45b93c9882788debdd4965404a8088c0e52ec98c0a
DIST thin-1.8.1.tar.gz 181377 BLAKE2B 883a35d60d5845defa1f20a85b90269838a1b1ebeb4d4f32561af061cdac05b545c254fe65cca828ccfed033ad934ad3b72f1795407734d3b377a6022b57397f SHA512 221ef0c0369c449f2ca121c435ffebed318d6179a3b5d52e24d2bd80212df9cac35db39d156275c915c24550f6d8ded9f29616785d0a38e85cd13a1702e31298
EBUILD thin-1.8.1-r1.ebuild 2544 BLAKE2B 0284d3d30f520faa73b85050a3414654ac9c4a85fec0853612b5086493be6de37a148dbbe8bead9ad8d08feccc15ce3c996d4088ead0568663922dcc5458f3a9 SHA512 e9df8e66a1f3469b41b01a4da780446d9edc463c0f169e1b8055b71102398946bb2e7c163dc9c182dc64c071982f27477f9003401eaf6ab719d867ebe134d24d
+EBUILD thin-1.8.1-r2.ebuild 2696 BLAKE2B dd1c423708dd9bb07c4f10904963d8b24a52ee4ec25f26ebbc5ef3814584ada872641217ff85d740cf67e4ff24ec9ca68bc055b8cc8e01b2bb046f196e22501a SHA512 6ccee535a74e4a52a283d956a91528072e52f63ddd4783162c8401c95839df5e98efa063fd15ae1a6f8930411d3bc08151f5121957e43aee3c485f2a9e1bf7a6
EBUILD thin-1.8.1.ebuild 2525 BLAKE2B a94a70719c1e60e9aaf9c0b70144060b030b3cf5c5ea783a806e8b363dbe6d92d3a5365991f058190e757ffb83b59fa198cae7e1b1fbb0443713252c628d7c31 SHA512 6a8182b208ef3acf96053f066ab57be871c0ccdc00957d15d01a2f1e7b6017e7ae1e973829ecf8719055728099cc3593ff6b1a871e8c9357cb1a096f318d3b57
MISC metadata.xml 610 BLAKE2B 8b633db16d80bc055f9e599b176dda37a854c615fcbbd399bf09b9dc26c08d207a170487b429351370b4b7160b1c5a3ba3ed1e582b282d07e05870805866a9e6 SHA512 af5acf36ba40b97581f13ec3fbb6b5519a4be59f3649d665df884847f14fb925bbff2c1480ef5a4c7b771b302927eb8a10350c7cb54e1d0c3e27ce7c7a31041a
diff --git a/www-servers/thin/thin-1.8.1-r2.ebuild b/www-servers/thin/thin-1.8.1-r2.ebuild
new file mode 100644
index 000000000000..e5383e716ea4
--- /dev/null
+++ b/www-servers/thin/thin-1.8.1-r2.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A fast and very simple Ruby web server"
+HOMEPAGE="http://code.macournoyer.com/thin/"
+SRC_URI="https://github.com/macournoyer/thin/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="doc test"
+
+DEPEND="${DEPEND}
+ dev-util/ragel"
+RDEPEND="${RDEPEND}"
+
+# The runtime dependencies are used at build-time as well since the
+# Rakefile loads thin!
+mydeps=">=dev-ruby/daemons-1.0.9
+ >=dev-ruby/rack-1.0.0:* <dev-ruby/rack-3:*
+ >=dev-ruby/eventmachine-1.0.4:0
+ virtual/ruby-ssl"
+
+ruby_add_rdepend "${mydeps}"
+ruby_add_bdepend "${mydeps}
+ dev-ruby/rake-compiler"
+
+all_ruby_prepare() {
+ # Fix Ragel-based parser generation (uses a *very* old syntax that
+ # is not supported in Gentoo)
+ sed -i -e 's: | rlgen-cd::' Rakefile || die
+
+ # Fix specs' dependencies so that the extension is not rebuilt
+ # when running tests
+ rm tasks/spec.rake || die
+
+ # Fix rspec version to allow newer 2.x versions
+ sed -i -e '/gem "rspec"/ s/1.2.9/3.0/ ; 2igem "rack", "<3"' spec/spec_helper.rb || die
+
+ # Avoid CLEAN since it may not be available and we don't need it.
+ sed -i -e '/CLEAN/ s:^:#:' tasks/*.rake || die
+
+ # Disable a test that is known for freezing the testsuite,
+ # reported upstream. In thin 1.5.1 this just fails.
+ sed -i \
+ -e '/should force kill process in pid file/,/^ end/ s:^:#:' \
+ spec/daemonizing_spec.rb || die
+
+ sed -i \
+ -e '/tracing routines (with NO custom logger)/,/^ end/ s:^:#:'\
+ spec/logging_spec.rb || die
+
+ find spec/perf -name "*_spec.rb" -exec \
+ sed -i '/be_faster_then/ i \ skip' {} \;
+
+ sed -i -e "s/Spec::Runner/Rspec/" spec/spec_helper.rb || die
+ # nasty but too complex to fix up for now :(
+ use doc || rm tasks/rdoc.rake
+}
+
+each_ruby_compile() {
+ ${RUBY} -S rake compile || die "rake compile failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ keepdir /etc/thin
+ newinitd "${FILESDIR}"/${PN}.initd-r4 ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd-2 ${PN}
+
+ einfo
+ elog "Thin is now shipped with init scripts."
+ elog "The default script (/etc/init.d/thin) will start all servers that have"
+ elog "configuration files in /etc/thin/. You can symlink the init script to"
+ elog "files of the format 'thin.SERVER' to be able to start individual servers."
+ elog "See /etc/conf.d/thin for more configuration options."
+ einfo
+}
+
+each_ruby_install() {
+ each_fakegem_install
+
+ # Ensure that newer rubygems version see the extention as installed
+ ruby_fakegem_extensions_installed
+}