summaryrefslogtreecommitdiff
path: root/www-servers/pshs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-02 15:59:12 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-02 15:59:12 +0000
commit06a7b5647e11a8ddf69b1c3d3ded6a8ba28b923e (patch)
tree8d58c1f4b049da677b33209b072f2b3057268fe0 /www-servers/pshs
parent99abbc5e5a6ecd3fc981b45646fd8cb5d320377b (diff)
gentoo resync : 02.03.2018
Diffstat (limited to 'www-servers/pshs')
-rw-r--r--www-servers/pshs/Manifest2
-rw-r--r--www-servers/pshs/pshs-0.3.3.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/www-servers/pshs/Manifest b/www-servers/pshs/Manifest
index bc7f4d1cd447..216eb1bc19d5 100644
--- a/www-servers/pshs/Manifest
+++ b/www-servers/pshs/Manifest
@@ -1,4 +1,6 @@
DIST pshs-0.3.2.tar.bz2 80103 BLAKE2B 884355e3cb621ce0367e3fe8f7697e68a5725e24fc4f5e977035cac1442eeecc1463cd5bccecc071d45250730a746c121d7b636a2b9db775e6ea174f1efb8406 SHA512 82eb0e0ff76ad6d5651b789ca59b654558562501f9f4b89a562773f5c60e80c6d43a86fca35a41a313952d8134b83fe6a11d1085c8c35cb9bbffd6d2a243964a
+DIST pshs-0.3.3.tar.bz2 81109 BLAKE2B c73aa8390257de4ffd616ecb08b570273075e72473a7e506a4ab4ca59a3ebf9f4c1467eabd1ef45b88d0d3422b14f55108c94d2e92222b186606b8b5cf8ab8c4 SHA512 c9c6dd854319153350a6e7ef245af8f89c0d50f783507211a34994d375f2ae442b22959e4a2fb1bcc02f976a8ff6f41545b176a32ea70174af0850cf1eaf77d9
EBUILD pshs-0.3.2.ebuild 971 BLAKE2B 47c6acca4b27e32b7af5a334a2b02d7a71acf7e0d01c7cf54f6c326141d9d4d2ebb6f0a046531daa9a109473bb7eba1743d9a4b7a061d8549cdb4cc7d14468fb SHA512 573eea1ae593f6d0a8429c683a2f54efb90276bedc1091ed38c4bcb02ca9ed62dd8876bd78626d9c8205251931251a238a4dad97d03d3c388e38672ffeb3f544
+EBUILD pshs-0.3.3.ebuild 981 BLAKE2B 7ba4628b45d41a11abe219f66513815f4882e89b9615075bfea8480a60cc5eb4739247614a51bd19188085ce985816da7aeb44879d72ebf99d4cba2817b78771 SHA512 ff647197f62dec1c3abadb4405f04724f1cab7569d5440e07122d0161bbcde624635624540fc19140f9a70f4b29621ce002fd9fc38457b300e6cf7076902bfd5
EBUILD pshs-9999.ebuild 1011 BLAKE2B 6b9807aabc60e93373dc2e38b15aa6877df3a42ae9791f4a6f3a92eaa0db0a618c6dd299865bb035e302b7e1a457b578ddf978240e44d4443a30e5744b4f4ea8 SHA512 831f63979c59d8aefa9d1b41f98e4eded021b437f1607218c34143687f22668dbd7dd7435bb2688d128699712ed9b5fa2e30536511dd4da9d39ab7b43d9f4b5f
MISC metadata.xml 812 BLAKE2B 22683da13714799f768dbbf0e941ef96434d78566d3b7ee136d88214b360ef2c1d15dd4357238103bfeccc559e99e342ff3b61c3241563d816671844f2e4c23d SHA512 9e58734863a46f1f6d8d4b0c2666fc0d596d45d924a60fc5a19a173018e3ca881c20862a3e879a63b9ccfab6dc6018ba122b3537e408336db26672b02374cdb2
diff --git a/www-servers/pshs/pshs-0.3.3.ebuild b/www-servers/pshs/pshs-0.3.3.ebuild
new file mode 100644
index 000000000000..cafb509f3846
--- /dev/null
+++ b/www-servers/pshs/pshs-0.3.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Pretty small HTTP server -- a command-line tool to share files"
+HOMEPAGE="https://github.com/mgorny/pshs/"
+SRC_URI="https://github.com/mgorny/${PN}/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl +magic +netlink qrcode ssl upnp"
+
+RDEPEND=">=dev-libs/libevent-2:0=
+ magic? ( sys-apps/file:0= )
+ qrcode? ( media-gfx/qrencode:0= )
+ ssl? ( >=dev-libs/libevent-2.1:0=[ssl]
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+ upnp? ( net-libs/miniupnpc:0= )"
+DEPEND="${RDEPEND}
+ netlink? ( sys-apps/iproute2[-minimal]
+ >=sys-kernel/linux-headers-2.6.27 )"
+# libnetlink is static only ATM
+
+src_configure() {
+ local myconf=(
+ $(use_enable magic libmagic)
+ $(use_enable netlink)
+ $(use_enable qrcode qrencode)
+ $(use_enable ssl)
+ $(use_enable upnp)
+ )
+
+ econf "${myconf[@]}"
+}