summaryrefslogtreecommitdiff
path: root/www-servers/nginx-unit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-21 19:11:44 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-21 19:11:44 +0100
commit47af801ff0ee4a4207b36e6917b1e496354940c0 (patch)
tree9420c678c469e86a72a75a5d89efaaa9208cb054 /www-servers/nginx-unit
parent6c7cfcb5a1624b262a84846285c2545c688af1a6 (diff)
gentoo resync : 21.07.2018
Diffstat (limited to 'www-servers/nginx-unit')
-rw-r--r--www-servers/nginx-unit/Manifest4
-rwxr-xr-xwww-servers/nginx-unit/files/nginx-unit.initd14
-rw-r--r--www-servers/nginx-unit/metadata.xml22
-rw-r--r--www-servers/nginx-unit/nginx-unit-1.3.ebuild39
4 files changed, 79 insertions, 0 deletions
diff --git a/www-servers/nginx-unit/Manifest b/www-servers/nginx-unit/Manifest
new file mode 100644
index 000000000000..b6756bb084f9
--- /dev/null
+++ b/www-servers/nginx-unit/Manifest
@@ -0,0 +1,4 @@
+AUX nginx-unit.initd 291 BLAKE2B a4ce1b0269de3d991bfdf30b6183418d32e2c94d21ca0ab154b9f44521895227057cad1fd2ca72015a4c25c90250cc31a6aa2f637caaa564eee7769a48b4d355 SHA512 89db5f2116d11ff8e741b23e41692585ee7e2446fb6d214666af913a1fec9a2f6d300512cb8d3b6a83795e714d6f17403e22dc12fd9c76b0551c14b71b6fd998
+DIST nginx-unit-1.3.tar.gz 401670 BLAKE2B 34a0ed9631c7061d1c71f8335103b0e266ef6f949afeb8cef283a7b5dd6c9f0a4835f20fdedd091af6950cd0897cb1ab48dea9f475e1b75a2872da7ac0090d10 SHA512 63a47b920bfdae7a7e034d616f520b27b46151a299cf5854373f7f8472043de0ffc98f9d62317c46e637857e0ef24668ded99be6e058315acf25b4e1c7f1ed09
+EBUILD nginx-unit-1.3.ebuild 937 BLAKE2B 09d8c3e3e8e0d0737f94bb1b483479fdce591f3a60a8ac5dab65d94e361e04b6bc1099f6c78432af93469c21c995a0bbde85d916c143ccf92ed0124d3e835913 SHA512 498a05d21d8593c0d640fadabee04245dc7c2c49050c314a1366ae4edd52a268b6a5745aa9d7eecbd0383706cac6c02b7838e0c517206b55b6ddeed849cb9340
+MISC metadata.xml 787 BLAKE2B a88efd7d7a5fe988156edf4775a7d5aca875957d507ae2e95a014b6f1bbbea7c9d66e2081525c3a495bcc88e8541d8d7e3a09bf5426847065c488920c442ed3e SHA512 793dc1852eb308056c81240a596302d647ccf96aae0f2585dc0e68e2cd4dd9444dbb9e65454c640e78377d83a9261dcb343a0082f0cefcfb4f9b5d1259ade15f
diff --git a/www-servers/nginx-unit/files/nginx-unit.initd b/www-servers/nginx-unit/files/nginx-unit.initd
new file mode 100755
index 000000000000..23720abcc1e1
--- /dev/null
+++ b/www-servers/nginx-unit/files/nginx-unit.initd
@@ -0,0 +1,14 @@
+#!/sbin/openrc-run
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+command="/usr/sbin/unitd"
+pidfile="/run/nginx-unit.pid"
+
+depend() {
+ use dns logger netmount
+}
+
+start_pre() {
+ checkpath -d /var/lib/nginx-unit -o root:root 0770
+}
diff --git a/www-servers/nginx-unit/metadata.xml b/www-servers/nginx-unit/metadata.xml
new file mode 100644
index 000000000000..7660440b3f51
--- /dev/null
+++ b/www-servers/nginx-unit/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@seichter.de</email>
+ <name>Ralph Seichter</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ NGINX Unit is a dynamic web and application server, designed to run
+ applications in multiple languages. Unit is lightweight, polyglot, and
+ dynamically configured via API. The design of the server allows
+ reconfiguration of specific application parameters as needed by the
+ engineering or operations.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">nginx/unit</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/www-servers/nginx-unit/nginx-unit-1.3.ebuild b/www-servers/nginx-unit/nginx-unit-1.3.ebuild
new file mode 100644
index 000000000000..da3e472ba88a
--- /dev/null
+++ b/www-servers/nginx-unit/nginx-unit-1.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A dynamic web and application server"
+HOMEPAGE="https://unit.nginx.org"
+SRC_URI="https://unit.nginx.org/download/unit-${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="perl python"
+REQUIRED_USE="|| ( ${IUSE} )"
+DEPEND="perl? ( dev-lang/perl:= )
+ python? ( dev-lang/python:= )"
+RDEPEND="${DEPEND}"
+S="${WORKDIR}/unit-${PV}"
+
+src_configure() {
+ ./configure \
+ --prefix=/usr \
+ --log=/var/log/${PN} \
+ --state=/var/lib/${PN} \
+ --pid=/run/${PN}.pid \
+ --control=unix:/run/${PN}.sock || die "Core configuration failed"
+ for flag in ${IUSE} ; do
+ if use ${flag} ; then
+ ./configure ${flag} || die "Module configuration failed: ${flag}"
+ fi
+ done
+}
+
+src_install() {
+ default
+ keepdir /var/lib/${PN}
+ fperms 0770 /var/lib/${PN}
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+}