summaryrefslogtreecommitdiff
path: root/www-servers/civetweb
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-11-15 17:13:45 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-11-15 17:13:45 +0000
commite2d84e38284aeb9d522a7e935554340ddf0e4a6f (patch)
tree5a7444ee5f2af59431481999f729676090b1e0f3 /www-servers/civetweb
parent519e4d5d99fc43d5c9a038098c029dc4ef9d6792 (diff)
gentoo resync : 15.11.2017
Diffstat (limited to 'www-servers/civetweb')
-rw-r--r--www-servers/civetweb/Manifest3
-rw-r--r--www-servers/civetweb/civetweb-1.10.ebuild36
-rw-r--r--www-servers/civetweb/metadata.xml10
3 files changed, 49 insertions, 0 deletions
diff --git a/www-servers/civetweb/Manifest b/www-servers/civetweb/Manifest
new file mode 100644
index 000000000000..b332d3f5199a
--- /dev/null
+++ b/www-servers/civetweb/Manifest
@@ -0,0 +1,3 @@
+DIST civetweb-1.10.tar.gz 11350512 SHA256 e6958f005aa01b02645bd3ff9760dd085e83d30530cdd97b584632419195bea5 SHA512 54035883fbec590f339a2b4b5bf1b9a93591ea50bff056830d0c45b874cf6e46ce5af39e9dd9d4e0e6c82bec844aa0f159503f337998e9e10e59099b8ecc3f79 WHIRLPOOL 3a2b45f36188612215b4fb2d1d85aa8e88677399f2065c19ef9c903a011434d44f47b1115862b2d7b4bda471feb6427879a454b5c1032ed28754afee1fd7c55e
+EBUILD civetweb-1.10.ebuild 786 SHA256 0ea68e75184e374443695a30af6efd105db32fae2ee6bfc18a3f585afb0ca8f2 SHA512 9a0d2c27b48274e511279c79227e228f6735b6390a61c6ebdbce3f56a09b08bac100b3c4161ab5939a42abacae9690ec9d9ab27c88828b49dd91ac55133d632b WHIRLPOOL f6f984b28aa272b547b01ffc34a24b6895793af7d77a894cebc7edaa8c304d7560e1afc229b907cb6f471fc031e9e5b72b20bb1dfb3926090e2f92d3528d8873
+MISC metadata.xml 300 SHA256 5f41a148907677ed450da1e1581e5bad7aaf1e002970fe71efe51afea8756dbf SHA512 9f3731d440b9cd7e045bba6f8053e719f40ce945d4e534bfcc1fdc6421f888c070a0496690c0397377f80296b49f3c789ae09c2ae9e9037cbc552a83d6b2930a WHIRLPOOL 3eabd8cab1aca5114fe5b72280e846165d2437b603a5d757b3dbd9804f9dce953033dbae563b21b89a3b01053ec9043a8c9ca699bc47e92f7ce983b4b0e5903f
diff --git a/www-servers/civetweb/civetweb-1.10.ebuild b/www-servers/civetweb/civetweb-1.10.ebuild
new file mode 100644
index 000000000000..62190ba870ba
--- /dev/null
+++ b/www-servers/civetweb/civetweb-1.10.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+HOMEPAGE="https://github.com/civetweb/civetweb/"
+DESCRIPTION="Embedded C/C++ web server"
+SRC_URI="https://github.com/civetweb/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ssl"
+
+RDEPEND="ssl? ( dev-libs/openssl:0= )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -e 's|DESTINATION lib$|DESTINATION ${CMAKE_INSTALL_LIBDIR}|' \
+ -i src/CMakeLists.txt || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=OFF
+ -DBUILD_SHARED_LIBS=ON
+ -DCIVETWEB_ENABLE_LUA=OFF
+ -DCIVETWEB_ENABLE_DUKTAPE=OFF
+ -DCIVETWEB_ENABLE_SSL="$(usex ssl)"
+ )
+
+ cmake-utils_src_configure
+}
diff --git a/www-servers/civetweb/metadata.xml b/www-servers/civetweb/metadata.xml
new file mode 100644
index 000000000000..da48c00830a1
--- /dev/null
+++ b/www-servers/civetweb/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="github">civetweb/civetweb</remote-id>
+ </upstream>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>