summaryrefslogtreecommitdiff
path: root/www-servers/civetweb/civetweb-1.16.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-30 23:18:22 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-30 23:18:22 +0100
commit36f117bb6eda5dab3ecc30577395d0279ed3f8f5 (patch)
treef13c93862d98a9d54ca0985d38f5f64bcd6f0547 /www-servers/civetweb/civetweb-1.16.ebuild
parentce23b28e3d5f58b4177dfa6006db905a41dd87ee (diff)
gentoo auto-resync : 30:04:2023 - 23:18:21
Diffstat (limited to 'www-servers/civetweb/civetweb-1.16.ebuild')
-rw-r--r--www-servers/civetweb/civetweb-1.16.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/www-servers/civetweb/civetweb-1.16.ebuild b/www-servers/civetweb/civetweb-1.16.ebuild
new file mode 100644
index 000000000000..83bd33185971
--- /dev/null
+++ b/www-servers/civetweb/civetweb-1.16.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+HOMEPAGE="https://github.com/civetweb/civetweb/"
+DESCRIPTION="Embedded C/C++ web server"
+SRC_URI="https://github.com/civetweb/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="cxx +server ssl"
+
+DEPEND="ssl? ( dev-libs/openssl:0= )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=OFF
+ -DBUILD_SHARED_LIBS=ON
+ -DCIVETWEB_BUILD_TESTING=OFF
+ -DCIVETWEB_ENABLE_LUA=OFF
+ -DCIVETWEB_ENABLE_DUKTAPE=OFF
+ -DCIVETWEB_ENABLE_WEBSOCKETS=ON
+ -DCIVETWEB_ENABLE_CXX="$(usex cxx)"
+ -DCIVETWEB_ENABLE_SERVER_EXECUTABLE="$(usex server)"
+ -DCIVETWEB_ENABLE_SSL="$(usex ssl)"
+ )
+
+ cmake_src_configure
+}