summaryrefslogtreecommitdiff
path: root/www-plugins
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
commit129160ec854dca4c3fedb5bcfbcb56930371da0f (patch)
tree53bf797418ac5e9b99c41ca0382c87b82421e5de /www-plugins
parent441d1370330332b7d78f238d2f5e13f7aed5e4e0 (diff)
gentoo new year resync : 01.01.2021
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/Manifest.gzbin1422 -> 1421 bytes
-rw-r--r--www-plugins/lightspark/Manifest2
-rw-r--r--www-plugins/lightspark/lightspark-0.8.3.ebuild95
3 files changed, 97 insertions, 0 deletions
diff --git a/www-plugins/Manifest.gz b/www-plugins/Manifest.gz
index 67cf4bebf65e..ca2d98847362 100644
--- a/www-plugins/Manifest.gz
+++ b/www-plugins/Manifest.gz
Binary files differ
diff --git a/www-plugins/lightspark/Manifest b/www-plugins/lightspark/Manifest
index efef82bcffea..d58eaa2a0f5d 100644
--- a/www-plugins/lightspark/Manifest
+++ b/www-plugins/lightspark/Manifest
@@ -1,3 +1,5 @@
DIST lightspark-0.8.2.tar.gz 1996482 BLAKE2B 09ef5f4bc4e78efe8c8ddb305e0c47091ba5b27c9b3bb2dd782079bc05a4836d43a80b47d1c30eba424b5d43a724502235a60c08451df4c8526b15a32274dbb4 SHA512 0ff636ad59523726232d9c2105843dc9ea835526c300bca7833e6d1a0ebf7630c1d10109143baabc16f95c1c954094603c945b705a6c9fb02f369e94fead034e
+DIST lightspark-0.8.3.tar.gz 2374990 BLAKE2B 3053ca1ce8a8c0b7e243d28c038b237647e86f72a0d4e171da338384e4228587aba21f141fe0656ebe8243343284afcd311d7ced22cb09f95538e2f618edfefc SHA512 023d1872577445a857c77908bc2ec83ebfa086bc77161dfd22b53fc0c38eb5d94cd5bb5c5a7508dee2039d3b8479c917dcee089fe551a984ec5525a5ae781997
EBUILD lightspark-0.8.2-r1.ebuild 2553 BLAKE2B 52445e714973731a9564d13dd00bc6380a6d342231f8bd6e4c84fea5af9b63ca9e7d95b1ec2fedf8ed441c4ac71d5bd9dcf4dff3a324f8ea942fa185fabb47c0 SHA512 f613c52de3c45db9af125cf90937ed1b0e1c5e993f66778a22704f7e546b138de13fc34388868554af96e474749829588fb11ff58d7a55533fd1a5439b5547ff
+EBUILD lightspark-0.8.3.ebuild 2541 BLAKE2B 468dfd3a653d10bd4192c364f64a3a901f7dba7e7d7e142eae95e5c278079dde15dde8b9bdc420b504b50937c9b7bad895415dcfa9d33368e2b993b31ccd012b SHA512 27628b4e45bebd60f3ce1d0a5b219500b716fadc7224b442e05ef254136a3f7488010468c9cbef0401d56531a6d9ee6c8b1a189ac596d47c9c7deee1b1fecd29
MISC metadata.xml 728 BLAKE2B c6a146e670ee88ef726ea394db7572b0ce014be4e33e0a1bcad4bae1fe7083fa9ce41f4c2817a3b7c09a43b8da4738d011f082292e1f38fa67f2ed5e078889fc SHA512 a18594a062a2014f0353d0caa72def28333ff34f8e211cd42f8dc9a192b0173a203ee16605e9bedbbac0989a72f64b88584a4e9e6c28d197fcbc83e296c46af5
diff --git a/www-plugins/lightspark/lightspark-0.8.3.ebuild b/www-plugins/lightspark/lightspark-0.8.3.ebuild
new file mode 100644
index 000000000000..fb319cbbb5a9
--- /dev/null
+++ b/www-plugins/lightspark/lightspark-0.8.3.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit cmake toolchain-funcs xdg-utils
+
+DESCRIPTION="High performance flash player"
+HOMEPAGE="https://lightspark.github.io/"
+SRC_URI="
+ https://github.com/lightspark/lightspark/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+S=${WORKDIR}/${P/_rc*/}
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cpu_flags_x86_sse2 curl ffmpeg gles2-only nsplugin ppapi profile rtmp"
+
+# Note: no LLVM since it's broken upstream
+RDEPEND="app-arch/xz-utils:0=
+ dev-cpp/glibmm:2=
+ dev-libs/glib:2=
+ dev-libs/libpcre:3=[cxx]
+ media-fonts/liberation-fonts
+ media-libs/freetype:2=
+ media-libs/libpng:0=
+ media-libs/libsdl2:0=
+ media-libs/sdl2-mixer:0=
+ sys-libs/zlib:0=
+ x11-libs/cairo:0=
+ x11-libs/libX11:0=
+ x11-libs/pango:0=
+ virtual/jpeg:0=
+ curl? ( net-misc/curl:0= )
+ ffmpeg? ( media-video/ffmpeg:0= )
+ gles2-only? ( media-libs/mesa:0=[gles2] )
+ !gles2-only? (
+ >=media-libs/glew-1.5.3:0=
+ virtual/opengl:0=
+ )
+ rtmp? ( media-video/rtmpdump:0= )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ amd64? ( dev-lang/nasm )
+ x86? ( dev-lang/nasm )
+ virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_CURL=$(usex curl)
+ -DENABLE_GLES2=$(usex gles2-only)
+ -DENABLE_LIBAVCODEC=$(usex ffmpeg)
+ -DENABLE_RTMP=$(usex rtmp)
+
+ -DENABLE_MEMORY_USAGE_PROFILING=$(usex profile)
+ -DENABLE_PROFILING=$(usex profile)
+ -DENABLE_SSE2=$(usex cpu_flags_x86_sse2)
+
+ -DCOMPILE_NPAPI_PLUGIN=$(usex nsplugin)
+ -DPLUGIN_DIRECTORY="${EPREFIX}"/usr/$(get_libdir)/${PN}/plugins
+ # TODO: install /etc/chromium file? block adobe-flash?
+ -DCOMPILE_PPAPI_PLUGIN=$(usex ppapi)
+ -DPPAPI_PLUGIN_DIRECTORY="${EPREFIX}"/usr/$(get_libdir)/chromium-browser/${PN}
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ if use nsplugin; then
+ # copied from nsplugins.eclass, that's broken in EAPI 7
+ dodir /usr/$(get_libdir)/nsbrowser/plugins
+ dosym ../../lightspark/plugins/liblightsparkplugin.so \
+ /usr/$(get_libdir)/nsbrowser/plugins/liblightsparkplugin.so
+ fi
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+
+ if use nsplugin && has_version "www-plugins/gnash[nsplugin]"; then
+ elog "Having two plugins installed for the same MIME type may confuse"
+ elog "Mozilla based browsers. It is recommended to disable the nsplugin"
+ elog "USE flag for either gnash or lightspark. For details, see"
+ elog "https://bugzilla.mozilla.org/show_bug.cgi?id=581848"
+ fi
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}