summaryrefslogtreecommitdiff
path: root/www-plugins/passff-host
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
commit46eedbedafdb0040c37884982d4c775ce277fb7b (patch)
treedb33a91259730be84999e13a8d8168c799f50ac0 /www-plugins/passff-host
parente23a08d0c97a0cc415aaa165da840b056f93c997 (diff)
gentoo resync : 20.10.2021
Diffstat (limited to 'www-plugins/passff-host')
-rw-r--r--www-plugins/passff-host/Manifest3
-rw-r--r--www-plugins/passff-host/passff-host-1.2.2.ebuild59
2 files changed, 62 insertions, 0 deletions
diff --git a/www-plugins/passff-host/Manifest b/www-plugins/passff-host/Manifest
index 5d0a10a96c67..1a243cc15e07 100644
--- a/www-plugins/passff-host/Manifest
+++ b/www-plugins/passff-host/Manifest
@@ -1,4 +1,7 @@
DIST passff-host-1.2.1.json 176 BLAKE2B 8eddc19cd0c072d25afff5cfa86a95d960ae7b986727099a04a1d983b887922f9ad77e940a2c80e0838a169afe81fa3f6529a901998bb98a6750ac888a09c264 SHA512 e4a4b90fb5323c6dbec339b9e67a7d546c6d7a95754fe03b3a4d96396c28de1caba3068b4e936ee0ce0997f865c8b5e53a3da1fb34f0123a04c5889302c28911
DIST passff-host-1.2.1.py 3666 BLAKE2B 6a95defc3b1abe91f95e83ab20e9d0e533da2ae0e2153d2b50abf0a77aeb426b6b0a0ed042c00912a434dadbf53a9091fa772df9b9f5c330982a9ab49b891bc8 SHA512 5fe848fe0d6a75b679ee18fd5d32fda963853b91ad382fc19780104d44d1052a7191188946af470722dab883f0318ec38980fc24f052aeb5c54cac98f810ee15
+DIST passff-host-1.2.2.json 176 BLAKE2B 8eddc19cd0c072d25afff5cfa86a95d960ae7b986727099a04a1d983b887922f9ad77e940a2c80e0838a169afe81fa3f6529a901998bb98a6750ac888a09c264 SHA512 e4a4b90fb5323c6dbec339b9e67a7d546c6d7a95754fe03b3a4d96396c28de1caba3068b4e936ee0ce0997f865c8b5e53a3da1fb34f0123a04c5889302c28911
+DIST passff-host-1.2.2.py 3691 BLAKE2B 3fb64c6ca0d512d61f7bd3884ff5714f5a1b93095ab1c99043645d8253b5128d3d054faec6bff0f560f536b10ffa1cd523dc440b19d90cfff3bac6009f0ce86e SHA512 407be35359e987f355f04a45bf8a0c1023ee04d3c6d7c4ea9cce29955957cd514302ca04aeda4367e8560e8d765159b5fddad2e51ea089f9eb2947564605b5cf
EBUILD passff-host-1.2.1-r1.ebuild 1544 BLAKE2B 4669eb2223577b008c42c9d1018b5b4f4a623368843eaccb9c2abbb35a469277c8d8c5149164a636f20780adbc1446d9c8dee177fc1489df4cb4238966d06e8b SHA512 f5eeeb0beccb6cad2163f66230175afca1c4f322ecff2c68f39674572564bb947cdb820a286ae14d302462f36aaef34c3ab87bb1f5e67d8e76b88e78cf5c0ba4
+EBUILD passff-host-1.2.2.ebuild 1544 BLAKE2B 4669eb2223577b008c42c9d1018b5b4f4a623368843eaccb9c2abbb35a469277c8d8c5149164a636f20780adbc1446d9c8dee177fc1489df4cb4238966d06e8b SHA512 f5eeeb0beccb6cad2163f66230175afca1c4f322ecff2c68f39674572564bb947cdb820a286ae14d302462f36aaef34c3ab87bb1f5e67d8e76b88e78cf5c0ba4
MISC metadata.xml 606 BLAKE2B a5d49f8a42512b029523ca6a6bd7381de2c8d55bba920eecb63b76936edd6a1821f3a89665e9e5aa934c94a4ec14d4ac6751f4e3085b9b953e0b02ef801e3329 SHA512 13da163e895654c551434f0765cb55e45209af882e822cbcf6a664fb6ce88b4ae8f64cf832c38a6e2827b0d0cccd945059196c7b8fff125ce25e3f0b6e283eb5
diff --git a/www-plugins/passff-host/passff-host-1.2.2.ebuild b/www-plugins/passff-host/passff-host-1.2.2.ebuild
new file mode 100644
index 000000000000..df908c998abd
--- /dev/null
+++ b/www-plugins/passff-host/passff-host-1.2.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 2018-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit python-single-r1
+
+DESCRIPTION="Host app for the PassFF WebExtension"
+HOMEPAGE="https://github.com/passff/passff-host"
+
+SRC_URI="
+ https://github.com/passff/passff-host/releases/download/${PV}/passff.py -> ${P}.py
+ https://github.com/passff/passff-host/releases/download/${PV}/passff.json -> ${P}.json
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="chrome chromium +firefox vivaldi"
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ || ( chrome chromium firefox vivaldi )
+"
+
+RDEPEND="${PYTHON_DEPS}"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp "${DISTDIR}/${P}.json" . || die
+ cp "${DISTDIR}/${P}.py" . || die
+}
+
+src_prepare() {
+ default
+ python_fix_shebang "${P}.py"
+}
+
+src_install() {
+ local target_dirs=()
+
+ use chrome && target_dirs+=( "/etc/opt/chrome/native-messaging-hosts" )
+ use chromium && target_dirs+=( "/etc/chromium/native-messaging-hosts" )
+ use firefox && target_dirs+=( "/usr/$(get_libdir)/mozilla/native-messaging-hosts" )
+ # www-client/firefox-bin compile-time dir is under /usr/lib/
+ use firefox && target_dirs+=( "/usr/lib/mozilla/native-messaging-hosts" )
+ use vivaldi && target_dirs+=( "/etc/vivaldi/native-messaging-hosts" )
+
+ for target_dir in "${target_dirs[@]}"; do
+ sed "s;PLACEHOLDER;${target_dir}/passff.py;g" "${P}.json" > "passff.json" || die
+
+ insinto "${target_dir}"
+ doins passff.json
+ exeinto "${target_dir}"
+ newexe "${P}.py" passff.py
+ done
+}