summaryrefslogtreecommitdiff
path: root/www-plugins/lightspark
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-29 20:19:23 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-29 20:19:23 +0100
commit12bb627384ddfd47382b9f1b6464481a58d01ebb (patch)
treef9760c04ccd4fcd7de214e2acd5b0e43fb530aa9 /www-plugins/lightspark
parent5fdd950c7ae03e12746a45c86d85861beaacc846 (diff)
gentoo resync : 29.08.2018
Diffstat (limited to 'www-plugins/lightspark')
-rw-r--r--www-plugins/lightspark/Manifest2
-rw-r--r--www-plugins/lightspark/lightspark-0.8.1.ebuild97
2 files changed, 99 insertions, 0 deletions
diff --git a/www-plugins/lightspark/Manifest b/www-plugins/lightspark/Manifest
index cc5f191c7cd3..49105d917f0e 100644
--- a/www-plugins/lightspark/Manifest
+++ b/www-plugins/lightspark/Manifest
@@ -1,4 +1,6 @@
+DIST lightspark-0.8.1.tar.gz 1899466 BLAKE2B d057deccc8ee03f16bfd384c9aee94ee70b7f6674bb0d46c2965f27868a2177c2985f791801975aab1608b4e59d9d40a51e327ec4b00e60eb6714f610b4c319f SHA512 ee9f02e4aa160d8e68cab743eddce5f4f5de0bb78f5daaaf69890b442701dc42094a59433cef136f6dc85e6fbce989bc8ff7ce8ad1ed1929c8501b13e24f2646
DIST lightspark-f6ed8284810ad91c277ed5d0835b215e7329450e.tar.gz 1880249 BLAKE2B 031dc48f40956fcfb5a8b0fd825da8a2a0dba6daa4646296a385d5f90f13027d44cbb09562f6bf57b8d5d415a278fa06974624aee42e14b75892c36798dceda0 SHA512 a75ebf5e666daec0f244285bfd1029feb6fcfa2aeba800f175bb07bc148d39e76435d77868c964b2e149019b763498990bf0db25ba632cf21b91ad0958412332
EBUILD lightspark-0.8.0_p20180401.ebuild 2732 BLAKE2B 08a5b4fc6846543722b269f8d16ace29eac1c282f3872ebd5c00fcbaf0c81130906990a39073d014c537edfec2b239414d59218684f3b1fb29af2fb0c9b4ed1f SHA512 6a3ee2e83cdf4f7396b8e1b760093b84f3f1f0ee1dbebc2d8ddf2c07576a50f714347c574f0b2dc138e2fb474eb1af39878667100afba427177bb54ebc97ba3c
+EBUILD lightspark-0.8.1.ebuild 2708 BLAKE2B 9f428a1a4028d3880775974a92faa3cafdc235df08e05bc3112df5e5a175f2b003c142df9ccd5cff06d316554aae1bc9dcc2b6b6dcc524e744ff63fead269b93 SHA512 a7b510a5d07f6a10d39146dbb3ad72261a4ba691ab0da1b3321e4ad5e9345bf135dacc3c4021bd3b120c407f4586cf95ddcaa62f5b32f22e7a8305677e207017
EBUILD lightspark-9999.ebuild 2619 BLAKE2B c90492a4d9bbda5c878548940ad9dac2fad26e3a129e07f68347c3cfc63f32cd76278f034208deb6b6d1fffd6f106562eaae2780c92b74961166154cbf854610 SHA512 1405ff1546e69903eb7e602c409209b3916c4c71019a512848fd224ea1de0fc8c256c557bda77ce67d2a573ebf60c1e79bc2183e4e7c991ab85a2b213a849576
MISC metadata.xml 799 BLAKE2B 1bfc24a5d49f8996b6b9c5375af9f1ac838f720ee57e6056b7f2ac3d7a0f92a1abfdfb6e94f87024bb615a1a483c6193c8331ad0f33b4b78026b45c560df11fe SHA512 baa701313b4066fe50b7f34551800c73e2f90bd704581d9c39166fcb339a571a414fee07bdf9c2347137f031c63a44133b2e373821a88435a5d64f763bf6cb59
diff --git a/www-plugins/lightspark/lightspark-0.8.1.ebuild b/www-plugins/lightspark/lightspark-0.8.1.ebuild
new file mode 100644
index 000000000000..6106645e3222
--- /dev/null
+++ b/www-plugins/lightspark/lightspark-0.8.1.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils gnome2-utils nsplugins toolchain-funcs xdg-utils
+
+EGIT_COMMIT="f6ed8284810ad91c277ed5d0835b215e7329450e"
+DESCRIPTION="High performance flash player"
+HOMEPAGE="http://lightspark.github.io/"
+SRC_URI="https://github.com/lightspark/lightspark/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cpu_flags_x86_sse2 curl ffmpeg gles libav nsplugin ppapi profile rtmp"
+
+RDEPEND="app-arch/xz-utils:0=
+ dev-cpp/glibmm:2=
+ >=dev-libs/boost-1.42:0=
+ dev-libs/glib:2=
+ dev-libs/libpcre:3=[cxx]
+ media-fonts/liberation-fonts
+ media-libs/freetype:2=
+ media-libs/libpng:0=
+ media-libs/libsdl2:0=
+ media-libs/sdl2-mixer:0=
+ >=sys-devel/llvm-3.4:=
+ sys-libs/zlib:0=
+ x11-libs/cairo:0=
+ x11-libs/libX11:0=
+ x11-libs/pango:0=
+ virtual/jpeg:0=
+ curl? ( net-misc/curl:0= )
+ ffmpeg? (
+ libav? ( <media-video/libav-13_pre:0= )
+ !libav? ( <media-video/ffmpeg-4:0= )
+ )
+ gles? ( media-libs/mesa:0=[gles2] )
+ !gles? (
+ >=media-libs/glew-1.5.3:0=
+ virtual/opengl:0=
+ )
+ rtmp? ( media-video/rtmpdump:0= )"
+DEPEND="${RDEPEND}
+ amd64? ( dev-lang/nasm )
+ x86? ( dev-lang/nasm )
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${P/_rc*/}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_CURL=$(usex curl)
+ -DENABLE_GLES2=$(usex gles)
+ -DENABLE_LIBAVCODEC=$(usex ffmpeg)
+ -DENABLE_RTMP=$(usex rtmp)
+
+ -DENABLE_MEMORY_USAGE_PROFILING=$(usex profile)
+ -DENABLE_PROFILING=$(usex profile)
+ -DENABLE_SSE2=$(usex cpu_flags_x86_sse2)
+
+ -DCOMPILE_NPAPI_PLUGIN=$(usex nsplugin)
+ -DPLUGIN_DIRECTORY="${EPREFIX}"/usr/$(get_libdir)/${PN}/plugins
+ # TODO: install /etc/chromium file? block adobe-flash?
+ -DCOMPILE_PPAPI_PLUGIN=$(usex ppapi)
+ -DPPAPI_PLUGIN_DIRECTORY="${EPREFIX}"/usr/$(get_libdir)/chromium-browser/${PN}
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ use nsplugin && inst_plugin /usr/$(get_libdir)/${PN}/plugins/liblightsparkplugin.so
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+
+ if use nsplugin && ! has_version www-plugins/gnash; then
+ elog "Lightspark now supports gnash fallback for its browser plugin."
+ elog "Install www-plugins/gnash to take advantage of it."
+ fi
+ if use nsplugin && has_version "www-plugins/gnash[nsplugin]"; then
+ elog "Having two plugins installed for the same MIME type may confuse"
+ elog "Mozilla based browsers. It is recommended to disable the nsplugin"
+ elog "USE flag for either gnash or lightspark. For details, see"
+ elog "https://bugzilla.mozilla.org/show_bug.cgi?id=581848"
+ fi
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}