summaryrefslogtreecommitdiff
path: root/www-plugins/chrome-binary-plugins/chrome-binary-plugins-78.0.3904.34_beta.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-10-13 21:54:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-10-13 21:54:24 +0100
commitda491770b9ba5f179e18db461c49cb6f1ccf0e1f (patch)
treed3e34a8bd906741ab18cf69d8d4f732853e26ade /www-plugins/chrome-binary-plugins/chrome-binary-plugins-78.0.3904.34_beta.ebuild
parentad6182343997a405079870a2fe91c4e0c6b94595 (diff)
parent5a165c60b9b8c4847067cb83b4be7da785d01f93 (diff)
gentoo resync : 28.09.2019
Diffstat (limited to 'www-plugins/chrome-binary-plugins/chrome-binary-plugins-78.0.3904.34_beta.ebuild')
-rw-r--r--www-plugins/chrome-binary-plugins/chrome-binary-plugins-78.0.3904.34_beta.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/www-plugins/chrome-binary-plugins/chrome-binary-plugins-78.0.3904.34_beta.ebuild b/www-plugins/chrome-binary-plugins/chrome-binary-plugins-78.0.3904.34_beta.ebuild
new file mode 100644
index 000000000000..44a588dd47fa
--- /dev/null
+++ b/www-plugins/chrome-binary-plugins/chrome-binary-plugins-78.0.3904.34_beta.ebuild
@@ -0,0 +1,61 @@
+# Copyright 2012-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib unpacker
+
+DESCRIPTION="Binary plugins from Google Chrome for use in Chromium"
+HOMEPAGE="https://www.google.com/chrome"
+
+case ${PV} in
+ *_alpha*)
+ SLOT="unstable"
+ CHROMEDIR="opt/google/chrome-${SLOT}"
+ MY_PV=${PV%_alpha}-1
+ ;;
+ *_beta*)
+ SLOT="beta"
+ CHROMEDIR="opt/google/chrome-${SLOT}"
+ MY_PV=${PV%_beta}-1
+ ;;
+ *)
+ SLOT="stable"
+ CHROMEDIR="opt/google/chrome"
+ MY_PV=${PV}-1
+ ;;
+esac
+
+MY_PN="google-chrome-${SLOT}"
+MY_P="${MY_PN}_${MY_PV}"
+
+SRC_URI="https://dl.google.com/linux/chrome/deb/pool/main/g/${MY_PN}/${MY_P}_amd64.deb"
+KEYWORDS="-* ~amd64"
+
+LICENSE="google-chrome"
+RESTRICT="bindist mirror strip"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ !<www-client/chromium-57[widevine(-)]
+"
+
+for x in 0 beta stable unstable; do
+ if [[ ${SLOT} != ${x} ]]; then
+ RDEPEND+=" !${CATEGORY}/${PN}:${x}"
+ fi
+done
+
+S="${WORKDIR}/${CHROMEDIR}"
+QA_PREBUILT="*"
+
+pkg_nofetch() {
+ eerror "Please wait 24 hours and sync your portage tree before reporting fetch failures."
+}
+
+src_install() {
+ insinto "/usr/$(get_libdir)/chromium-browser"
+ doins -r WidevineCdm
+}