summaryrefslogtreecommitdiff
path: root/www-plugins/chrome-binary-plugins/chrome-binary-plugins-77.0.3865.75_beta.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-25 19:33:39 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-28 08:31:11 +0100
commitad6182343997a405079870a2fe91c4e0c6b94595 (patch)
tree4aa7483cd0ad7de54338afc8e7971417abe1dd81 /www-plugins/chrome-binary-plugins/chrome-binary-plugins-77.0.3865.75_beta.ebuild
parente8f81810baa21f490d6910e8e2d424546b72a333 (diff)
gentoo resync : 25.09.2019
Diffstat (limited to 'www-plugins/chrome-binary-plugins/chrome-binary-plugins-77.0.3865.75_beta.ebuild')
-rw-r--r--www-plugins/chrome-binary-plugins/chrome-binary-plugins-77.0.3865.75_beta.ebuild67
1 files changed, 0 insertions, 67 deletions
diff --git a/www-plugins/chrome-binary-plugins/chrome-binary-plugins-77.0.3865.75_beta.ebuild b/www-plugins/chrome-binary-plugins/chrome-binary-plugins-77.0.3865.75_beta.ebuild
deleted file mode 100644
index 3fd84e77d226..000000000000
--- a/www-plugins/chrome-binary-plugins/chrome-binary-plugins-77.0.3865.75_beta.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 2012-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit multilib unpacker
-
-DESCRIPTION="Binary plugins from Google Chrome for use in Chromium"
-HOMEPAGE="https://www.google.com/chrome"
-
-case ${PV} in
- *_alpha*)
- SLOT="unstable"
- CHROMEDIR="opt/google/chrome-${SLOT}"
- MY_PV=${PV%_alpha}-1
- ;;
- *_beta*)
- SLOT="beta"
- CHROMEDIR="opt/google/chrome-${SLOT}"
- MY_PV=${PV%_beta}-1
- ;;
- *)
- SLOT="stable"
- CHROMEDIR="opt/google/chrome"
- MY_PV=${PV}-1
- ;;
-esac
-
-MY_PN="google-chrome-${SLOT}"
-MY_P="${MY_PN}_${MY_PV}"
-
-SRC_URI="https://dl.google.com/linux/chrome/deb/pool/main/g/${MY_PN}/${MY_P}_amd64.deb"
-KEYWORDS="-* ~amd64"
-
-LICENSE="google-chrome"
-IUSE="+widevine"
-RESTRICT="bindist mirror strip"
-
-RDEPEND="
- widevine? (
- dev-libs/glib:2
- dev-libs/nspr
- dev-libs/nss
- !<www-client/chromium-57[widevine(-)]
- )
-"
-
-for x in 0 beta stable unstable; do
- if [[ ${SLOT} != ${x} ]]; then
- RDEPEND+=" !${CATEGORY}/${PN}:${x}"
- fi
-done
-
-S="${WORKDIR}/${CHROMEDIR}"
-QA_PREBUILT="*"
-
-pkg_nofetch() {
- eerror "Please wait 24 hours and sync your portage tree before reporting fetch failures."
-}
-
-src_install() {
- insinto /usr/$(get_libdir)/chromium
- if use widevine; then
- doins libwidevinecdm.so
- dosym ../chromium/libwidevinecdm.so /usr/$(get_libdir)/chromium-browser/libwidevinecdm.so
- fi
-}