summaryrefslogtreecommitdiff
path: root/www-plugins/chrome-binary-plugins/chrome-binary-plugins-122.0.6261.128.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-13 06:46:47 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-13 06:46:47 +0000
commitafb19abe0ec73761b4e330ee952a19e98d4bc7e3 (patch)
treec831ae0927550faddb9a37c12b33f38c1b376073 /www-plugins/chrome-binary-plugins/chrome-binary-plugins-122.0.6261.128.ebuild
parent360468f13add58583c7780bcacafb5452a07851d (diff)
gentoo auto-resync : 13:03:2024 - 06:46:47
Diffstat (limited to 'www-plugins/chrome-binary-plugins/chrome-binary-plugins-122.0.6261.128.ebuild')
-rw-r--r--www-plugins/chrome-binary-plugins/chrome-binary-plugins-122.0.6261.128.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/www-plugins/chrome-binary-plugins/chrome-binary-plugins-122.0.6261.128.ebuild b/www-plugins/chrome-binary-plugins/chrome-binary-plugins-122.0.6261.128.ebuild
new file mode 100644
index 000000000000..76256358489d
--- /dev/null
+++ b/www-plugins/chrome-binary-plugins/chrome-binary-plugins-122.0.6261.128.ebuild
@@ -0,0 +1,62 @@
+# Copyright 2012-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit unpacker
+
+DESCRIPTION="Binary plugins from Google Chrome for use in Chromium"
+HOMEPAGE="https://www.google.com/chrome"
+
+case ${PV} in
+ *_alpha*)
+ SLOT="unstable"
+ CHROMEDIR="opt/google/chrome-${SLOT}"
+ MY_PV=${PV%_alpha}-1
+ ;;
+ *_beta*)
+ SLOT="beta"
+ CHROMEDIR="opt/google/chrome-${SLOT}"
+ MY_PV=${PV%_beta}-1
+ ;;
+ *)
+ SLOT="stable"
+ CHROMEDIR="opt/google/chrome"
+ MY_PV=${PV}-1
+ ;;
+esac
+
+KEYWORDS="-* amd64"
+
+MY_PN="google-chrome-${SLOT}"
+MY_P="${MY_PN}_${MY_PV}"
+
+SRC_URI="https://dl.google.com/linux/chrome/deb/pool/main/g/${MY_PN}/${MY_P}_amd64.deb"
+
+LICENSE="google-chrome"
+RESTRICT="bindist mirror strip"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ sys-libs/glibc
+"
+
+for x in 0 beta stable unstable; do
+ if [[ ${SLOT} != ${x} ]]; then
+ RDEPEND+=" !${CATEGORY}/${PN}:${x}"
+ fi
+done
+
+S="${WORKDIR}/${CHROMEDIR}"
+QA_PREBUILT="*"
+
+pkg_nofetch() {
+ eerror "Please wait 24 hours and sync your portage tree before reporting fetch failures."
+}
+
+src_install() {
+ insinto "/usr/$(get_libdir)/chromium-browser"
+ doins -r WidevineCdm
+}