summaryrefslogtreecommitdiff
path: root/www-plugins/browserpass
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
commitceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (patch)
tree9f47ee47c31a0f13f9496879cd88a1042550aa81 /www-plugins/browserpass
parent53cba99042fa967e2a93da9f8db806fe2d035543 (diff)
gentoo (leap year) resync : 29.02.2020
Diffstat (limited to 'www-plugins/browserpass')
-rw-r--r--www-plugins/browserpass/Manifest1
-rw-r--r--www-plugins/browserpass/browserpass-3.0.6-r2.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/www-plugins/browserpass/Manifest b/www-plugins/browserpass/Manifest
index d014a1dcf520..6a60b5b68b52 100644
--- a/www-plugins/browserpass/Manifest
+++ b/www-plugins/browserpass/Manifest
@@ -3,4 +3,5 @@ DIST github.com-golang-sys-6d18c012aee9febd81bbf9806760c8c4480e870d.tar.gz 15328
DIST github.com-mattn-go-zglob-a8912a37f9e7.tar.gz 8030 BLAKE2B 2c7719a15f598b06d479bf35b1154b0685ee94d7c94bae9a3e3ae63b0706b63c885cd226e2749402a92d5937a5d8b03aa94ccf14fad6c8adbaf438ed131f04f4 SHA512 ebcd8096a15082f454be3d6349e1ae092696db52b843ca2cad84fb4ba8f5f9411db7b9bf40e387238e30c33495062ee711de4249e56889fa059c9c6ccd1600f0
DIST github.com-sirupsen-logrus-v1.4.2.tar.gz 41373 BLAKE2B 3675dd82fd9c174fddf93eea87f3ca2c2671d9719ba148b03136c35ce6a3ce95866c57cb706a641a14522a522606dc9ea9ec9f0a6c7da6f8cf18f46b9f4bd3ee SHA512 c29689e5ea0ff919afc6fe1c492898d8b898e6831c442d3fc45c29508bdfda08604b1ea09d3b17db401bddca69fd5f8f744610075ee3c0577df6a537e0980a13
EBUILD browserpass-3.0.6-r1.ebuild 1361 BLAKE2B e1a0506035d3818109bfe7797aa39e394be4c20ccd4e06881064ac357a25c065fedf145eec6318ad6a82cbe7edd86acf5e4ad22ad15263a0bdc311b6aaff78df SHA512 c5c17658281dc1243c82d8459cb9bebf6c86c756cf9d71b9ef759788700a94fa96bf704acc644e55d5616c693d7bad64a11ebd5554fd273161e9040e99f80094
+EBUILD browserpass-3.0.6-r2.ebuild 1478 BLAKE2B de180539077c587f82df125c0026ee5d377f5dad2ff2c1f3c39e4f6f76cb37664add8698039be54f4fd611cf77433b641aee9e45913b826307822fff921437d9 SHA512 07022eda304fbd24879af059995f99c0bbe0f9349a1f6681a8097feeae3c351c45ca18de5a3250f13e87c0366a97442555473da29e78188a7ceed9c937a173b5
MISC metadata.xml 246 BLAKE2B c7559c694569e2eb079aa44ab82aac05dd7218624519133b1d1de233f6d4bce0872ada012e00dc369051e9685d9a25d314c05318d1b109ee81945dd739da51df SHA512 0d07f784095273f14c7d63a215a76c84fec302e6e52717f0e47c29916aa90149239dfe7ed3227a42e2863226e4448d8a2e8321ccc589ad6d9f725731b45559a2
diff --git a/www-plugins/browserpass/browserpass-3.0.6-r2.ebuild b/www-plugins/browserpass/browserpass-3.0.6-r2.ebuild
new file mode 100644
index 000000000000..a931577f7adb
--- /dev/null
+++ b/www-plugins/browserpass/browserpass-3.0.6-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit go-module
+
+DESCRIPTION="WebExtension host binary for app-admin/pass, a UNIX password manager"
+HOMEPAGE="https://github.com/browserpass/browserpass-native"
+
+EGO_VENDOR=(
+ "github.com/mattn/go-zglob a8912a37f9e7" # MIT
+ "github.com/sirupsen/logrus v1.4.2" # MIT
+ "golang.org/x/sys 6d18c012aee9febd81bbf9806760c8c4480e870d github.com/golang/sys" # BSD
+)
+
+MY_PN=browserpass-native
+SRC_URI="https://github.com/browserpass/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
+ $(go-module_vendor_uris)"
+
+LICENSE="BSD ISC MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+DEPEND=""
+RDEPEND="app-crypt/gnupg"
+
+S="${WORKDIR}"/${MY_PN}-${PV}
+
+src_compile() {
+ go build || die
+
+ sed -e 's|%%replace%%|'${EPREFIX}'/usr/libexec/browserpass-native|' \
+ -i browser-files/firefox-host.json browser-files/chromium-host.json || die
+}
+
+src_install() {
+ exeinto /usr/libexec
+ doexe browserpass-native
+
+ insinto /usr/lib/mozilla/native-messaging-hosts
+ newins browser-files/firefox-host.json com.github.browserpass.native.json
+
+ insinto /usr/lib64/mozilla/native-messaging-hosts
+ newins browser-files/firefox-host.json com.github.browserpass.native.json
+
+ insinto /etc/chromium/native-messaging-hosts
+ newins browser-files/chromium-host.json com.github.browserpass.native.json
+
+ insinto /etc/opt/chrome/native-messaging-hosts
+ newins browser-files/chromium-host.json com.github.browserpass.native.json
+}