summaryrefslogtreecommitdiff
path: root/www-misc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-05 23:26:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-05 23:26:20 +0100
commit2de9aaae9b6018544ada7f67e2229605e1ec4d04 (patch)
tree231bad5690196ca522285d446614a065879cc7d0 /www-misc
parent4274bed0c1f1fd06a654f5816e30d82059f4cc39 (diff)
gentoo auto-resync : 05:04:2023 - 23:26:20
Diffstat (limited to 'www-misc')
-rw-r--r--www-misc/Manifest.gzbin2756 -> 2920 bytes
-rw-r--r--www-misc/logswan/Manifest4
-rw-r--r--www-misc/logswan/logswan-2.1.14.ebuild28
-rw-r--r--www-misc/logswan/logswan-9999.ebuild28
-rw-r--r--www-misc/logswan/metadata.xml24
5 files changed, 84 insertions, 0 deletions
diff --git a/www-misc/Manifest.gz b/www-misc/Manifest.gz
index 9859f5832007..5b0d9f92080c 100644
--- a/www-misc/Manifest.gz
+++ b/www-misc/Manifest.gz
Binary files differ
diff --git a/www-misc/logswan/Manifest b/www-misc/logswan/Manifest
new file mode 100644
index 000000000000..b61dc3a634fb
--- /dev/null
+++ b/www-misc/logswan/Manifest
@@ -0,0 +1,4 @@
+DIST logswan-2.1.14.tar.gz 25223 BLAKE2B d1c18eac839cadeb9486ef032954e271616483aa69419db0d24c7abf0f70e008e9f4ed6f0b054bd1b65d7277ddf923cb7d30c4caa92a6ab4226d5db3df7b99dc SHA512 1956d65088e9cc41d981e47ce487996d0e2e0bf1666f871d59f9f91770666aac90840e4a5b88581f8c2da91ef953ad0e8e4856e088fa86546d74afb8f6ed8b77
+EBUILD logswan-2.1.14.ebuild 594 BLAKE2B 0393fa346ac2f89ba1baae2276a3f27b696445e382448daad5385da1db0e5e0a13cf6a837bf01ab4b9139e090d12ec508ecb05f7e5a45580cb3ecc4b5fa77f39 SHA512 669064e757c500c8e2b270b2108dc8f1c27e4f5ed1b98f84389e5fc5eaf7a63ec127b5dc5ace3dc479c12f1c3a6a0acfae6cecccbd22c227b10bff5d67dc7aff
+EBUILD logswan-9999.ebuild 594 BLAKE2B 0393fa346ac2f89ba1baae2276a3f27b696445e382448daad5385da1db0e5e0a13cf6a837bf01ab4b9139e090d12ec508ecb05f7e5a45580cb3ecc4b5fa77f39 SHA512 669064e757c500c8e2b270b2108dc8f1c27e4f5ed1b98f84389e5fc5eaf7a63ec127b5dc5ace3dc479c12f1c3a6a0acfae6cecccbd22c227b10bff5d67dc7aff
+MISC metadata.xml 1152 BLAKE2B 9856c0ca9f4e79e4c788fab1117300507ddf5534bedad95dec1701bcd4237959e1fb366e0a750cad844a1185e66f6c2221b15f28ed7ee5ec2775cb57a23afe60 SHA512 e13714ee925bfaa69c641f999ae12491f8eb0eb1a50dd22548ad111f59d5891a3acdb8fb48fb82e68175350a5da2631461adf6331ea45b4b1765cd2d493f79c9
diff --git a/www-misc/logswan/logswan-2.1.14.ebuild b/www-misc/logswan/logswan-2.1.14.ebuild
new file mode 100644
index 000000000000..6ac9fe8874df
--- /dev/null
+++ b/www-misc/logswan/logswan-2.1.14.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Fast Web log analyzer using probabilistic data structures"
+HOMEPAGE="https://www.logswan.org/
+ https://github.com/fcambus/logswan/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/fcambus/${PN}.git"
+else
+ SRC_URI="https://github.com/fcambus/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+
+RDEPEND="
+ dev-libs/jansson:=
+ dev-libs/libmaxminddb:=
+"
+DEPEND="${RDEPEND}"
diff --git a/www-misc/logswan/logswan-9999.ebuild b/www-misc/logswan/logswan-9999.ebuild
new file mode 100644
index 000000000000..6ac9fe8874df
--- /dev/null
+++ b/www-misc/logswan/logswan-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Fast Web log analyzer using probabilistic data structures"
+HOMEPAGE="https://www.logswan.org/
+ https://github.com/fcambus/logswan/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/fcambus/${PN}.git"
+else
+ SRC_URI="https://github.com/fcambus/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+
+RDEPEND="
+ dev-libs/jansson:=
+ dev-libs/libmaxminddb:=
+"
+DEPEND="${RDEPEND}"
diff --git a/www-misc/logswan/metadata.xml b/www-misc/logswan/metadata.xml
new file mode 100644
index 000000000000..1642e2f30440
--- /dev/null
+++ b/www-misc/logswan/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription>
+ Logswan is a fast Web log analyzer using probabilistic data structures. It
+ is targeted at very large log files, typically APIs logs. It has constant
+ memory usage regardless of the log file size, and takes approximatively 4MB
+ of RAM. Unique visitors counting is performed using two HyperLogLog
+ counters (one for IPv4, and another one for IPv6), providing a relative
+ accuracy of 0.10%. String representations of IP addresses are used and
+ preferred as they offer better precision. Project design goals include:
+ speed, memory-usage efficiency, and keeping the code as simple as possible.
+ </longdescription>
+ <upstream>
+ <changelog>https://raw.githubusercontent.com/fcambus/logswan/master/ChangeLog</changelog>
+ <bugs-to>https://github.com/fcambus/logswan/issues/</bugs-to>
+ <remote-id type="github">fcambus/logswan</remote-id>
+ </upstream>
+</pkgmetadata>