summaryrefslogtreecommitdiff
path: root/www-misc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-22 12:05:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-22 12:05:36 +0100
commit02eb6576978c38afed5787f6f2dbab8353379d66 (patch)
tree0b82220aae58c1307bef3aff0f342f4cdf858161 /www-misc
parent490ef2c2dc8b4e808f37add1adee21a754efd9a9 (diff)
gentoo auto-resync : 22:04:2024 - 12:05:36
Diffstat (limited to 'www-misc')
-rw-r--r--www-misc/Manifest.gzbin2757 -> 2759 bytes
-rw-r--r--www-misc/buku/Manifest2
-rw-r--r--www-misc/buku/buku-4.9.ebuild77
3 files changed, 79 insertions, 0 deletions
diff --git a/www-misc/Manifest.gz b/www-misc/Manifest.gz
index 5c8bade9badd..91b172ed6622 100644
--- a/www-misc/Manifest.gz
+++ b/www-misc/Manifest.gz
Binary files differ
diff --git a/www-misc/buku/Manifest b/www-misc/buku/Manifest
index 93a3039fa690..cd681259f3e0 100644
--- a/www-misc/buku/Manifest
+++ b/www-misc/buku/Manifest
@@ -1,3 +1,5 @@
DIST buku-4.8.tar.gz 591883 BLAKE2B 459ff04a414d3f320a76e8d7792a977f40b030597b846cff34abc862f062956dcfe477d01606744b13e8afe1c6d48f73848816488094f4941b4723a5cd4fedb6 SHA512 a87311adbd72ed614e870c24ecf890633672a6dab12d18f40017177049b2aaebbc66776740f893248b99f2f79d85b6d7b9e57c1fd1bbf6c95963ca57649dc2bf
+DIST buku-4.9.tar.gz 615794 BLAKE2B 79e0b7980d1df2b063be5b115c6d55fce63b9e9a58bae5c1ae4d81d77b644c90df2698e20a1743daf5468f4b08ab7b2125af073906385693419249b989686f3f SHA512 3804ea759c3b0172ab07b266123b27683f4785f1fb10859b4fd5b41e267b93e6ad0901b2456a27e434aef216f2063c5881d2755ec45789b3f2d42fe608b32eb2
EBUILD buku-4.8.ebuild 2993 BLAKE2B 753a39c9fd0f910c0e0c28b9dd89bd31b961dda97d7401831beeb18948d7a30e779e3d391d03aff64033e698806fdcec899089df655da6f145b1c9758ea963f2 SHA512 1aa7dac15094455f20293e6807cb2dbb4f15dd302768e753aa6c487d39a8ad9057de78060d7cbcac2b4dfe2a8b9d3c91db3acc0abde8d63c6c301067e09184f4
+EBUILD buku-4.9.ebuild 1972 BLAKE2B b46eecbeb269212f393d190454bfdb0dc88a940764a1de54b537586530956efd720bdd37cbd522a3803ec826cdf823ecbca15ef14e9d38a8422862e4004febfa SHA512 32add7af8acfec60cd7f085b3f39c504c0aa22941c36225964a2d1ab2eb6ab29c496e091581c06ffee9e887e2dfeba324ec83b5b2e7a9132b08ca3bb96e1cbce
MISC metadata.xml 580 BLAKE2B b3eca833a48e557d420c951266207f9ef521fd436cb4c9b69683f327e36ac1e0428b91e1a09dfe4622077af1a65ba31db0e59c36a895a3377797e51bbb74e0d6 SHA512 bf04984b64a9e0e488c9eefb0416afef47df54aa40e8ca4ff5690433435ecbb6c881be930d6b99ee99fa15995f216fc970d2db197dc9ac82c74e0092c1b099e3
diff --git a/www-misc/buku/buku-4.9.ebuild b/www-misc/buku/buku-4.9.ebuild
new file mode 100644
index 000000000000..a97191b80844
--- /dev/null
+++ b/www-misc/buku/buku-4.9.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10,11,12} )
+PYTHON_REQ_USE="sqlite"
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Powerful command-line bookmark manager"
+HOMEPAGE="https://github.com/jarun/buku"
+SRC_URI="https://github.com/jarun/${PN}/archive/v$(ver_cut 1-2).tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/beautifulsoup4-4.6.0[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ >=dev-python/html5lib-1.0.1[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/attrs[${PYTHON_USEDEP}]
+ >=dev-python/click-7.0[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ >=dev-python/py-1.5.0[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-4.2[${PYTHON_USEDEP}]
+ >=dev-python/vcrpy-4.0.2[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_IGNORE=(
+ # bukuserver tests
+ tests/test_views.py
+ tests/test_server.py
+)
+
+EPYTEST_DESELECT=(
+ # Broken with network-sandbox
+ tests/test_buku.py::test_network_handler_with_url
+ tests/test_buku.py::test_fetch_data_with_url
+ tests/test_bukuDb.py::TestBukuDb::test_tnyfy_url
+ tests/test_bukuDb.py::test_add_rec_exec_arg
+ tests/test_bukuDb.py::test_load_firefox
+ tests/test_bukuDb.py::test_print_db
+ tests/test_bukuDb.py::test_print_rec
+ tests/test_bukuDb.py::test_refreshdb
+)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Remove support for bukuserver - complex depgraph which isn't all
+ # sufficiently packaged in Gentoo
+ sed -ie '/console_scripts/s/,.*/]/' setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ insinto /usr/share/zsh/site-functions
+ doins auto-completion/zsh/_*
+
+ newbashcomp auto-completion/bash/buku-completion.bash "${PN}"
+
+ doman buku.1
+}