summaryrefslogtreecommitdiff
path: root/www-misc/urlwatch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
commite9d044d4b9b71200a96adfa280848858c0f468c9 (patch)
tree1bd8ef816043a8cd340f1d774e79553a1a7d31d8 /www-misc/urlwatch
parentfc2f1018fc323ef2c6572734a9b130427cba76a6 (diff)
gentoo resync : 13.11.2021
Diffstat (limited to 'www-misc/urlwatch')
-rw-r--r--www-misc/urlwatch/Manifest2
-rw-r--r--www-misc/urlwatch/urlwatch-2.24.ebuild74
2 files changed, 76 insertions, 0 deletions
diff --git a/www-misc/urlwatch/Manifest b/www-misc/urlwatch/Manifest
index d2c6d1642c56..3d9cf8b5bf19 100644
--- a/www-misc/urlwatch/Manifest
+++ b/www-misc/urlwatch/Manifest
@@ -1,5 +1,7 @@
DIST urlwatch-2.22.tar.gz 136306 BLAKE2B e7f10872e5d7f42ec0ac1073783431c4b0e4fcdcf40884a9f7f52aee36705fbdbaaf5f9e671223715040c6f68cc580f531ba753c9326a2b1380d2fb707f66f1c SHA512 f2c1e0d279689d1e5761203ba139614b972c6266c30877262d59759b0ce63342a820a063f001039848427ea4af4325505c636762cdedb3dc60ebd09e859914f4
DIST urlwatch-2.23.tar.gz 137917 BLAKE2B 330c52cad62985d24b2cc4c7345156abe9d5d369f8b3f4402856eb96a98f75422de49045bc10910e5cc81306744aad2dce7c05667a6f4eeb22b2bba47869f260 SHA512 e54f8fe2d8307ca9f2f222e6a2082d517a330db60e410b7c991283a2bf88aa861306965b23ca644811aa69425ec2281f7f48d5e34047b808c0897f45ffc7fcbc
+DIST urlwatch-2.24.tar.gz 141175 BLAKE2B 7868ba757493c97ef65136d3da67ef3bb6b0d62e52ab150e169d66adea420872990527a622d305bd14923ff367041d615dcea1495871258040ec2cbb73ee7613 SHA512 ed84cb69ecd8894851c3be0165edfa1dfee92a0b49ea1383e4cfd7c31eb0604f99b1a90d9508753064b58bdd8fc4c0369d817303858d07562b37c3f2ac4cae52
EBUILD urlwatch-2.22.ebuild 2027 BLAKE2B ab0672d343860d9f5b5127bf3462d71261a1ea32ddf1af10dc034d247d5709cdd51f935f952c55ed916301c5e2c2a6230487461cc207a317f199e11574162157 SHA512 ae6dd63fdda75ff22f5fbe288816634826378c06f9ac066a41148e08f69ee1260b62c8e60b55e8f021bf6add09516d0c650b9a50f9f5c92ea45fa9d6f90cf5de
EBUILD urlwatch-2.23.ebuild 2226 BLAKE2B e31161870ad1cccec96f8523fc13db58e6e10e8cf3fecfaa0519026ebd4f6b108fa20469f2b603eeff277c07249571dd5a553956f95fb8678d1d6bca22484627 SHA512 6cc6fd3fe7c347b9242c21d77da9d53fac3d6e091b48a5cc7cb3212adb736a4a7ef4c6ad84112e7adfcadd9abef3e7040e6044b0ee28181c9c4c1441580d3b61
+EBUILD urlwatch-2.24.ebuild 2433 BLAKE2B 982a6e5ba8f7904961dd3daf91cbd44cc15c3dc55029dc97960c096eadf8e8613a5302605f0858412de3a50d6ac52978199d91b15a7e05c4f600b625793a2ffd SHA512 80469a5f2b8c74f4f0361a30023e8be74ef9603b002a459406dab3c5d74cfdb16c49b68a84e069c4ee78049b4a88c650a090722c7194a6dee98425041d7f3eba
MISC metadata.xml 541 BLAKE2B f4518dac79cafa9a225d87e125b1fbb3e090c7d3ea1d90a307d8b881379b809112fdc0bd3da6a229daf228aa5660fd130a048fefc63c9a19743987a4c94e528d SHA512 86cf47f19a24fb11c4b1a02b1fe9490a5c171c77b4237a1d0557ce553b1b97ef05f1849f4d745aa0c86f27b2c74f646898f94484ecf75848379b3a02f4157170
diff --git a/www-misc/urlwatch/urlwatch-2.24.ebuild b/www-misc/urlwatch/urlwatch-2.24.ebuild
new file mode 100644
index 000000000000..ceff0e2189e5
--- /dev/null
+++ b/www-misc/urlwatch/urlwatch-2.24.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A tool for monitoring webpages for updates"
+HOMEPAGE="https://thp.io/2008/urlwatch/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/cssselect[${PYTHON_USEDEP}]
+ dev-python/keyring[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/minidb[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/jq[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( CHANGELOG.md README.md )
+
+distutils_enable_sphinx docs/source dev-python/alabaster
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Require the pdftotext module
+ "lib/urlwatch/tests/test_filter_documentation.py::test_url[https://example.net/pdf-test.pdf-job12]"
+ "lib/urlwatch/tests/test_filter_documentation.py::test_url[https://example.net/pdf-test-password.pdf-job13]"
+ # Requires the pytesseract module
+ "lib/urlwatch/tests/test_filter_documentation.py::test_url[https://example.net/ocr-test.png-job28]"
+ # Fail because of argv parsing: https://github.com/thp/urlwatch/issues/677
+ "lib/urlwatch/tests/test_handler.py::test_run_watcher"
+ "lib/urlwatch/tests/test_handler.py::test_number_of_tries_in_cache_is_increased"
+ "lib/urlwatch/tests/test_handler.py::test_report_error_when_out_of_tries"
+ "lib/urlwatch/tests/test_handler.py::test_reset_tries_to_zero_when_successful"
+ # Skip code quality check
+ "lib/urlwatch/tests/test_handler.py::test_pep8_conformance"
+)
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ if ! has_version dev-python/chump; then
+ elog "Install 'dev-python/chump' to enable Pushover" \
+ "notifications support"
+ fi
+ if ! has_version dev-python/jq; then
+ elog "Install 'dev-python/jq' to enable jq filtering support"
+ fi
+ if ! has_version dev-python/pushbullet-py; then
+ elog "Install 'dev-python/pushbullet-py' to enable" \
+ "Pushbullet notifications support"
+ fi
+ elog "HTML parsing can be improved by installing one of the following packages"
+ elog "and changing the html2text subfilter parameter:"
+ elog "dev-python/beautifulsoup4"
+ elog "app-text/html2text"
+ elog "dev-python/html2text"
+ elog "www-client/lynx"
+ fi
+}