summaryrefslogtreecommitdiff
path: root/www-misc/fcgiwrap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
commit36ac65103bf5503e5bad1ecc7e8cb9e7643f6840 (patch)
treed9d1fbc20509d4c90f57fb2d9e1459bc8034c831 /www-misc/fcgiwrap
parenta1392efe64137262023d92492396ca9156d22396 (diff)
Revert "gentoo resync : 13.09.2019"
This reverts commit a1392efe64137262023d92492396ca9156d22396.
Diffstat (limited to 'www-misc/fcgiwrap')
-rw-r--r--www-misc/fcgiwrap/Manifest2
-rw-r--r--www-misc/fcgiwrap/fcgiwrap-1.1.0_pre20150419.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/www-misc/fcgiwrap/Manifest b/www-misc/fcgiwrap/Manifest
index 1a61dc6d63ba..f0a1db29b0c6 100644
--- a/www-misc/fcgiwrap/Manifest
+++ b/www-misc/fcgiwrap/Manifest
@@ -1,4 +1,6 @@
DIST fcgiwrap-1.1.0.tar.gz 9924 BLAKE2B a96a87bfd1e4845be3a5018e5574edd40a800926ac531a041fae07f6810da509eecf97a19b2debe0ea318f2968f30184f4f6c1c02495777492d32826a0f759a1 SHA512 b8d35762d1d3c94a67602290b0092f0c38cffbbcd3dbc16597abf8b92172909b04450c238de2e430e841a17dd47fdd48d6a001f77539966980ef1af61e447ddc
+DIST fcgiwrap-1.1.0_pre20150419.tar.gz 10834 BLAKE2B 174a832b8d2996de38203244ecece55ca1bd808b1e6724894c9ef99a7236ad40fbe4031450797f14931008305d50b4d2dfcc1abe97586fda9f45194c8b16bf4e SHA512 48df3f0b5ad15d172b7ee883d53c59ecbd78c0c401ef1452df8fc03af1a7aed153464b2515ca18881af70f6baf6c80e0b405d1dde4888a20397b9db272ea6ba4
EBUILD fcgiwrap-1.1.0-r1.ebuild 1313 BLAKE2B b87272e5158a3ea56b573e34c31eebb75a900ac3f799a5533be65685260b4c02955fc58aa78e29b8e48f64512358646c99faffd8bb8ce3377254d9b132792dea SHA512 82c1d923eaf31578f7bd53beb1e342773dcb0d6d151f892c1e0281944c4bb91b5a9f65075b23045844f7374ac8ceb4948dfc92577060e0645355f1a7f520ae31
+EBUILD fcgiwrap-1.1.0_pre20150419.ebuild 1471 BLAKE2B b75461a9cbbcce40ccdfc2ff347a7ab84ac6c2292a80b92001860aa7497fea0b79b7131762c84789041f8f4f41b6a711faa6ebf8ff9b8c1bb0641ab7d65ef641 SHA512 abbcfea26e21a59350035aec6c6ea3d109a56735bc8a00de81226d7e73afe39f5951ce9b3537118f9c2e678e518fa5af5caad4b9af05a12070bd74d02109c211
EBUILD fcgiwrap-9999.ebuild 1361 BLAKE2B eee47215eb02c0b034ce4648244bfc71b8fb9a83b6e90690a8318ea4a7891cfa889129b07464cd2f7b2450e3c9307c83627c77b0167091cb356fa8b2c010a246 SHA512 0271ad94f88ec1c158f6c1e52e7037ada92f5c29f872eb8941b42d215c4465642e8ca7c8a905f4dc65fa02559f2995d42225fb048dc0a9ec0833b36d60d87e32
MISC metadata.xml 458 BLAKE2B 5170c572ca69ce1f1b03748af228cc788021c6f92dd2cc77584a852d6d03112a7ce3c36c4e6a41c952e55c180d8c750004f372565bf2c283b7f15f34aa806ff2 SHA512 d668390a3f179b243abeed455b9fe85eaef426848c1484572a564d1d631835ddd069046bbd84f5841ce60eadf81866ed69b60ce0b4bb301a91f5695441c3a1c9
diff --git a/www-misc/fcgiwrap/fcgiwrap-1.1.0_pre20150419.ebuild b/www-misc/fcgiwrap/fcgiwrap-1.1.0_pre20150419.ebuild
new file mode 100644
index 000000000000..b6310e79a9d5
--- /dev/null
+++ b/www-misc/fcgiwrap/fcgiwrap-1.1.0_pre20150419.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+[[ ${PV} = *9999* ]] && VCS_ECLASS="git-r3" || VCS_ECLASS=""
+inherit autotools systemd toolchain-funcs ${VCS_ECLASS}
+
+DESCRIPTION="Simple FastCGI wrapper for CGI scripts (CGI support for nginx)"
+HOMEPAGE="https://github.com/gnosek/fcgiwrap"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="systemd"
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/gnosek/${PN}.git"
+else
+ MY_REV="99c942c90063c73734e56bacaa65f947772d9186"
+ MY_P="gnosek-fcgiwrap-${MY_REV:0:7}"
+ SRC_URI="https://github.com/gnosek/${PN}/tarball/${MY_REV} -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+RDEPEND="
+ dev-libs/fcgi
+ systemd? ( sys-apps/systemd )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( README.rst )
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ sed -e "s/-Werror//" \
+ -i configure.ac || die "sed failed"
+
+ sed -e '/man8dir = $(DESTDIR)/s/@prefix@//' \
+ -i Makefile.in || die "sed failed"
+
+ sed -e "s/libsystemd-daemon/libsystemd/" \
+ -i configure.ac || die "sed failed"
+ tc-export CC
+
+ # Fix systemd units for Gentoo
+ sed -i -e '/User/d' systemd/fcgiwrap.service || die
+ sed -i -e '/Group/d' systemd/fcgiwrap.service || die
+
+ eapply_user
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with systemd) \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+}
+
+pkg_postinst() {
+ einfo 'You may want to install www-servers/spawn-fcgi to use with fcgiwrap.'
+}