summaryrefslogtreecommitdiff
path: root/www-misc/bookmarksync
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /www-misc/bookmarksync
reinit the tree, so we can have metadata
Diffstat (limited to 'www-misc/bookmarksync')
-rw-r--r--www-misc/bookmarksync/Manifest5
-rw-r--r--www-misc/bookmarksync/bookmarksync-0.3.4-r2.ebuild42
-rw-r--r--www-misc/bookmarksync/metadata.xml13
3 files changed, 60 insertions, 0 deletions
diff --git a/www-misc/bookmarksync/Manifest b/www-misc/bookmarksync/Manifest
new file mode 100644
index 000000000000..0318ef73e53b
--- /dev/null
+++ b/www-misc/bookmarksync/Manifest
@@ -0,0 +1,5 @@
+DIST bookmarksync-0.3.4.tar.gz 14324 SHA256 3111f55a8b1f6dd4d2f343bef4d15b58186a429505760ac8f38e2c4e4592fba8 SHA512 97464e32e9c21010eccf34b9bc94ce67d20f9b7a1f00b4e10e7096c0bde527a8b2a83a05c8623aa009fa0ab1895b025241aba2dfaf6881755bf05682b9e710d0 WHIRLPOOL 9a93d1f06c1dcab0da5c7df437b2d6a18e69d70fba0668ea3a7c59a2f96e30fe6189ea72ca57a8eab40baa31b579866abb81fc3c50d7ce15a3b474c43369c364
+EBUILD bookmarksync-0.3.4-r2.ebuild 845 SHA256 f07466f055412722440bef7fcc22254d54df088e627d4ee75edc5c2147c86c55 SHA512 247141b6b7caf814d8943f6bd265335d2a6899ebe76ae9f1fd22af15fd1687ff01181626d8a15083829530fa3a0719e50900e43a5c7e44d5b401dde9df20fc81 WHIRLPOOL 8533e9b701673cef37c86b58ca5761ed4a1739d02b6214f2dceecd2e0f75c7ef78f44b981d1dc024a578f59da1ee0517cfab2e7109ee7e877a8d7183cc91b34c
+MISC ChangeLog 2665 SHA256 79d014f29e04a4872de252d5325b56c89fcb15fabaa734da5108bd80c2171094 SHA512 459505b16688af8a35b1de3850865e516f9b92645e52d8c1d32f8eaf773f0adef1a3546e28631635af72bdfb8dd81e17798bc3ec12ef09817901aacf40b1b683 WHIRLPOOL 4ac09622a8c679ffaa3c03c3f0a6ac73417f3b3f26b7a0835c271777d45075b13bb94785f7f70d8ea930bd6bad5b10668d3fd2f4e84ea61a1d516a05c5435b5b
+MISC ChangeLog-2015 3965 SHA256 e13b67c25fd2a98d77194c7ff4e765cbb20242f85d2f0e7b44c9de9be413de4a SHA512 f17cd3ee68ac2a4d2ef0026e2d6859e2ec30c4892f69541ed0ea1fd41bcc1a51e27d8c366410ba2d14b081dda898644b34bf2565b65b1534d8a3529d7b9a053a WHIRLPOOL 4db4eb3bae7a74e59bf1ec948f8750bade3dd84cc3f28c1a3de76dda523cd5fda688e8ef229ccb976d70b3b4466a14d25693285b88dd45f5575f0bf261243cd0
+MISC metadata.xml 500 SHA256 0e64bba5901a9aebf8b7b6fb28c8416058326b98ca28da95829b2ae9aeeb3835 SHA512 fa87dc923d87b2126f2f4a75d2089dc5fa82e3f9cb362e46b0cec174aa1cc705abecd2242b208ac6b89af743ae106cc7913029887ab8e0112c20158fd92bd7fe WHIRLPOOL f62b9a83134f5f1d666b784bc3d7b9553b744219baf437dcacf1370e903462526e267a84bf08cf627bb10be582bd41c36b6ad37b6d477854e84213da1bafed07
diff --git a/www-misc/bookmarksync/bookmarksync-0.3.4-r2.ebuild b/www-misc/bookmarksync/bookmarksync-0.3.4-r2.ebuild
new file mode 100644
index 000000000000..ade6c8153bbf
--- /dev/null
+++ b/www-misc/bookmarksync/bookmarksync-0.3.4-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="bookmarksync synchronizes various browser bookmark files"
+HOMEPAGE="https://sourceforge.net/projects/booksync/"
+SRC_URI="mirror://sourceforge/booksync/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ppc x86"
+SLOT="0"
+
+IUSE="perl"
+RESTRICT="mirror"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ perl? ( dev-lang/perl )"
+
+src_prepare() {
+ sed -i Makefile \
+ -e 's|g++|$(CXX) $(CFLAGS)|g' \
+ -e 's| -o | $(LDFLAGS)&|g' \
+ || die "sed Makefile"
+ tc-export CXX
+}
+
+src_install () {
+ dobin bookmarksync
+ if use perl ; then
+ dobin tools/bookmarksync.pl
+ dodoc tools/README.tools
+ fi
+ dodoc README TODO DEVELOPERS
+}
+
+pkg_postinst () {
+ use perl && ewarn "You will need to modify bookmarksync.pl before use"
+}
diff --git a/www-misc/bookmarksync/metadata.xml b/www-misc/bookmarksync/metadata.xml
new file mode 100644
index 000000000000..6a55e7781e31
--- /dev/null
+++ b/www-misc/bookmarksync/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <longdescription>
+ bookmarksync is a tool used for synchronizing different bookmark files
+ and types. It preserves current bookmark structures and sorts in new
+ ones correctly in existing directorys or create new one if necessary.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">booksync</remote-id>
+ </upstream>
+</pkgmetadata>