summaryrefslogtreecommitdiff
path: root/www-misc/bookmarksync/bookmarksync-0.3.4-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
commite3872864be25f7421015bef2732fa57c0c9fb726 (patch)
tree9cb29a544215119b5c5538e37211b994ce1c87ae /www-misc/bookmarksync/bookmarksync-0.3.4-r3.ebuild
parent480486b52ea64765faf696c88b2c6a26a5a454d4 (diff)
gentoo resync : 04.08.2018
Diffstat (limited to 'www-misc/bookmarksync/bookmarksync-0.3.4-r3.ebuild')
-rw-r--r--www-misc/bookmarksync/bookmarksync-0.3.4-r3.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/www-misc/bookmarksync/bookmarksync-0.3.4-r3.ebuild b/www-misc/bookmarksync/bookmarksync-0.3.4-r3.ebuild
new file mode 100644
index 000000000000..288100d55459
--- /dev/null
+++ b/www-misc/bookmarksync/bookmarksync-0.3.4-r3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="bookmarksync synchronizes various browser bookmark files"
+HOMEPAGE="https://sourceforge.net/projects/booksync/"
+SRC_URI="mirror://sourceforge/booksync/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ppc x86"
+SLOT="0"
+
+IUSE="perl"
+RESTRICT="mirror"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ perl? ( dev-lang/perl )"
+
+src_prepare() {
+ default
+ sed -i Makefile \
+ -e 's|g++|$(CXX) $(CFLAGS)|g' \
+ -e 's| -o | $(LDFLAGS)&|g' \
+ || die "sed Makefile"
+ tc-export CXX
+}
+
+src_install () {
+ dobin bookmarksync
+ if use perl ; then
+ dobin tools/bookmarksync.pl
+ dodoc tools/README.tools
+ fi
+ dodoc README TODO DEVELOPERS
+}
+
+pkg_postinst () {
+ use perl && ewarn "You will need to modify bookmarksync.pl before use"
+}