summaryrefslogtreecommitdiff
path: root/www-client
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-04 02:14:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-04 02:14:42 +0100
commitba32ac7204934e0c69e1cc7529edce6efdbeb265 (patch)
tree79dbf15bc5803a13e0c015970a4df6e506d14205 /www-client
parent56ef021c58088c79bc71257eb348ff6decc47607 (diff)
gentoo auto-resync : 04:04:2024 - 02:14:41
Diffstat (limited to 'www-client')
-rw-r--r--www-client/Manifest.gzbin6030 -> 6033 bytes
-rw-r--r--www-client/epiphany/Manifest2
-rw-r--r--www-client/epiphany/epiphany-45.3.ebuild87
3 files changed, 89 insertions, 0 deletions
diff --git a/www-client/Manifest.gz b/www-client/Manifest.gz
index a40a9e21047c..e7adccc11b65 100644
--- a/www-client/Manifest.gz
+++ b/www-client/Manifest.gz
Binary files differ
diff --git a/www-client/epiphany/Manifest b/www-client/epiphany/Manifest
index 7c3f99cc6f3f..1a6a420b535c 100644
--- a/www-client/epiphany/Manifest
+++ b/www-client/epiphany/Manifest
@@ -1,3 +1,5 @@
DIST epiphany-44.6.tar.xz 3994776 BLAKE2B e73fc66d7138961b61085538daf15c0d93a13827a9fcef62f111ddee87541a0fb61a9fb8fba7814c613da8179c895ddedcc22e2838885aa9222c327609968dfb SHA512 9af157db0f7a68d64fec9fd17465ee8cc900879a3613c3f3e03ea27938a84c0dda6be30b4d1d2cc0f9ddba5cf5d41de3d3156b0580fdce03b1d8f920bb96536c
+DIST epiphany-45.3.tar.xz 4005168 BLAKE2B 9f8965d310efcfa21e133a24a29ce97ffff94e0b202be599bb83085095c77f93f81e6ef248d9b844e0790d35712471c2f27dd31fc808d6244b59251df26ae468 SHA512 4fac6b21dc40f77312e7c9367cb4d0e4ef292d1a30c3759405543fc372b044f9de98523854a0da7a4024a1429ce35b5513160a2977fb361d71a7a86d94dbf596
EBUILD epiphany-44.6.ebuild 1924 BLAKE2B c1e93221bc5c8679fdca26712c939b5accc74a62cf5b644063f4456d90ed8b31082bb379225b811378dd1a15fd762a68c85bf191afd7db5da4b7a92ad96fed23 SHA512 23c5430b788b01c53df6e3b6a0d65f609af134aee981bf64081680842d793ff308a25dbe3e46feee2e917dd9dee8bb503d15fb9f480a93fa9314c5e074f7f243
+EBUILD epiphany-45.3.ebuild 1927 BLAKE2B 20d54389db3c6fe74337b8ac0c99a2e6e25e0611650ea2f345ceaeeb9fb5fd1398202cdbd20d16e53bd620a29d059e5512703eb349855af28eb116a012b184ef SHA512 cbc866c93cc44784c96eea326dab024a16d1632fc23da48d75eeb92f0be86a55c121997359c1b4983a4e58a82507d24389e4d9946bcb3683aa68bd8bfc5f8cf1
MISC metadata.xml 349 BLAKE2B 3d863d6eb39cc99c7587d53af80d4df96f5c1bb534e406ee904d3b39f947c24e1153707581473e1477d984cd7be541925b4ff002d546f5d50f1115d1ad639362 SHA512 10d54acb787b2d9dab84b43fcc0e578d7afcae36142bef5028ac3838bfce6ae63348a4e05ee97eaa2f7d90204457990c9cf604c8df0dd714d62b907bf4da3019
diff --git a/www-client/epiphany/epiphany-45.3.ebuild b/www-client/epiphany/epiphany-45.3.ebuild
new file mode 100644
index 000000000000..db78c1770324
--- /dev/null
+++ b/www-client/epiphany/epiphany-45.3.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg virtualx
+
+DESCRIPTION="GNOME webbrowser based on Webkit"
+HOMEPAGE="https://wiki.gnome.org/Apps/Web https://gitlab.gnome.org/GNOME/epiphany"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ >=x11-libs/cairo-1.2
+ >=app-crypt/gcr-3.9.0:4=[gtk]
+ >=x11-libs/gdk-pixbuf-2.36.5:2
+ >=dev-libs/glib-2.74.0:2
+ gnome-base/gsettings-desktop-schemas
+ >=media-libs/gstreamer-1.0
+ >=gui-libs/gtk-4.10.0:4
+ >=app-text/iso-codes-0.35
+ >=dev-libs/json-glib-1.6
+ app-arch/libarchive:=
+ >=gui-libs/libadwaita-1.4.0:1
+ >=app-crypt/libsecret-0.19
+ >=net-libs/libsoup-2.99.4:3.0
+ >=dev-libs/libxml2-2.6.12:2
+ >=dev-libs/nettle-3.4:=
+ >=dev-libs/libportal-0.6:0=[gtk]
+ >=dev-db/sqlite-3.22:3
+ >=net-libs/webkit-gtk-2.41.1:6=
+
+ dev-libs/gmp:0=
+"
+RDEPEND="${DEPEND}
+ x11-themes/adwaita-icon-theme
+"
+# appstream-glib needed for appdata.xml gettext translation
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ -Ddeveloper_mode=false
+ # maybe enable later if network-sandbox is off, but in 3.32.4 the network test
+ # is commented out upstream anyway
+ -Dnetwork_tests=disabled
+ -Dtech_preview=false
+ $(meson_feature test unit_tests)
+ -Dgranite=disabled
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ if ! has_version net-libs/webkit-gtk:6[jpeg2k]; then
+ ewarn "Your net-libs/webkit-gtk:6 is built without USE=jpeg2k."
+ ewarn "Various image galleries/managers may be broken."
+ fi
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}