summaryrefslogtreecommitdiff
path: root/www-client/uget/uget-2.2.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-24 14:47:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-24 14:47:38 +0100
commitb4d43e8c611df4a8061b6f88d9e9f6b1e3c83903 (patch)
tree911928b566777494d08ebe2c16cb64f15af71901 /www-client/uget/uget-2.2.1-r1.ebuild
parent61f10f985e19dfe20a4d9552902625edd5b6eabb (diff)
gentoo resync : 24.06.2021
Diffstat (limited to 'www-client/uget/uget-2.2.1-r1.ebuild')
-rw-r--r--www-client/uget/uget-2.2.1-r1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/www-client/uget/uget-2.2.1-r1.ebuild b/www-client/uget/uget-2.2.1-r1.ebuild
new file mode 100644
index 000000000000..7c472abd0299
--- /dev/null
+++ b/www-client/uget/uget-2.2.1-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg
+
+DESCRIPTION="Download manager using gtk+ and libcurl"
+HOMEPAGE="http://www.ugetdm.com"
+SRC_URI="mirror://sourceforge/urlget/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc x86"
+IUSE="aria2 appindicator control-socket +gnutls gstreamer libnotify nls openssl rss"
+REQUIRED_USE="^^ ( gnutls openssl )"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/libpcre
+ net-misc/curl
+ >=x11-libs/gtk+-3.4:3
+ gnutls? (
+ net-libs/gnutls
+ dev-libs/libgcrypt:0
+ )
+ aria2? ( net-misc/aria2[xmlrpc] )
+ appindicator? ( dev-libs/libappindicator:3 )
+ gstreamer? ( media-libs/gstreamer:1.0 )
+ libnotify? ( x11-libs/libnotify )
+ openssl? ( dev-libs/openssl:0= )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
+
+src_configure() {
+ local myconf=(
+ $(use_enable appindicator)
+ $(use_enable control-socket unix_socket)
+ $(use_enable gstreamer)
+ $(use_enable libnotify notify)
+ $(use_enable nls)
+ $(use_enable rss rss_notify)
+ $(use_with gnutls)
+ $(use_with openssl)
+ )
+
+ econf "${myconf[@]}"
+}