summaryrefslogtreecommitdiff
path: root/www-client/surf/surf-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /www-client/surf/surf-9999.ebuild
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'www-client/surf/surf-9999.ebuild')
-rw-r--r--www-client/surf/surf-9999.ebuild30
1 files changed, 17 insertions, 13 deletions
diff --git a/www-client/surf/surf-9999.ebuild b/www-client/surf/surf-9999.ebuild
index d6b737a623dc..2b48a07f1c22 100644
--- a/www-client/surf/surf-9999.ebuild
+++ b/www-client/surf/surf-9999.ebuild
@@ -2,42 +2,46 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit git-r3 savedconfig toolchain-funcs
+inherit savedconfig toolchain-funcs
DESCRIPTION="a simple web browser based on WebKit/GTK+"
HOMEPAGE="https://surf.suckless.org/"
-EGIT_REPO_URI="https://git.suckless.org/surf"
-EGIT_BRANCH="surf-webkit2"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.suckless.org/surf"
+ EGIT_BRANCH="surf-webkit2"
+else
+ SRC_URI="https://dl.suckless.org/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
LICENSE="MIT"
SLOT="0"
-KEYWORDS=""
IUSE="tabbed"
-COMMON_DEPEND="
+DEPEND="
app-crypt/gcr[gtk]
dev-libs/glib:2
net-libs/webkit-gtk:4
x11-libs/gtk+:3
x11-libs/libX11
"
-DEPEND="
- ${COMMON_DEPEND}
- virtual/pkgconfig
-"
-RDEPEND="
+RDEPEND="${DEPEND}
!sci-chemistry/surf
- ${COMMON_DEPEND}
!savedconfig? (
- >=x11-misc/dmenu-4.7
net-misc/curl
x11-apps/xprop
+ x11-misc/dmenu
x11-terms/st
)
tabbed? ( x11-misc/tabbed )
"
+BDEPEND="
+ virtual/pkgconfig
+"
PATCHES=(
- "${FILESDIR}"/${PN}-9999-gentoo.patch
+ "${FILESDIR}"/${PN}-2.1-gentoo.patch
)
pkg_setup() {