summaryrefslogtreecommitdiff
path: root/www-client/surf/surf-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /www-client/surf/surf-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'www-client/surf/surf-9999.ebuild')
-rw-r--r--www-client/surf/surf-9999.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/www-client/surf/surf-9999.ebuild b/www-client/surf/surf-9999.ebuild
new file mode 100644
index 000000000000..c21a83052259
--- /dev/null
+++ b/www-client/surf/surf-9999.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit git-r3 savedconfig toolchain-funcs
+
+DESCRIPTION="a simple web browser based on WebKit/GTK+"
+HOMEPAGE="https://surf.suckless.org/"
+EGIT_REPO_URI="https://git.suckless.org/surf"
+EGIT_BRANCH="surf-webkit2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+
+COMMON_DEPEND="
+ app-crypt/gcr[gtk]
+ dev-libs/glib:2
+ net-libs/libsoup
+ net-libs/webkit-gtk:4
+ x11-libs/gtk+:3
+ x11-libs/libX11
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ virtual/pkgconfig
+"
+RDEPEND="
+ !sci-chemistry/surf
+ ${COMMON_DEPEND}
+ x11-apps/xprop
+ x11-misc/dmenu
+ !savedconfig? (
+ net-misc/curl
+ x11-terms/st
+ )
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-9999-gentoo.patch
+)
+
+pkg_setup() {
+ if ! use savedconfig; then
+ elog "The default config.h assumes you have"
+ elog " net-misc/curl"
+ elog " x11-terms/st"
+ elog "installed to support the download function."
+ elog "Without those, downloads will fail (gracefully)."
+ elog "You can fix this by:"
+ elog "1) Installing these packages, or"
+ elog "2) Setting USE=savedconfig and changing config.h accordingly."
+ fi
+}
+
+src_prepare() {
+ default
+
+ restore_config config.h
+
+ tc-export CC PKG_CONFIG
+}
+
+src_install() {
+ default
+
+ save_config config.h
+}