summaryrefslogtreecommitdiff
path: root/www-client/qutebrowser
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-03 13:48:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-03 13:48:30 +0100
commit24d75f43d3d4caf76f2448bb277e89a3b3ae0d99 (patch)
tree4f290d635d831599222130ba8ddbf1a726129426 /www-client/qutebrowser
parent8d8735134b6bb6e159162e531cccb456691a4ed4 (diff)
gentoo auto-resync : 03.08.2022 - 13:48:05
Diffstat (limited to 'www-client/qutebrowser')
-rw-r--r--www-client/qutebrowser/Manifest3
-rw-r--r--www-client/qutebrowser/metadata.xml1
-rw-r--r--www-client/qutebrowser/qutebrowser-3.0.0_pre9999.ebuild174
3 files changed, 177 insertions, 1 deletions
diff --git a/www-client/qutebrowser/Manifest b/www-client/qutebrowser/Manifest
index 08d831041adc..89c57c51f549 100644
--- a/www-client/qutebrowser/Manifest
+++ b/www-client/qutebrowser/Manifest
@@ -1,4 +1,5 @@
DIST qutebrowser-2.5.2.tar.gz 6114611 BLAKE2B 5f56e1e2c390bb2f36c95e25a2dae9e5203020ff6b2cf1e13092cf493efa950b24b8ff8f23af6eed93ca8b316e30f86715ecd2f2eb28c341210de0b25c9f67ad SHA512 4751ea1a5b1776f085fcd1f9ab5ff805155fca34d0272ba8eb6574f9074257929c3fb5b50c9053a522bfb346aee1a2551b58cf933c6ff7c5c84fd10559ec36fc
EBUILD qutebrowser-2.5.2.ebuild 4386 BLAKE2B 46da9c624ce3e90ba1538686b52996d3c0886c99a52631694788b39acc7e2541a55417e03252314d3dd7e2106b1bba81b5f32279adfbe06b602d721a2b5c7efb SHA512 60924de2de77291d9b547693080c5edf1c4367aa3840db69ac7cb01ac241dc3b5a7c0897160b4031435d13f70f8b925722fb36cf33d6a487556c00ccb9167103
+EBUILD qutebrowser-3.0.0_pre9999.ebuild 6030 BLAKE2B b37b8c3e3b712985fd39a69000ba41c0ea4a338ee00bc2c246b80f215270584b27a9d80c1195417aaf8053db295dfb0dba8fc390e61b545baed6aec5791903f3 SHA512 f057a3e7e0588742289d3b8c639d9feeac32fcd901746fc21453318e998c3cf2d06e011b87f331cf3e10613d4c3bc0bb644b6e17c862b6e6caae40a428263a13
EBUILD qutebrowser-9999.ebuild 4387 BLAKE2B ff92d8705c2369729256a8de911634de9988c65cc8910da495d014c30a52d4e61722ade884c3989c4dbe506889ceb616b4e1794cdd860adf9d151dcce8b57b85 SHA512 0f074d74305762383bc647d3e883bee4d1b376d659844e4e2afe1867fc7b81da85c4e140f70e22fb268407d18e0166f813dbfe62fbeba085f8d8befce35027fe
-MISC metadata.xml 945 BLAKE2B e796d777d56a5452b6652d77e011dfb160684f6e7498d0c4fad583bb828ecd111c25be5d80ed906b9b579e6ccd33315fc20a727342df0fb1b66b1a71effcea25 SHA512 80a65a391a84208042d9e7a6e0b5e8644ed07d5e389cd6a7b314b961dca5cff6406c5556693b34dcd275acfb27d05d9e40f77e9d503f9e3e8054ab6b6763932d
+MISC metadata.xml 1018 BLAKE2B 9d0c406995b2036671113b6513c3ed2fdb5021eae9d1dde5c186efeccdde6dae127857e3e5898f7809edcc27eca4b47f37965155ac0ff21bedb78e242421fd54 SHA512 2af79f18d31f9efe8df852f4bca132caf1d79fc06f6388959deb367470d4975af541a75c70831b549d944112bcd0bc7e11510a81bce4ef1391fbf1354425b769
diff --git a/www-client/qutebrowser/metadata.xml b/www-client/qutebrowser/metadata.xml
index 44b66f5f9007..224624c5a073 100644
--- a/www-client/qutebrowser/metadata.xml
+++ b/www-client/qutebrowser/metadata.xml
@@ -24,6 +24,7 @@
<use>
<flag name="adblock">Enable Brave's ABP-style adblocker library
for improved adblocking</flag>
+ <flag name="qt6">Use Qt6 that provides a newer Chromium version</flag>
<flag name="widevine">Unsupported closed-source DRM capability
(required by Netflix VOD)</flag>
</use>
diff --git a/www-client/qutebrowser/qutebrowser-3.0.0_pre9999.ebuild b/www-client/qutebrowser/qutebrowser-3.0.0_pre9999.ebuild
new file mode 100644
index 000000000000..50f156d349ff
--- /dev/null
+++ b/www-client/qutebrowser/qutebrowser-3.0.0_pre9999.ebuild
@@ -0,0 +1,174 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1 multiprocessing optfeature xdg
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/qutebrowser/qutebrowser.git"
+ EGIT_BRANCH="qt6-v2"
+else
+ SRC_URI="https://github.com/qutebrowser/qutebrowser/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Keyboard-driven, vim-like browser based on Python and Qt"
+HOMEPAGE="https://www.qutebrowser.org/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="+adblock +qt6 widevine"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/importlib_resources[${PYTHON_USEDEP}]' 3.8)
+ $(python_gen_cond_dep '
+ dev-python/colorama[${PYTHON_USEDEP}]
+ >=dev-python/jinja-3.1.2[${PYTHON_USEDEP}]
+ >=dev-python/markupsafe-2.1.1[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-6[${PYTHON_USEDEP}]
+ dev-python/zipp[${PYTHON_USEDEP}]
+ adblock? ( dev-python/adblock[${PYTHON_USEDEP}] )')
+ qt6? (
+ dev-qt/qtbase:6[icu]
+ $(python_gen_cond_dep '
+ dev-python/PyQt6[${PYTHON_USEDEP},dbus,gui,network,opengl,printsupport,qml,sql,widgets]
+ dev-python/PyQt6_WebEngine[${PYTHON_USEDEP},widgets]')
+ )
+ !qt6? (
+ dev-qt/qtcore:5[icu]
+ dev-qt/qtgui:5[png]
+ $(python_gen_cond_dep '
+ dev-python/PyQt5[${PYTHON_USEDEP},dbus,declarative,gui,network,opengl,printsupport,sql,widgets]
+ dev-python/PyQtWebEngine[${PYTHON_USEDEP}]')
+ )
+ widevine? ( www-plugins/chrome-binary-plugins )"
+BDEPEND="
+ $(python_gen_cond_dep '
+ test? (
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/cheroot[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest-bdd[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-qt[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/pytest-xvfb[${PYTHON_USEDEP}]
+ dev-python/tldextract[${PYTHON_USEDEP}]
+ qt6? ( dev-python/PyQt6[testlib] )
+ !qt6? ( dev-python/PyQt5[testlib] )
+ )')"
+[[ ${PV} == *9999 ]] && BDEPEND+=" app-text/asciidoc"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ if use widevine; then
+ # Qt6 knows Gentoo's, but pass to ensure libdir, EPREFIX, and for Qt5
+ local widevine=${EPREFIX}/usr/$(get_libdir)/chromium-browser/WidevineCdm/_platform_specific/linux_x64/libwidevinecdm.so
+ sed "/yield from _qtwebengine_settings_args/a\ yield '--widevine-path=${widevine}'" \
+ -i ${PN}/config/qtargs.py || die
+ fi
+
+ # ensure run the requested Qt backend
+ sed -i '/^_WRAPPERS = /,/^]/c\_WRAPPERS = [ "PyQt'$(usex qt6 6 5)'" ]' \
+ ${PN}/qt/machinery.py || die
+
+ # let eclass handle python
+ sed -i '/setup.py/d' misc/Makefile || die
+
+ # live version lacks pre-generated docs
+ [[ ${PV} != *9999 ]] || ${EPYTHON} scripts/asciidoc2html.py || die
+
+ # disable unnecessary tests/plugins that need extras (_ignore not enough)
+ sed -e '/pytest-benchmark/d' -e 's/--benchmark[^ ]*//' \
+ -e '/pytest-instafail/d' -e 's/--instafail//' \
+ -i pytest.ini || die
+ if [[ ${PV} == *9999 ]]; then
+ rm tests/unit/scripts/test_run_vulture.py || die
+ else
+ rm tests/unit/scripts/test_problemmatchers.py || die
+ fi
+}
+
+python_test() {
+ local -x PYTEST_QT_API=pyqt$(usex qt6 6 5)
+
+ local EPYTEST_DESELECT=(
+ # end2end and other IPC tests are broken with "Name error" if
+ # socket path is over ~104 characters (=124 in /var/tmp/portage)
+ # https://github.com/qutebrowser/qutebrowser/issues/888 (not just OSX)
+ tests/end2end
+ tests/unit/misc/test_ipc.py
+ # not worth running dbus over
+ tests/unit/browser/test_notification.py::TestDBus
+ # bug 819393
+ tests/unit/commands/test_userscripts.py::test_custom_env[_POSIXUserscriptRunner]
+ # calls eclass' python2 "failure" wrapper
+ tests/unit/misc/test_checkpyver.py::test_old_python
+ # qtargs are mangled with USE=widevine
+ $(usev widevine tests/unit/config/test_qtargs.py)
+ )
+
+ # single thread is slow, but do half+1 given spikes ram usage quickly
+ local jobs=$(($(makeopts_jobs) / 2 + 1))
+
+ # skip benchmarks (incl. _tree), and warning tests broken by -Wdefault
+ epytest -n ${jobs} -k 'not _bench and not _matches_tree and not _warning'
+}
+
+python_install_all() {
+ emake -f misc/Makefile DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
+
+ rm "${ED}"/usr/share/${PN}/scripts/{mkvenv,utils}.py || die
+ fperms -x /usr/share/${PN}/{scripts/cycle-inputs.js,userscripts/README.md}
+ python_fix_shebang "${ED}"/usr/share/${PN}
+
+ einstalldocs
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+
+ has_version "${CATEGORY}/${PN}[qt6]" && QUTEBROWSER_HAD_QT6=
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "PDF display support" www-plugins/pdfjs
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "Note that optional scripts in ${EROOT}/usr/share/${PN}/{user,}scripts"
+ elog "have additional dependencies not covered by this ebuild, for example"
+ elog "view_in_mpv needs media-video/mpv[lua] and net-misc/yt-dlp."
+ fi
+
+ if [[ ! -v QUTEBROWSER_HAD_QT6 ]] && use qt6; then
+ elog "USE=qt6 is enabled using the qt6-v2 branch, it is work-in-progress"
+ elog "and some issues are to be expected. Can follow upstream progress at:"
+ elog " https://github.com/qutebrowser/qutebrowser/issues/7202 [qt6 general]"
+ elog " https://github.com/qutebrowser/qutebrowser/tree/qt6-v2 [used branch]"
+ elog
+ elog "You may optionally want to backup your ~/.local/share/${PN} before"
+ elog "it is converted to use Qt6 WebEngine (one-way conversion). ${PN}"
+ elog "will also warn about this on launch for a last chance to abort."
+ fi
+
+ # TODO: left-out given be confusing while IUSE is masked anywhere
+# if use !qt6; then
+# ewarn "USE=qt6 is disabled, be warned that Qt5's WebEngine uses an older"
+# ewarn "chromium version. While it is relatively maintained for security, it may"
+# ewarn "cause issues for sites/features designed with a newer version in mind."
+# fi
+}