summaryrefslogtreecommitdiff
path: root/www-client/qutebrowser/qutebrowser-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /www-client/qutebrowser/qutebrowser-9999.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'www-client/qutebrowser/qutebrowser-9999.ebuild')
-rw-r--r--www-client/qutebrowser/qutebrowser-9999.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/www-client/qutebrowser/qutebrowser-9999.ebuild b/www-client/qutebrowser/qutebrowser-9999.ebuild
index 6e52913c8194..8e1dcf48ee29 100644
--- a/www-client/qutebrowser/qutebrowser-9999.ebuild
+++ b/www-client/qutebrowser/qutebrowser-9999.ebuild
@@ -5,6 +5,7 @@ EAPI=8
DISTUTILS_SINGLE_IMPL=1
DISTUTILS_USE_PEP517=setuptools
+# py3.11: wait for https://github.com/python/cpython/issues/93252
PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1 optfeature xdg
@@ -26,7 +27,7 @@ IUSE="+adblock widevine"
RDEPEND="
dev-qt/qtcore:5[icu]
dev-qt/qtgui:5[png]
- $(python_gen_cond_dep 'dev-python/importlib_resources[${PYTHON_USEDEP}]' python3_8)
+ $(python_gen_cond_dep 'dev-python/importlib_resources[${PYTHON_USEDEP}]' 3.8)
$(python_gen_cond_dep '
dev-python/colorama[${PYTHON_USEDEP}]
>=dev-python/jinja-3.0.2[${PYTHON_USEDEP}]
@@ -56,8 +57,8 @@ BDEPEND="
distutils_enable_tests pytest
-python_prepare_all() {
- distutils-r1_python_prepare_all
+src_prepare() {
+ distutils-r1_src_prepare
if use widevine; then
local widevine=${EPREFIX}/usr/$(get_libdir)/chromium-browser/WidevineCdm/_platform_specific/linux_x64/libwidevinecdm.so
@@ -92,6 +93,8 @@ python_test() {
tests/unit/misc/test_checkpyver.py::test_old_python
# bug 819393
tests/unit/commands/test_userscripts.py::test_custom_env[_POSIXUserscriptRunner]
+ # not worth running dbus over
+ tests/unit/browser/test_notification.py::TestDBus
)
use widevine && EPYTEST_DESELECT+=( tests/unit/config/test_qtargs.py )