summaryrefslogtreecommitdiff
path: root/www-client/lynx/lynx-2.9.0_pre9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-22 01:55:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-22 01:55:45 +0000
commitb2c59335bfbeb25c5644f32172e1e9b23c447710 (patch)
tree0e8e19f47e39be0a7b9b06cb86db760c6d6b5965 /www-client/lynx/lynx-2.9.0_pre9.ebuild
parent427ba64bd6bcdd59a1ae9bc7c5cec0299d135413 (diff)
gentoo auto-resync : 22:12:2022 - 01:55:45
Diffstat (limited to 'www-client/lynx/lynx-2.9.0_pre9.ebuild')
-rw-r--r--www-client/lynx/lynx-2.9.0_pre9.ebuild98
1 files changed, 0 insertions, 98 deletions
diff --git a/www-client/lynx/lynx-2.9.0_pre9.ebuild b/www-client/lynx/lynx-2.9.0_pre9.ebuild
deleted file mode 100644
index 1d0e795886c4..000000000000
--- a/www-client/lynx/lynx-2.9.0_pre9.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-case ${PV} in
- *_pre*) MY_P="${PN}${PV/_pre/dev.}" ;;
- *_rc*) MY_P="${PN}${PV/_rc/pre.}" ;;
- *_p*|*) MY_P="${PN}${PV/_p/rel.}" ;;
-esac
-
-DESCRIPTION="An excellent console-based web browser with ssl support"
-HOMEPAGE="https://lynx.invisible-island.net/"
-SRC_URI="https://invisible-mirror.net/archives/lynx/tarballs/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="bzip2 cjk gnutls idn nls ssl"
-
-RDEPEND="sys-libs/ncurses:=[unicode(+)]
- sys-libs/zlib
- bzip2? ( app-arch/bzip2 )
- idn? ( net-dns/libidn:0= )
- nls? ( virtual/libintl )
- ssl? (
- !gnutls? (
- dev-libs/openssl:0=
- )
- gnutls? (
- dev-libs/libgcrypt:0=
- >=net-libs/gnutls-2.6.4:=
- )
- )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- nls? ( sys-devel/gettext )"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}/${PN}-2.9.0_pre9-mint.patch"
- "${FILESDIR}/${PN}-2.9.0_pre9-parallel.patch"
-)
-
-src_configure() {
- local myconf=(
- --enable-cgi-links
- --enable-color-style
- --enable-externs
- --enable-file-upload
- --enable-included-msgs
- --enable-ipv6
- --enable-nested-tables
- --enable-nsl-fork
- --enable-persistent-cookies
- --enable-prettysrc
- --enable-read-eta
- --enable-scrollbar
- --with-screen=ncursesw
- --with-zlib
- $(use_enable cjk)
- $(use_enable idn idna)
- $(use_enable nls)
- $(use_with bzip2 bzlib)
- )
- if use ssl; then
- myconf+=(
- --with-$(usex gnutls gnutls ssl)="${EPREFIX}/usr"
- )
- fi
-
- econf "${myconf[@]}"
-
- # Compared to openssl gnutls-openssl API does not use
- # default trust store: bug #604526.
- sed -e \
- "s|#define SSL_CERT_FILE NULL|#define SSL_CERT_FILE \"${EPREFIX}/etc/ssl/certs/ca-certificates.crt\"|" \
- -i userdefs.h || die
-}
-
-src_compile() {
- # generating translation files in parallel is currently broken
- use nls && emake -C po -j1
- emake
-}
-
-src_install() {
- emake install DESTDIR="${D}"
-
- sed -i "s|^HELPFILE.*$|HELPFILE:file://localhost/usr/share/doc/${PF}/lynx_help/lynx_help_main.html|" \
- "${ED}"/etc/lynx.cfg || die "lynx.cfg not found"
- sed -i '/^#CHARACTER_SET:/ c\CHARACTER_SET:utf-8' \
- "${ED}"/etc/lynx.cfg || die "lynx.cfg not found"
-
- dodoc CHANGES COPYHEADER PROBLEMS README
- dodoc -r docs lynx_help
-}