summaryrefslogtreecommitdiff
path: root/www-client/links
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /www-client/links
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'www-client/links')
-rw-r--r--www-client/links/Manifest2
-rw-r--r--www-client/links/links-2.23.ebuild168
2 files changed, 170 insertions, 0 deletions
diff --git a/www-client/links/Manifest b/www-client/links/Manifest
index 7bfcd406046b..4a5b7757ecbd 100644
--- a/www-client/links/Manifest
+++ b/www-client/links/Manifest
@@ -1,3 +1,5 @@
DIST links-2.22.tar.bz2 6481705 BLAKE2B a6855fcc62377116fe61adb01623c0cd757ee47ae36bfb35ae657a6d6587f9e47b6b1f78ad73e3fca911ad4aee8c15f364d4af911d694f04229b107d10d6f422 SHA512 d2c9f764d64c2d73b85c998db9fc8c241556977380eef1f4041623ca306f5798227b2b57daecf09ee85e0b07f8738bdfe0b84fefc924d6e05d931e29d29ba40e
+DIST links-2.23.tar.bz2 6521143 BLAKE2B baefdadddc0d44511488ca1a085a45f3235b9c58ae6013c1efce495a33e86b96575eba6a15df4f14ea82b7d1ffb69ea312d5d5223ba9c605709bdb5d153ef6cb SHA512 3c233dab2e7e5ca72f582c5af9c5799b3d6c1a5a64d4e9e0209f78f347a245dc760c2340f71839fd42e1c9f358599b8baa12aa024938f2ab1b6424c8fb0b9a7d
EBUILD links-2.22.ebuild 3377 BLAKE2B 3d20a0be3d96ff064abc2c47895032fd5674cc1123e89f13d69b40a7208e821f13aab9f5ad5c50e87cae272059472e1c57d0ae3e095cda73171bbc6e8d56b584 SHA512 1d67d4b8d420894d6dc0d95ad430ab316204055c3bd5b5413cb7c277d19da218bb98d78effe4c47ab6f3d4a9a987108835ea46e40d2e865240e3ba429899cfb6
+EBUILD links-2.23.ebuild 3384 BLAKE2B 15d8e51a1bb6429f4c8da921834866ca2a076fb08ddebb4e9a919bd1ce2539a274e7d5079d14f26cf74ea704602dd9ff8ac2ccf401f86b693d37a01fffb090c2 SHA512 43cdfca23b0ba275c147fef5878f93805dfba5f084eae72527e7ed74e2c957d0d9e5f196eca34752202c89bd00379338a3ab4822c82e03ae2eac0977d40ff5dc
MISC metadata.xml 671 BLAKE2B a27e4d153f5b73c96a6e15b21306a3d47c1df9cc9492b115d58ddcf3af8ba8b7c5b51b985c32b31fd04e88b400022f1db873063fab519792aa18c67538f0b790 SHA512 6913a9c3b54ac53235f85ef4a4ba8c370b7ffa4fd429e2a3d1a065eab96ba5e36f35b704622c9599585cdcbad43e14783ef92934c0e250bc315a3d9754aac360
diff --git a/www-client/links/links-2.23.ebuild b/www-client/links/links-2.23.ebuild
new file mode 100644
index 000000000000..0b91e96ea46a
--- /dev/null
+++ b/www-client/links/links-2.23.ebuild
@@ -0,0 +1,168 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools desktop xdg-utils
+
+DESCRIPTION="A fast and lightweight web browser running in both graphics and text mode"
+HOMEPAGE="http://links.twibright.com/"
+SRC_URI="http://${PN}.twibright.com/download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="brotli bzip2 fbcon freetype gpm ipv6 jpeg libevent livecd lzip lzma ssl suid svga tiff unicode X zlib zstd"
+
+GRAPHICS_DEPEND="media-libs/libpng:0="
+
+RDEPEND="
+ brotli? (
+ app-arch/brotli
+ )
+ bzip2? (
+ app-arch/bzip2
+ )
+ fbcon? (
+ ${GRAPHICS_DEPEND}
+ )
+ freetype? (
+ media-libs/fontconfig
+ media-libs/freetype
+ )
+ gpm? (
+ sys-libs/gpm
+ )
+ jpeg? (
+ virtual/jpeg:0
+ )
+ libevent? (
+ dev-libs/libevent:0=
+ )
+ livecd? (
+ ${GRAPHICS_DEPEND}
+ sys-libs/gpm
+ virtual/jpeg:0
+ )
+ lzip? (
+ app-arch/lzip
+ )
+ lzma? (
+ app-arch/xz-utils
+ )
+ ssl? (
+ dev-libs/openssl:0=
+ )
+ svga? (
+ ${GRAPHICS_DEPEND}
+ media-libs/svgalib
+ )
+ tiff? (
+ media-libs/tiff:0
+ )
+ X? (
+ ${GRAPHICS_DEPEND}
+ x11-libs/libXext
+ )
+ zlib? (
+ sys-libs/zlib
+ )
+ zstd? (
+ app-arch/zstd
+ )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ fbcon? ( virtual/os-headers )
+ livecd? ( virtual/os-headers )
+ X? ( dev-util/desktop-file-utils )"
+
+REQUIRED_USE="!livecd? ( fbcon? ( gpm ) )
+ svga? ( suid )"
+
+DOCS=( AUTHORS BRAILLE_HOWTO ChangeLog KEYS NEWS README SITES )
+
+src_prepare() {
+ use X && xdg_environment_reset
+
+ if use unicode; then
+ pushd intl > /dev/null || die
+ ./gen-intl || die
+ ./synclang || die
+ popd > /dev/null || die
+ fi
+
+ # error: conditional "am__fastdepCXX" was never defined (for eautoreconf)
+ sed -i \
+ -e '/AC_PROG_CXX/s:dnl ::' \
+ -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' \
+ configure.in || die #467020
+
+ # Upstream configure produced by broken autoconf-2.13. This also fixes
+ # toolchain detection.
+ mv configure.in configure.ac || die
+
+ default
+ eautoreconf #131440 and #103483#c23
+}
+
+src_configure() {
+ local myconf
+
+ if use livecd; then
+ export ac_cv_lib_gpm_Gpm_Open=yes
+ myconf+=' --with-fb --with-libjpeg'
+ else
+ export ac_cv_lib_gpm_Gpm_Open=$(usex gpm)
+ fi
+
+ if use X || use fbcon || use svga || use livecd; then
+ myconf+=' --enable-graphics'
+ fi
+
+ econf \
+ --without-directfb \
+ --without-librsvg \
+ $(use_with brotli) \
+ $(use_with bzip2) \
+ $(use_with fbcon fb) \
+ $(use_with freetype) \
+ $(use_with ipv6) \
+ $(use_with jpeg libjpeg) \
+ $(use_with libevent) \
+ $(use_with lzip) \
+ $(use_with lzma) \
+ $(use_with ssl) \
+ $(use_with svga svgalib) \
+ $(use_with tiff libtiff) \
+ $(use_with X x) \
+ $(use_with zlib) \
+ $(use_with zstd) \
+ ${myconf}
+}
+
+src_install() {
+ HTML_DOCS="doc/links_cal/*"
+ default
+
+ if use X; then
+ newicon Links_logo.png links.png
+ make_desktop_entry 'links -g %u' Links links 'Network;WebBrowser'
+ local d="${ED}"/usr/share/applications
+ echo 'MimeType=x-scheme-handler/http;' >> "${d}"/*.desktop || die
+ if use ssl; then
+ sed -i -e 's:x-scheme-handler/http;:&x-scheme-handler/https;:' \
+ "${d}"/*.desktop || die
+ fi
+ fi
+
+ use suid && fperms 4755 /usr/bin/links
+}
+
+pkg_postinst() {
+ use X && xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ use X && xdg_desktop_database_update
+}