summaryrefslogtreecommitdiff
path: root/www-client/falkon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-02 15:59:12 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-02 15:59:12 +0000
commit06a7b5647e11a8ddf69b1c3d3ded6a8ba28b923e (patch)
tree8d58c1f4b049da677b33209b072f2b3057268fe0 /www-client/falkon
parent99abbc5e5a6ecd3fc981b45646fd8cb5d320377b (diff)
gentoo resync : 02.03.2018
Diffstat (limited to 'www-client/falkon')
-rw-r--r--www-client/falkon/Manifest3
-rw-r--r--www-client/falkon/falkon-3.0.0.ebuild64
-rw-r--r--www-client/falkon/metadata.xml11
3 files changed, 78 insertions, 0 deletions
diff --git a/www-client/falkon/Manifest b/www-client/falkon/Manifest
new file mode 100644
index 000000000000..058e14fedf18
--- /dev/null
+++ b/www-client/falkon/Manifest
@@ -0,0 +1,3 @@
+DIST falkon-3.0.0.tar.xz 1985800 BLAKE2B 8505e2c91600d265c28f70c37bf9e8f669ecd907dd9263371a4a4c10b854d32415ec1a3fd6ac163b297d0a9f42c542d4691a6cd417ed81864585f0c66b769e34 SHA512 1d99ecd47022986570dd6bb9b57484abe30838bf52daf669c977e1d2a9381efdd60912fd72b97e0b43b6102159f4343c4d1589d4f6442d0ed62c24f1482a8d97
+EBUILD falkon-3.0.0.ebuild 1583 BLAKE2B 518f7ef4219a2b3bf3bd24842075e1427355182b441a1f35cdd7aab0c743375553856e95a7db7bd8566169319d953e5bffb650b97d1b8338dcaba7d58b3b5cbc SHA512 8425a175b9dce7976ee78cfd83e4a43a08529176ece6d3fefe560f73a52d3cae8ef637dc5a40d6f4b83fe146d543ea9e902ee4671de7ef47ba54927bdcda9384
+MISC metadata.xml 369 BLAKE2B de669dca0f4ec7ab36e7dfb4fc71d68bf8e5f829e0501be7f1e68cd1d8e0866e48ea53396f6c1cf37333032b1254744430d57a17b7cc5c52677b6606dbdb66d5 SHA512 befbc1782dffeb3f3cb44fe7046a8b44037268ee741e774e30dff433b624e6488e4edb09d3c5e796721a16b8887d1df334a70cb26326ae71401db8e7d14f0304
diff --git a/www-client/falkon/falkon-3.0.0.ebuild b/www-client/falkon/falkon-3.0.0.ebuild
new file mode 100644
index 000000000000..6da8f0a0600f
--- /dev/null
+++ b/www-client/falkon/falkon-3.0.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_TEST="true"
+QT_MINIMAL="5.9.2"
+inherit kde5
+
+DESCRIPTION="Cross-platform web browser using QtWebEngine"
+HOMEPAGE="https://www.qupzilla.com/"
+if [[ ${KDE_BUILD_TYPE} != live ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${PV%.0}/src/${P}.tar.xz"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus gnome-keyring kwallet libressl +X"
+
+COMMON_DEPEND="
+ $(add_qt_dep qtdeclarative 'widgets')
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork 'ssl')
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtsql 'sqlite')
+ $(add_qt_dep qtwebchannel)
+ $(add_qt_dep qtwebengine 'widgets')
+ $(add_qt_dep qtwidgets)
+ dbus? ( $(add_qt_dep qtdbus) )
+ gnome-keyring? ( gnome-base/gnome-keyring )
+ kwallet? ( $(add_frameworks_dep kwallet) )
+ libressl? ( dev-libs/libressl:= )
+ !libressl? ( dev-libs/openssl:0= )
+ X? (
+ $(add_qt_dep qtx11extras)
+ x11-libs/libxcb:=
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_qt_dep linguist-tools)
+ $(add_qt_dep qtconcurrent)
+ gnome-keyring? ( virtual/pkgconfig )
+"
+RDEPEND="${COMMON_DEPEND}
+ !www-client/qupzilla
+ $(add_qt_dep qtsvg)
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_DBUS=$(usex !dbus)
+ -DBUILD_KEYRING=$(usex gnome-keyring)
+ $(cmake-utils_use_find_package kwallet KF5Wallet)
+ -DNO_X11=$(usex !X)
+ )
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+ elog "If you were previously using QupZilla, you can manually migrate your profiles"
+ elog "by moving the config directory from ~/.config/qupzilla to ~/.config/falkon"
+}
diff --git a/www-client/falkon/metadata.xml b/www-client/falkon/metadata.xml
new file mode 100644
index 000000000000..007c58ff2baa
--- /dev/null
+++ b/www-client/falkon/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>qt@gentoo.org</email>
+ <name>Gentoo Qt Project</name>
+ </maintainer>
+ <use>
+ <flag name="kwallet">Enable encrypted storage of passwords with <pkg>kde-frameworks/kwallet</pkg></flag>
+ </use>
+</pkgmetadata>