summaryrefslogtreecommitdiff
path: root/www-client/elinks
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-03 00:07:26 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-03 00:07:26 +0100
commita3bb28551df94028000fb72308a9e9baa01458b0 (patch)
tree33b14c7bf0dffbd5bb04dbd5b395514ebdda4896 /www-client/elinks
parent6657c680376cedf378fcf328e5fa03ed3b41d580 (diff)
gentoo auto-resync : 03:06:2024 - 00:07:25
Diffstat (limited to 'www-client/elinks')
-rw-r--r--www-client/elinks/Manifest3
-rw-r--r--www-client/elinks/elinks-0.16.1.1-r3.ebuild187
-rw-r--r--www-client/elinks/elinks-9999.ebuild16
3 files changed, 199 insertions, 7 deletions
diff --git a/www-client/elinks/Manifest b/www-client/elinks/Manifest
index 735703175a20..95de0c481520 100644
--- a/www-client/elinks/Manifest
+++ b/www-client/elinks/Manifest
@@ -1,5 +1,6 @@
AUX elinks-0.16.1.1-perl-5.38.patch 1527 BLAKE2B 1a39c77ef9d29490c745e58998e6798dbb74faf399a50cbba32beac2b5e09ec55f047594d120c9c8db79201ef0f24633e5cd96b16a7eb9c201a061bf5372636b SHA512 64dbe341b15eea0cb0795909e745f74bee17ff6a3e38425a3fc48c5881fccf48d510ca4e2737e44e87dee9700b774a86700ec256a5fc0c6fe6540fca0ad33d2e
DIST elinks-0.16.1.1.tar.xz 2037292 BLAKE2B 05578eaa7a88f0abe4472b876a1f72645d32119ce807a61962f8d24a5b444240d3b94189bf25142c0e51e2d404d5992ace07ecc23ef1316d5f3942736b265267 SHA512 49e03ff4766e29b6fd4324d226e415ca1329a84d4a44fac40ecd72186dd104de88c3e541810a008dc6f1d1ed889a45edbef159cbc6ac3860756ca21261ffec8a
EBUILD elinks-0.16.1.1-r2.ebuild 4769 BLAKE2B e141e9a71a8a20dec53491bfa2178a58c920d1592970883fc169850b48f6b7dea4bbbc1cfb10676f3c287f5bceb55e681a048c531f549093019ad3bfb6245229 SHA512 62b64d6335da8478ee7ee5bc89b0eae20207fb3bcf51b65147d10e60b3495d1e6e4586d6d575efa2742aee9b3f757b8bf5384cc706d3f4578ea41fd7e8fda7a8
-EBUILD elinks-9999.ebuild 4718 BLAKE2B 444631466adeea0a6b528e7108537345ca6460246338dfbd3ea9078ff3677b1e52dedbddb7b37dc1b591df495db72d3c524d694a51c22a58875de8e246201ab3 SHA512 96da6f39a97c079a9064fa24757f0f27f21f727472fab90373d71b46aa9cd2878e1a7dc95c18a2421188b033d4aaa654cdf6b716545117c381cb8e838aaecc31
+EBUILD elinks-0.16.1.1-r3.ebuild 4875 BLAKE2B 0aac775dfbf7f58c4a1e0fbcb670efca6553bf61e9e84a326aa18a911004065767296b8916762a9ac09f0fc3643b58e161a739b64da745ed6e9a1e42ee6ad8d0 SHA512 a57d29a004232103edbfe5b1c0e5a6616b09441fb65722d648b1c04c8bcd14d10f5d46bf644eabf4afec02eb3150400ef6a78672a9bb89d5cf1c62fa25b6344e
+EBUILD elinks-9999.ebuild 4818 BLAKE2B d1290f6f99f4bf2b6664226dfe7ddcfd29aaccc06f44a821e46ed6970d459ee35a368b3d2648f08d5eaf505e031abc81ec97a74d8e9ff5a9dc49e1be2ce5ba87 SHA512 889cd16fb6ad851d2c1668538179bb430586b88b58de193ede00a8b588872a3d48da53ed5432c4a71513e36337ace59e0f5c4022d63d370bd520345de0a4811f
MISC metadata.xml 938 BLAKE2B 93a927137d89d306b73f04faad6f43714b00349810b0531e274b90d086fda7285d992734263dee5b5274857af1d615e61871d9348e0e8dc759717a7fc4332e50 SHA512 9ba6c3d9228c5f74304447d469afa2ff2984fa3d637faaee7946d442b979c6c99eab87726b4f88aef4af43c515f3105c97fc8d6d64965794bbd6c4c539ac199c
diff --git a/www-client/elinks/elinks-0.16.1.1-r3.ebuild b/www-client/elinks/elinks-0.16.1.1-r3.ebuild
new file mode 100644
index 000000000000..f879db1c426e
--- /dev/null
+++ b/www-client/elinks/elinks-0.16.1.1-r3.ebuild
@@ -0,0 +1,187 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+LUA_COMPAT=( lua5-{1,2,3,4} luajit )
+
+inherit flag-o-matic meson lua-single python-single-r1
+
+DESCRIPTION="Advanced and well-established text-mode web browser"
+HOMEPAGE="http://elinks.or.cz/"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/rkd77/felinks"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/rkd77/elinks/releases/download/v${PV}/${P}.tar.xz"
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="bittorrent brotli bzip2 debug finger ftp gopher gpm gnutls guile idn"
+IUSE+=" javascript lua lzma +mouse nls nntp perl python samba ssl test tre unicode X xml zlib zstd"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="
+ lua? ( ${LUA_REQUIRED_USE} )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+RDEPEND="
+ >=sys-libs/ncurses-5.2:=[unicode(+)]
+ brotli? ( app-arch/brotli:= )
+ bzip2? ( >=app-arch/bzip2-1.0.2 )
+ gpm? (
+ >=sys-libs/gpm-1.20.0-r5
+ )
+ guile? ( >=dev-scheme/guile-1.6.4-r1[deprecated] )
+ idn? ( net-dns/libidn:= )
+ javascript? (
+ dev-cpp/libxmlpp:5.0
+ dev-lang/mujs:=
+ )
+ lua? ( ${LUA_DEPS} )
+ lzma? ( app-arch/xz-utils )
+ perl? ( dev-lang/perl:= )
+ python? ( ${PYTHON_DEPS} )
+ samba? ( net-fs/samba )
+ ssl? (
+ !gnutls? ( dev-libs/openssl:= )
+ gnutls? ( net-libs/gnutls:= )
+ )
+ tre? ( dev-libs/tre )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXt
+ )
+ xml? ( >=dev-libs/expat-1.95.4 )
+ zlib? ( >=sys-libs/zlib-1.1.4 )
+ zstd? ( app-arch/zstd:= )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )"
+BDEPEND="
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+ test? (
+ net-dns/libidn
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.16.1.1-perl-5.38.patch
+)
+
+pkg_setup() {
+ use lua && lua-single_pkg_setup
+
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ # This file is severely broken w.r.t. strict-aliasing and upstream acknowledges it:
+ # https://github.com/rkd77/elinks/blob/d05ce90b35d82109aab320b490e3ca54aa6df057/src/util/lists.h#L14
+ # https://github.com/rkd77/elinks/blob/d05ce90b35d82109aab320b490e3ca54aa6df057/src/meson.build#L44
+ #
+ # Although they force fno-strict-aliasing, they do so inconsistently and not for the testsuite (!!!).
+ # Just add it again.
+ #
+ # DO not trust the LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
+ local emesonargs=(
+ -Ddocdir="${EPREFIX}"/usr/share/doc/${PF}
+ -Dhtmldoc=false
+ -Dpdfdoc=false
+ -Dapidoc=false
+ -D88-colors=true
+ -D256-colors=true
+ $(meson_use bittorrent)
+ $(meson_use brotli)
+ $(meson_use bzip2 bzlib)
+ $(usex debug '-Ddebug=true' '-Dfastmem=true')
+ $(meson_use finger)
+ $(meson_use ftp)
+ -Dfsp=false
+ -Dgemini=false
+ $(meson_use nls gettext)
+ $(meson_use gopher)
+ $(meson_use gpm)
+ $(meson_use guile)
+ -Dgssapi=false
+ -Dhtml-highlight=true
+ $(meson_use idn)
+ $(meson_use javascript mujs)
+ -Dipv6=true
+ -Dleds=true
+ -Dlibev=false
+ -Dlibevent=false
+ -Dluapkg=$(usex lua ${ELUA:-0} '')
+ $(meson_use lzma)
+ $(meson_use mouse)
+ #-Dmujs=false
+ $(meson_use nls)
+ $(meson_use nntp)
+ $(meson_use perl)
+ $(meson_use python)
+ -Dquickjs=false
+ -Druby=false
+ $(meson_use samba smb)
+ -Dsm-scripting=false
+ -Dspidermonkey=false
+ -Dterminfo=true
+ $(meson_use test)
+ $(meson_use tre)
+ -Dtrue-color=true
+ $(meson_use xml xbel)
+ $(meson_use X x)
+ $(meson_use zlib)
+ $(meson_use zstd)
+ )
+
+ if use ssl ; then
+ if use gnutls ; then
+ emesonargs+=( -Dgnutls=true )
+ else
+ emesonargs+=( -Dopenssl=true)
+ fi
+ else
+ emesonargs+=( -Dgnutls=false -Dopenssl=false )
+ fi
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ insinto /etc/elinks
+ newins contrib/keybind-full.conf keybind-full.sample
+ newins contrib/keybind.conf keybind.conf.sample
+
+ dodoc AUTHORS BUGS ChangeLog INSTALL NEWS README SITES THANKS TODO doc/*.*
+ docinto contrib ; dodoc contrib/{README,colws.diff,elinks[-.]vim*}
+ docinto contrib/lua ; dodoc contrib/lua/{*.lua,elinks-remote}
+ docinto contrib/conv ; dodoc contrib/conv/*.*
+ docinto contrib/guile ; dodoc contrib/guile/*.scm
+
+ # elinks uses an internal copy of gettext which ships files that may
+ # collide with the system's gettext (https://bugs.gentoo.org/635090)
+ rm -f "${ED}"/usr/{share/locale/locale,lib/charset}.alias || die
+}
+
+pkg_postinst() {
+ elog "You may want to convert your html.cfg and links.cfg of"
+ elog "Links or older ELinks versions to the new ELinks elinks.conf"
+ elog "using ${EROOT}/usr/share/doc/${PF}/contrib/conv/conf-links2elinks.pl"
+ elog
+ elog "Please have a look at ${EROOT}/etc/elinks/keybind-full.sample and"
+ elog "${EROOT}/etc/elinks/keybind.conf.sample for some bindings examples."
+ elog
+ elog "You will have to set your TERM variable to 'xterm-256color'"
+ elog "to be able to use 256 colors in elinks."
+}
diff --git a/www-client/elinks/elinks-9999.ebuild b/www-client/elinks/elinks-9999.ebuild
index 7611b9f21af9..414f0f24a9ec 100644
--- a/www-client/elinks/elinks-9999.ebuild
+++ b/www-client/elinks/elinks-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{10..11} )
LUA_COMPAT=( lua5-{1,2,3,4} luajit )
-inherit flag-o-matic meson lua-single python-any-r1
+inherit flag-o-matic meson lua-single python-single-r1
DESCRIPTION="Advanced and well-established text-mode web browser"
HOMEPAGE="http://elinks.or.cz/"
@@ -23,9 +23,12 @@ fi
LICENSE="GPL-2"
SLOT="0"
IUSE="bittorrent brotli bzip2 debug finger ftp gopher gpm gnutls guile idn"
-IUSE+=" javascript lua lzma +mouse nls nntp perl samba ssl test tre unicode X xml zlib zstd"
+IUSE+=" javascript lua lzma +mouse nls nntp perl python samba ssl test tre unicode X xml zlib zstd"
RESTRICT="!test? ( test )"
-REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
+REQUIRED_USE="
+ lua? ( ${LUA_REQUIRED_USE} )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
RDEPEND="
>=sys-libs/ncurses-5.2:=[unicode(+)]
@@ -43,6 +46,7 @@ RDEPEND="
lua? ( ${LUA_DEPS} )
lzma? ( app-arch/xz-utils )
perl? ( dev-lang/perl:= )
+ python? ( ${PYTHON_DEPS} )
samba? ( net-fs/samba )
ssl? (
!gnutls? ( dev-libs/openssl:= )
@@ -60,7 +64,6 @@ RDEPEND="
DEPEND="${RDEPEND}
X? ( x11-base/xorg-proto )"
BDEPEND="
- ${PYTHON_DEPS}
virtual/pkgconfig
nls? ( sys-devel/gettext )
test? (
@@ -71,7 +74,7 @@ BDEPEND="
pkg_setup() {
use lua && lua-single_pkg_setup
- python-any-r1_pkg_setup
+ use python && python-single-r1_pkg_setup
}
src_configure() {
@@ -90,6 +93,7 @@ src_configure() {
-Ddocdir="${EPREFIX}"/usr/share/doc/${PF}
-Dhtmldoc=false
-Dpdfdoc=false
+ -Dapidoc=false
-D88-colors=true
-D256-colors=true
$(meson_use bittorrent)
@@ -119,7 +123,7 @@ src_configure() {
$(meson_use nls)
$(meson_use nntp)
$(meson_use perl)
- -Dpython=false
+ $(meson_use python)
-Dquickjs=false
-Druby=false
$(meson_use samba smb)