summaryrefslogtreecommitdiff
path: root/www-client/elinks/elinks-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-09 16:53:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-09 16:53:27 +0000
commit80208fb578cf92cc308906660ca6d7860c6b2a1f (patch)
tree6f06818031b553c506fc10dfe9908a835df288aa /www-client/elinks/elinks-9999.ebuild
parent06a7b5647e11a8ddf69b1c3d3ded6a8ba28b923e (diff)
gentoo resync : 09.03.2018
Diffstat (limited to 'www-client/elinks/elinks-9999.ebuild')
-rw-r--r--www-client/elinks/elinks-9999.ebuild96
1 files changed, 47 insertions, 49 deletions
diff --git a/www-client/elinks/elinks-9999.ebuild b/www-client/elinks/elinks-9999.ebuild
index 871ec4ab5abb..5f0bf215d165 100644
--- a/www-client/elinks/elinks-9999.ebuild
+++ b/www-client/elinks/elinks-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -8,7 +8,6 @@ inherit autotools git-r3 python-any-r1
EGIT_REPO_URI="https://github.com/rkd77/felinks"
-MY_P="${P/_/}"
DESCRIPTION="Advanced and well-established text-mode web browser"
HOMEPAGE="http://elinks.or.cz/"
@@ -17,14 +16,13 @@ SLOT="0"
KEYWORDS=""
IUSE="bittorrent brotli bzip2 debug finger ftp gopher gpm guile idn ipv6
javascript libressl lua +mouse nls nntp perl ruby samba ssl tre unicode X xml zlib"
-RESTRICT="test"
DEPEND="
${PYTHON_DEPS}
brotli? ( app-arch/brotli )
bzip2? ( >=app-arch/bzip2-1.0.2 )
gpm? ( >=sys-libs/ncurses-5.2:0= >=sys-libs/gpm-1.20.0-r5 )
- guile? ( >=dev-scheme/guile-1.6.4-r1[deprecated,discouraged] )
+ guile? ( >=dev-scheme/guile-1.6.4-r1[deprecated] )
idn? ( net-dns/libidn )
javascript? ( >=dev-lang/spidermonkey-1.8.5:0= )
lua? ( >=dev-lang/lua-5:0= )
@@ -59,53 +57,53 @@ src_prepare() {
}
src_configure() {
- local myconf=""
+ local myconf=(
+ --sysconfdir="${EPREFIX}"/etc/elinks
+ --enable-leds
+ --enable-88-colors
+ --enable-256-colors
+ --enable-true-color
+ --enable-html-highlight
+ $(use_with gpm)
+ $(use_with brotli)
+ $(use_with bzip2 bzlib)
+ $(use_with guile)
+ $(use_with idn)
+ $(use_with javascript spidermonkey)
+ $(use_with lua)
+ $(use_with perl)
+ $(use_with ruby)
+ $(use_with tre)
+ $(use_with X x)
+ $(use_with zlib)
+ $(use_enable bittorrent)
+ $(use_enable finger)
+ $(use_enable ftp)
+ $(use_enable gopher)
+ $(use_enable ipv6)
+ $(use_enable mouse)
+ $(use_enable nls)
+ $(use_enable nntp)
+ $(use_enable samba smb)
+ $(use_enable xml xbel)
+ )
if use debug ; then
- myconf="--enable-debug"
+ myconf+=( --enable-debug )
else
- myconf="--enable-fastmem"
+ myconf+=( --enable-fastmem )
fi
# NOTE about GNUTSL SSL support (from the README -- 25/12/2002)
# As GNUTLS is not yet 100% stable and its support in ELinks is not so well
# tested yet, it's recommended for users to give a strong preference to OpenSSL whenever possible.
if use ssl ; then
- myconf="${myconf} --with-openssl=${EPREFIX}/usr"
+ myconf+=( --with-openssl="${EPREFIX}"/usr )
else
- myconf="${myconf} --without-openssl --without-gnutls"
+ myconf+=( --without-openssl --without-gnutls )
fi
- econf \
- --sysconfdir="${EPREFIX}"/etc/elinks \
- --enable-leds \
- --enable-88-colors \
- --enable-256-colors \
- --enable-true-color \
- --enable-html-highlight \
- $(use_with gpm) \
- $(use_with brotli) \
- $(use_with bzip2 bzlib) \
- $(use_with guile) \
- $(use_with idn) \
- $(use_with javascript spidermonkey) \
- $(use_with lua) \
- $(use_with perl) \
- $(use_with ruby) \
- $(use_with tre) \
- $(use_with X x) \
- $(use_with zlib) \
- $(use_enable bittorrent) \
- $(use_enable finger) \
- $(use_enable ftp) \
- $(use_enable gopher) \
- $(use_enable ipv6) \
- $(use_enable mouse) \
- $(use_enable nls) \
- $(use_enable nntp) \
- $(use_enable samba smb) \
- $(use_enable xml xbel) \
- ${myconf}
+ econf "${myconf[@]}"
}
src_compile() {
@@ -126,18 +124,18 @@ src_install() {
docinto contrib/guile ; dodoc contrib/guile/*.scm
# elinks uses an internal copy of gettext which ships files that may
- # colliding with the system's gettext (https://bugs.gentoo.org/635090)
+ # collide with the system's gettext (https://bugs.gentoo.org/635090)
rm -f "${ED}"/usr/{share/locale/locale,lib/charset}.alias || die
}
pkg_postinst() {
- einfo "You may want to convert your html.cfg and links.cfg of"
- einfo "Links or older ELinks versions to the new ELinks elinks.conf"
- einfo "using /usr/share/doc/${PF}/contrib/conv/conf-links2elinks.pl"
- einfo
- einfo "Please have a look at /etc/elinks/keybind-full.sample and"
- einfo "/etc/elinks/keybind.conf.sample for some bindings examples."
- einfo
- einfo "You will have to set your TERM variable to 'xterm-256color'"
- einfo "to be able to use 256 colors in elinks."
+ elog "You may want to convert your html.cfg and links.cfg of"
+ elog "Links or older ELinks versions to the new ELinks elinks.conf"
+ elog "using /usr/share/doc/${PF}/contrib/conv/conf-links2elinks.pl"
+ elog
+ elog "Please have a look at /etc/elinks/keybind-full.sample and"
+ elog "/etc/elinks/keybind.conf.sample for some bindings examples."
+ elog
+ elog "You will have to set your TERM variable to 'xterm-256color'"
+ elog "to be able to use 256 colors in elinks."
}