summaryrefslogtreecommitdiff
path: root/www-apps
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-15 02:02:03 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-15 02:02:03 +0000
commit16a4365c3b854e62b50726456ddb29bb78fd5038 (patch)
tree6de11adc70daeb6424485bb16be162d2cb277018 /www-apps
parent59d772d9463f8cf6a145a677bedbf377a0625aff (diff)
gentoo auto-resync : 15:12:2024 - 02:02:03
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/Manifest.gzbin13134 -> 13131 bytes
-rw-r--r--www-apps/gitea/Manifest2
-rw-r--r--www-apps/gitea/gitea-1.22.6.ebuild150
3 files changed, 152 insertions, 0 deletions
diff --git a/www-apps/Manifest.gz b/www-apps/Manifest.gz
index 63e46ab10d05..79ec43c0bcad 100644
--- a/www-apps/Manifest.gz
+++ b/www-apps/Manifest.gz
Binary files differ
diff --git a/www-apps/gitea/Manifest b/www-apps/gitea/Manifest
index 28612c27815a..715f287b2efd 100644
--- a/www-apps/gitea/Manifest
+++ b/www-apps/gitea/Manifest
@@ -2,5 +2,7 @@ AUX gitea.confd-r1 243 BLAKE2B 87caa8371f53f52b0a85f720342f9f358dedec9240ab78998
AUX gitea.initd-r3 802 BLAKE2B 2e33e95f7d2762986184d45b0bbb250cc5e04fffc4e4b006233b28e5b57be69eef1d83441adebe2b94681585edaf77f9da4eb97930f91e75c1b1a5cd8d137633 SHA512 5ff2e653180a0601734fcd055dfffdfdc12363736ed2e56c8576c802398b90f4025b44002cbb9a3fd1e0c2d4c169f62d460381c6c549746d3390e55fc1c677d1
AUX gitea.service-r4 730 BLAKE2B 0a1f799bf341f1a067f417aa21c1ce5c3168fe523081ef1711483d469da71699a2c163f1db008f7724329d6b6a819b1cdc76bc16309691522ebfc5dc9dfa7476 SHA512 cdd13299115e632bc474f24af6d4114b36be6489e11dd8c46b22fbd3f122194d4891cd2452f1654ef9256978fa4d0b6c11c08e386138a6cba29ea69945de8797
DIST gitea-1.22.3.tar.gz 54325752 BLAKE2B e556dab98ea210e6bd6106addd7a019b380ffa624010eb095f5042fbf060febc8769192532a3d3506160e9d447a9e7831dbcb8fed87e6e4ecea169cbc3382c75 SHA512 a659c6eb70c01b8776e4533bca8b55bf3a4f276b43564323946076297f7f12486c0f7f872d835dcbaad62b7f79847c42c922db566f156db23f5c33140e46c39e
+DIST gitea-1.22.6.tar.gz 54465618 BLAKE2B 221d30c680eddd7e1aad0f906ffff5a7e564d153f8977a99a3a965d725cef0bf601a7b6c3bbd4fcc235f0a0f58ec1eb39635da3bc85d59e6856384123898a193 SHA512 a36522eeaa89dd1352ad2540966f7306416d8bb85a5e5ef8cbb52e489fd274c69b95e87e60a28aaed0adf7c12c07a66572b401f784edfd117f859bf4265961f7
EBUILD gitea-1.22.3.ebuild 5358 BLAKE2B 12cfe2f5a7e458d2ed3f9fcbf2378d2557db79663a6bfdc015ecd1e64566416ad3b1ca8e15309683d080348a465d26f8ca65f8c6862434f9b516160450e059f2 SHA512 ebbc2570e203adb6be5509c9bd2aaeaeaa5e6af65018f34c0252f21545c5dd1a89238288be7cda744a1caa4dde2b87841e8345819cd162b1e86d4cbdd1220ff3
+EBUILD gitea-1.22.6.ebuild 5359 BLAKE2B ac3065332b96b4ba71b9178264367f77d9b6a6205ff05ce9962abca7ae9047f3e43cbba3c3af23d1893c37122c9cb8977971065f8035144750ccfff8640ee0fe SHA512 4bfc51161608ada0f7a2f9b3960063785a26638dc017a85eec169fa0a72a6fd0bea796b9c1c5a3da5165b5b9376fa80523e130c55cd41081ad951fd2e53cd924
MISC metadata.xml 754 BLAKE2B 0880dba11ea8bd584aa4dbebd94fbb5073e2ece2694152d7c1c7b8eaf531fbc0d314d98405c050e31a025e7031fd2476129347fc4a3643ffd0cc38aeebbee676 SHA512 58f218fac259cf5d11f288f079786323f1e76cd5e5e7503b4efe68ae86fb9d8d76773b1a9eed4872dabb9cf20f337509fc52d20bba7c60d7fb83b04adffa0e30
diff --git a/www-apps/gitea/gitea-1.22.6.ebuild b/www-apps/gitea/gitea-1.22.6.ebuild
new file mode 100644
index 000000000000..dd49814314cb
--- /dev/null
+++ b/www-apps/gitea/gitea-1.22.6.ebuild
@@ -0,0 +1,150 @@
+# Copyright 2016-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit fcaps go-module tmpfiles systemd flag-o-matic user-info
+
+DESCRIPTION="A painless self-hosted Git service"
+HOMEPAGE="https://gitea.com https://github.com/go-gitea/gitea"
+
+SRC_URI="https://github.com/go-gitea/gitea/releases/download/v${PV}/gitea-src-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-src-${PV}"
+LICENSE="Apache-2.0 BSD BSD-2 CC0-1.0 ISC MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+IUSE="+acct gogit pam sqlite pie"
+
+DEPEND="
+ acct? (
+ acct-group/git
+ acct-user/git[gitea] )
+ pam? ( sys-libs/pam )"
+RDEPEND="${DEPEND}
+ !gogit? ( dev-vcs/git )"
+BDEPEND=">=dev-lang/go-1.22:="
+
+DOCS=(
+ custom/conf/app.example.ini CHANGELOG.md CONTRIBUTING.md README.md
+)
+FILECAPS=(
+ -m 711 cap_net_bind_service+ep usr/bin/gitea
+)
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+
+ sed -i -e "s#^MODE = console#MODE = file#" custom/conf/app.example.ini || die
+}
+
+src_configure() {
+ # bug 832756 - PIE build issues
+ filter-flags -fPIE
+ filter-ldflags -fPIE -pie
+}
+
+src_compile() {
+ local gitea_tags
+ local -a gitea_settings makeenv
+
+ # The space-separated list of the -tags flag is deprecated, please
+ # always use the comma-separated list in the future.
+ gitea_tags="bindata"
+ gitea_tags+="$(usex gogit ',gogit' '')"
+ gitea_tags+="$(usex pam ',pam' '')"
+ gitea_tags+="$(usex sqlite ',sqlite,sqlite_unlock_notify' '')"
+
+ gitea_settings=(
+ "-X code.gitea.io/gitea/modules/setting.CustomConf=${EPREFIX}/etc/gitea/app.ini"
+ "-X code.gitea.io/gitea/modules/setting.CustomPath=${EPREFIX}/var/lib/gitea/custom"
+ "-X code.gitea.io/gitea/modules/setting.AppWorkPath=${EPREFIX}/var/lib/gitea"
+ )
+
+ makeenv=(
+ LDFLAGS="-extldflags \"${LDFLAGS}\" ${gitea_settings[*]}"
+ TAGS="${gitea_tags}"
+ )
+
+ if use pie ; then
+ # Please check the supported platforms when a new keyword request opened,
+ # refer to file: 'go/src/internal/platform/supported.go'.
+ # When PIE buildmode is not supported by internal linker, the external
+ # linker will be used automatically, refer to:
+ # https://github.com/golang/go/blob/ed817f1c4055a559a94afffecbb91c78e4f39942/src/cmd/link/internal/ld/config.go#L149
+ makeenv+=( EXTRA_GOFLAGS="-buildmode=pie" )
+ fi
+
+ env "${makeenv[@]}" emake backend
+}
+
+src_install() {
+ dobin gitea
+
+ einstalldocs
+
+ newconfd "${FILESDIR}/gitea.confd-r1" gitea
+ newinitd "${FILESDIR}/gitea.initd-r3" gitea
+ newtmpfiles - gitea.conf <<-EOF
+ d /run/gitea 0755 git git
+ EOF
+ systemd_newunit "${FILESDIR}"/gitea.service-r4 gitea.service
+
+ insinto /etc/gitea
+ newins custom/conf/app.example.ini app.ini
+ if use acct; then
+ fowners root:git /etc/gitea/{,app.ini}
+ fperms g+w,o-rwx /etc/gitea/{,app.ini}
+
+ diropts -m0750 -o git -g git
+ keepdir /var/lib/gitea /var/lib/gitea/custom /var/lib/gitea/data
+ keepdir /var/log/gitea
+ fi
+}
+
+pkg_postinst() {
+ fcaps_pkg_postinst
+
+ # It is not guaranteed that the git user and group always exist (due to the acct USE Flag),
+ # but for convenience, the tmpfile uses the git user and group by default.
+ # To avoid installation errors, a condition needs to be added here:
+ # if there is no git user or group, the installation of tmpfile will be skipped
+ # and the user will be notified to handle it by themselves.
+ if egetent passwd git &>/dev/null && \
+ egetent group git &>/dev/null; then
+ tmpfiles_process gitea.conf
+ else
+ eerror "Unable to install the tmpfile for gitea due to the git user or group is missing,"
+ eerror "please install tmpfile manually or rebuild this package with USE flag 'acct'."
+ eerror "You can simply copy the default tmpfile from '/usr/lib/tmpfiles.d/gitea.conf'"
+ eerror "to higher priority path '/etc/tmpfiles.d/gitea.conf', and correct it with"
+ eerror "the right User and Group value (see tmpfiles.d(5) for details), then execute:"
+ eerror " # systemd-tmpfiles --create /etc/tmpfiles.d/gitea.conf"
+ eerror "to install it."
+ fi
+
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ if ver_test "${REPLACING_VERSIONS}" -lt 1.21; then
+ ewarn "Since version 1.21.0:"
+ ewarn " 1. The built-in SSH server will now only accept SSH user"
+ ewarn " certificates, not server certificates. This behaviour matches OpenSSH."
+ ewarn " 2. The options of the subcommand must follow the subcommand now."
+ ewarn " 3. Remove 'CHARSET' config option for MySQL, always use 'utf8mb4'."
+ ewarn "For other breaking changes, see <https://github.com/go-gitea/gitea/releases/tag/v1.21.0>."
+ fi
+ if ver_test "${REPLACING_VERSIONS}" -lt 1.22; then
+ ewarn "Since version 1.22.0:"
+ ewarn " 1. Minimum database requirements updated to MySQL 8.0, PostgreSQL 12, and MSSQL 2012."
+ ewarn " 2. There are a lot of refactoring changes related to customizing templates."
+ ewarn " 3. The default duration of the 'Remember login' feature has been"
+ ewarn " changed from one week to one month."
+ ewarn " 4. Enhanced auth token/remember me, the obsolete setting"
+ ewarn " '[security].COOKIE_USERNAME' has been removed."
+ ewarn " 5. For MinIO storage, adds a prefix path for all MinIO storage"
+ ewarn " and override base path will override the path."
+ ewarn " 6. Now use a more restricted sanitizer for the repository description."
+ ewarn "For more details, see <https://github.com/go-gitea/gitea/releases/tag/v1.22.0>."
+ fi
+ fi
+}