summaryrefslogtreecommitdiff
path: root/www-apps/xpra-html5
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-13 04:33:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-13 04:33:56 +0100
commit1206d22a2d6005bb271c68ea4e9b5c610a74b225 (patch)
treed7172cb47512371bf13f70b3b6742cbb411f3edf /www-apps/xpra-html5
parent2a5945e8688d3afc432c5f32eedad3b1f306b073 (diff)
gentoo auto-resync : 13:07:2023 - 04:33:56
Diffstat (limited to 'www-apps/xpra-html5')
-rw-r--r--www-apps/xpra-html5/Manifest2
-rw-r--r--www-apps/xpra-html5/xpra-html5-8.1.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/www-apps/xpra-html5/Manifest b/www-apps/xpra-html5/Manifest
index 930e01e28649..d2953c804cc5 100644
--- a/www-apps/xpra-html5/Manifest
+++ b/www-apps/xpra-html5/Manifest
@@ -1,3 +1,5 @@
DIST xpra-html5-6.1.tar.gz 1416380 BLAKE2B ba0e2bdcae91b30a1f46655dc505f5338cd8c516414f55871c6bc01b6bdcd81d351d66c575c6a7a219cb0c29e7da17e8db558b928dc89067b5ad3289520005f2 SHA512 3539c235f38a66f0a8eaea679df4b4bb4a1ef778ab31baf705acc29b0d4b3998ae84081eeac085db973d170afaa1ee0f167124efc3e48266145fdbef255a6bf5
+DIST xpra-html5-8.1.tar.gz 1328112 BLAKE2B c9ada4a5131273e29aa02cbee740bfaa7bcf50751231cd0fd04e9ccbd29a4cea31a0617a51019120ccf68fc9b8060c2f837f000c3ca67d2d049e9b1d27a622e0 SHA512 c02aa50e65414b06fe978113005fd13f631d73bde602a4d5c3c4d7281dfe23330cee01bb5c0701652fe1c91d91350dd9bc9b4f5144f6940ab4a83cf6743be1dd
EBUILD xpra-html5-6.1.ebuild 950 BLAKE2B 7b58f757aa4ac2df4cfedc55c427fb627f12f8edce2041d99a1c8c7fe686c04ac61c693bf07e3bd02f59187d34bdc76bf536476d69459d6ea1c3571b1ff534f7 SHA512 2b7ba2a31d3211323ae39913c0715e857df464715b910e157c7c0e9d5e0503e3ca0e69ae3236a314334c9ceb00f66ae55da81e686282fc14f9faa1a73814a3bf
+EBUILD xpra-html5-8.1.ebuild 950 BLAKE2B a31748759886062826c0d8aa8b953ff657e722f9d3acdb3b52d24c337273f83aec19860fc6b90d06a4630528c8f20f4343c501dcca08d7a113ae78c8589cdaf9 SHA512 5983f0f7cdadcbb5b6d532e518e436889659896b9b7dccb72849c399b2e9b08d62f389e95305964e0def1f801228e10d6b153ebf46d5e9c78612993fb10a3639
MISC metadata.xml 551 BLAKE2B 6d62f17a775361ec0b066cb994bc5a6ccc841e61991aa44a72512e82ac94c6a66ad7fbf3998c784cf830cfe44f03e496edd9b491e95f173fea71f328349bd457 SHA512 d839ba317b8d58e5849de92243408096799b1328baa3d46e0ca06e4c038639a35566a9a636f7da491820bc0e3af0cbd5e18043bf815b873f3ead4d68ff54c960
diff --git a/www-apps/xpra-html5/xpra-html5-8.1.ebuild b/www-apps/xpra-html5/xpra-html5-8.1.ebuild
new file mode 100644
index 000000000000..e5118ee749bc
--- /dev/null
+++ b/www-apps/xpra-html5/xpra-html5-8.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+inherit python-any-r1
+
+DESCRIPTION="HTML5 client to connect to any xpra server"
+HOMEPAGE="https://xpra.org/"
+SRC_URI="https://github.com/Xpra-org/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="brotli +gzip minify"
+
+BDEPEND="
+ ${PYTHON_DEPS}
+ brotli? ( app-arch/brotli )
+ minify? ( dev-util/uglifyjs )
+"
+
+src_configure() {
+ cat <<EOF > vcs-info || die
+BRANCH=gentoo
+REVISION=${PR#r}
+LOCAL_MODIFICATIONS=0
+EOF
+}
+
+src_install() {
+ "${PYTHON}" <<EOF || die
+import setup
+setup.set_version("${PV}")
+setup.install_html5(
+ root="${D}",
+ install_dir="${EPREFIX}/usr/share/xpra/www/",
+ config_dir="${EPREFIX}/etc/xpra/html5-client",
+ minifier="$(usex minify uglifyjs copy)",
+ gzip=$(usex gzip True False),
+ brotli=$(usex brotli True False),
+)
+EOF
+}