summaryrefslogtreecommitdiff
path: root/www-apps/wordpress/wordpress-4.9.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:52:04 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:52:04 +0100
commit71bc00c87bba1ce31de0dac6c3b7fd1aee6917fc (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /www-apps/wordpress/wordpress-4.9.7.ebuild
parent6612a728ea11526a849618ec515ad57131d64416 (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'www-apps/wordpress/wordpress-4.9.7.ebuild')
-rw-r--r--www-apps/wordpress/wordpress-4.9.7.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/www-apps/wordpress/wordpress-4.9.7.ebuild b/www-apps/wordpress/wordpress-4.9.7.ebuild
new file mode 100644
index 000000000000..19231ee76d17
--- /dev/null
+++ b/www-apps/wordpress/wordpress-4.9.7.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit webapp
+
+DESCRIPTION="Wordpress PHP and MySQL based content management system (CMS)"
+HOMEPAGE="https://wordpress.org/"
+SRC_URI="https://wordpress.org/${P/_rc/-RC}.tar.gz"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="virtual/httpd-php
+ || ( dev-lang/php[mysql] dev-lang/php[mysqli] )"
+
+S=${WORKDIR}/${PN}
+
+need_httpd_cgi
+
+IUSE="+akismet examples +themes vhosts"
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc readme.html
+ rm readme.html license.txt || die
+
+ if ! use akismet ; then
+ rm -R wp-content/plugins/akismet/ || die
+ fi
+ if ! use examples ; then
+ rm wp-content/plugins/hello.php || die
+ fi
+ if ! use themes ; then
+ rm -R wp-content/themes/*/ || die
+ fi
+
+ [[ -f wp-config.php ]] || cp wp-config-sample.php wp-config.php
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/index.php
+ webapp_serverowned "${MY_HTDOCSDIR}"/wp-admin/menu.php
+ webapp_serverowned "${MY_HTDOCSDIR}"
+
+ webapp_configfile "${MY_HTDOCSDIR}"/wp-config.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_postupgrade_txt en "${FILESDIR}"/postupgrade-en.txt
+
+ webapp_src_install
+}