summaryrefslogtreecommitdiff
path: root/www-apps/venus/venus-20100911-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
commit71deace00d1a2b091313fe137ab7092418c6f87c (patch)
tree9f1f0dee23e13658e52f49437befe78427148c51 /www-apps/venus/venus-20100911-r1.ebuild
parent29aabba0ea759c6a2864ff5631735b67ee38e5e0 (diff)
gentoo resync : 10.02.2020
Diffstat (limited to 'www-apps/venus/venus-20100911-r1.ebuild')
-rw-r--r--www-apps/venus/venus-20100911-r1.ebuild75
1 files changed, 0 insertions, 75 deletions
diff --git a/www-apps/venus/venus-20100911-r1.ebuild b/www-apps/venus/venus-20100911-r1.ebuild
deleted file mode 100644
index 44d5059cd316..000000000000
--- a/www-apps/venus/venus-20100911-r1.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 )
-
-inherit webapp python-single-r1
-
-WEBAPP_MANUAL_SLOT="yes"
-
-DESCRIPTION="A feed aggregator application"
-HOMEPAGE="http://intertwingly.net/code/venus/"
-SRC_URI="mirror://gentoo/${P}.tar.bz2"
-
-LICENSE="PSF-2.2"
-KEYWORDS="amd64 x86"
-IUSE="django genshi redland test"
-RESTRICT="!test? ( test )"
-SLOT="0"
-
-RDEPEND="
- dev-python/bsddb3[${PYTHON_USEDEP}]
- dev-python/chardet[${PYTHON_USEDEP}]
- dev-python/httplib2[${PYTHON_USEDEP}]
- dev-python/utidylib[${PYTHON_USEDEP}]
- django? ( dev-python/django[${PYTHON_USEDEP}] )
- genshi? ( dev-python/genshi[${PYTHON_USEDEP}] )
- redland? ( dev-python/rdflib[redland,${PYTHON_USEDEP}] )
- ${PYTHON_DEPS}"
-DEPEND="${RDEPEND}"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-S="${WORKDIR}"/${PN}
-
-pkg_setup() {
- python-single-r1_pkg_setup
- webapp_pkg_setup
-}
-
-src_prepare() {
- eapply "${FILESDIR}"/venus-bsddb3.patch
- eapply_user
- python_fix_shebang .
-}
-
-src_test() {
- "${PYTHON}" runtests.py || die
-}
-
-src_install() {
- webapp_src_preinst
-
- dodoc AUTHORS README TODO
- dodoc -r docs
-
- python_moduleinto venus
- python_domodule *.py filters planet
-
- insinto "${MY_APPDIR}"
- doins -r themes
-
- insinto "${MY_HOSTROOTDIR}/conf"
- doins -r examples
-
- webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
-
- webapp_src_install
-}
-
-pkg_postinst() {
- webapp_pkg_postinst
- elog "Installation instructions can be found at /usr/share/doc/${PF}/html/
- or http://intertwingly.net/code/venus/docs/index.html"
-}