summaryrefslogtreecommitdiff
path: root/www-apps/rutorrent
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-23 13:50:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-23 13:50:55 +0000
commited8299fef4175104e66b734cfc0482770614f398 (patch)
treed701a504c6fca51a0182f6ba21f16af855ee24b4 /www-apps/rutorrent
parent4035d30ea0ada73d992bb7d583c0b37a053714fe (diff)
gentoo auto-resync : 23:12:2023 - 13:50:55
Diffstat (limited to 'www-apps/rutorrent')
-rw-r--r--www-apps/rutorrent/Manifest2
-rw-r--r--www-apps/rutorrent/rutorrent-4.2.9.ebuild71
2 files changed, 73 insertions, 0 deletions
diff --git a/www-apps/rutorrent/Manifest b/www-apps/rutorrent/Manifest
index 98fab0a370dd..1adbf0b75d4f 100644
--- a/www-apps/rutorrent/Manifest
+++ b/www-apps/rutorrent/Manifest
@@ -1,4 +1,6 @@
DIST rutorrent-4.2.6.tar.gz 2360873 BLAKE2B 810dc7e237114df6f013b2a663c29ea581c27518415f6abb0c8ae0648bb18a352caa236bc877627d2145833c7e23cf39d55c15221285598d1a05ab223c3fed7d SHA512 0c561ae738f88990e1d374ad55de02cd9e842a9a674a6dd221711a8f52e1ce2ce627e151461fcf7286a8459960dc897858f24c2fe3671f705ed90b63f60123fb
+DIST rutorrent-4.2.9.tar.gz 2361701 BLAKE2B 8383d49e7f7f8b2781e2d848fbcaf1607056c5f69bb677666fd2ce9c509bbe52d2c3dea04b68b5b2b9ef6801eb4b82ed80ce036298a4945daf8ce282da2d2dfb SHA512 cf7792e68006f60a99c903ca87f5e3f5f6d779874f2fb9d04e37c6283db9c5700e270f3d1c98557f9f971ec9c50cbb16a424f5acd50246212f7a016b2138359e
EBUILD rutorrent-4.2.6.ebuild 1823 BLAKE2B 3ccbc5bce6c2bed8328f4911409350e50fda8dbe393069b857bc39ebf75368905dab5fdac75c5a2f2ca16b88bc67e801c029e02874182bfd26bb46c747ee0102 SHA512 35fe365ca6478306b9a15f3b24f8a89434b52bf788d53ff308907cb51bf7c2ca04ee0bf84f7c83dc41435b8f5a5d7027295457d77778b66d14742c7828865b9e
+EBUILD rutorrent-4.2.9.ebuild 1823 BLAKE2B 3ccbc5bce6c2bed8328f4911409350e50fda8dbe393069b857bc39ebf75368905dab5fdac75c5a2f2ca16b88bc67e801c029e02874182bfd26bb46c747ee0102 SHA512 35fe365ca6478306b9a15f3b24f8a89434b52bf788d53ff308907cb51bf7c2ca04ee0bf84f7c83dc41435b8f5a5d7027295457d77778b66d14742c7828865b9e
EBUILD rutorrent-9999.ebuild 1823 BLAKE2B 3ccbc5bce6c2bed8328f4911409350e50fda8dbe393069b857bc39ebf75368905dab5fdac75c5a2f2ca16b88bc67e801c029e02874182bfd26bb46c747ee0102 SHA512 35fe365ca6478306b9a15f3b24f8a89434b52bf788d53ff308907cb51bf7c2ca04ee0bf84f7c83dc41435b8f5a5d7027295457d77778b66d14742c7828865b9e
MISC metadata.xml 532 BLAKE2B bda4bb0ebd276f6f799362f8057f849c53a3e13ea6f7884363ed4c56cd01f9c25b390fbb0f75741bc5fc20f07ef64a597e9b6179736eb91f1ba110473ff11763 SHA512 b828c0cf6eec5ea72e08388845affc378cd2c81571ad99dbe612b9a871434371ce3dfc4492a8b70645677eb17d324060b0de98bf6c112bd2da24f4d02b5f2552
diff --git a/www-apps/rutorrent/rutorrent-4.2.9.ebuild b/www-apps/rutorrent/rutorrent-4.2.9.ebuild
new file mode 100644
index 000000000000..9c59d3d50153
--- /dev/null
+++ b/www-apps/rutorrent/rutorrent-4.2.9.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp optfeature
+
+DESCRIPTION="ruTorrent is a front-end for the popular Bittorrent client rTorrent"
+HOMEPAGE="https://github.com/Novik/ruTorrent"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Novik/ruTorrent.git"
+else
+ SRC_URI="https://github.com/Novik/ruTorrent/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc ~x86"
+ S="${WORKDIR}/ruTorrent-${PV}"
+fi
+
+LICENSE="GPL-2+ MIT"
+
+RDEPEND="
+ dev-lang/php[xml,gd]
+ virtual/httpd-php
+"
+
+need_httpd_cgi
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ rm -r .github || die
+ find . \( -name .gitignore -o -name .gitmodules \) -type f -delete || die
+ if [[ ${PV} == 9999 ]]; then
+ rm -r .git .gitattributes || die
+ fi
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ # can not use fperms beacuse of globbing
+ chmod +x "${ED}${MY_HTDOCSDIR}"/plugins/*/*.sh \
+ "${ED}${MY_HTDOCSDIR}"/php/test.sh || die "chmod failed"
+
+ keepdir "${MY_HTDOCSDIR}"/conf/users
+ keepdir "${MY_HTDOCSDIR}"/share/settings
+ keepdir "${MY_HTDOCSDIR}"/share/torrents
+ keepdir "${MY_HTDOCSDIR}"/share/users
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/conf
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/share
+
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/.htaccess
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/config.php
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/access.ini
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/plugins.ini
+ webapp_configfile "${MY_HTDOCSDIR}"/share/.htaccess
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+
+ optfeature "Show audio file spectogram" media-sound/sox
+ optfeature "Display media file information" media-video/mediainfo
+ optfeature "Scrape Cloudflare based sites" dev-python/cloudscraper
+}