summaryrefslogtreecommitdiff
path: root/www-apps/rutorrent
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-01 23:44:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-01 23:44:45 +0100
commitca52870b45c298a446df20ae15d12bff5f37c480 (patch)
tree96295ab2f8990b4411cd7628ff8ded21b5e3a030 /www-apps/rutorrent
parent5bd02f229a9c4ce484e49ec36dcb1f4eb5dfcdae (diff)
gentoo auto-resync : 01:10:2023 - 23:44:45
Diffstat (limited to 'www-apps/rutorrent')
-rw-r--r--www-apps/rutorrent/Manifest2
-rw-r--r--www-apps/rutorrent/rutorrent-4.2.6.ebuild71
2 files changed, 73 insertions, 0 deletions
diff --git a/www-apps/rutorrent/Manifest b/www-apps/rutorrent/Manifest
index be6338b4aef9..d2d3c018845d 100644
--- a/www-apps/rutorrent/Manifest
+++ b/www-apps/rutorrent/Manifest
@@ -1,4 +1,6 @@
DIST rutorrent-4.1.6.tar.gz 2256263 BLAKE2B 7767d4c79473239303cda844e95804e5ff02bae3a037e83caf619c02fb16172057226d426d1b8ba7155dc8dc8602d59a631f9336271979d463bf7478cfa529a1 SHA512 e6c38712c1cb2836fe5172212294382431832359dec9f60f2654d5ce934a7ff3164b86b846db5db0541737d1133e1bbc7c61e688e28f02eece3837cd1d201d1a
+DIST rutorrent-4.2.6.tar.gz 2360873 BLAKE2B 810dc7e237114df6f013b2a663c29ea581c27518415f6abb0c8ae0648bb18a352caa236bc877627d2145833c7e23cf39d55c15221285598d1a05ab223c3fed7d SHA512 0c561ae738f88990e1d374ad55de02cd9e842a9a674a6dd221711a8f52e1ce2ce627e151461fcf7286a8459960dc897858f24c2fe3671f705ed90b63f60123fb
EBUILD rutorrent-4.1.6.ebuild 1830 BLAKE2B 10c3015824921e3fc31ea96556f5aad6f1b14f4402908c493164f1246f5344105c9b07212f4e4ab04823845b80aecfbda94ab5cfa833d161bd41eed00e0d91c6 SHA512 78c7a623007cfedfca04866b080da88dd0bd8655c78900030fe5a06040b0a11b93bacc72426eb20abf909e76d2a8fd4bbaf35b5e500b0980aead05627eabf78b
+EBUILD rutorrent-4.2.6.ebuild 1830 BLAKE2B 10c3015824921e3fc31ea96556f5aad6f1b14f4402908c493164f1246f5344105c9b07212f4e4ab04823845b80aecfbda94ab5cfa833d161bd41eed00e0d91c6 SHA512 78c7a623007cfedfca04866b080da88dd0bd8655c78900030fe5a06040b0a11b93bacc72426eb20abf909e76d2a8fd4bbaf35b5e500b0980aead05627eabf78b
EBUILD rutorrent-9999.ebuild 1830 BLAKE2B 10c3015824921e3fc31ea96556f5aad6f1b14f4402908c493164f1246f5344105c9b07212f4e4ab04823845b80aecfbda94ab5cfa833d161bd41eed00e0d91c6 SHA512 78c7a623007cfedfca04866b080da88dd0bd8655c78900030fe5a06040b0a11b93bacc72426eb20abf909e76d2a8fd4bbaf35b5e500b0980aead05627eabf78b
MISC metadata.xml 532 BLAKE2B bda4bb0ebd276f6f799362f8057f849c53a3e13ea6f7884363ed4c56cd01f9c25b390fbb0f75741bc5fc20f07ef64a597e9b6179736eb91f1ba110473ff11763 SHA512 b828c0cf6eec5ea72e08388845affc378cd2c81571ad99dbe612b9a871434371ce3dfc4492a8b70645677eb17d324060b0de98bf6c112bd2da24f4d02b5f2552
diff --git a/www-apps/rutorrent/rutorrent-4.2.6.ebuild b/www-apps/rutorrent/rutorrent-4.2.6.ebuild
new file mode 100644
index 000000000000..f7dbb6ae40d3
--- /dev/null
+++ b/www-apps/rutorrent/rutorrent-4.2.6.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp optfeature
+
+DESCRIPTION="ruTorrent is a front-end for the popular Bittorrent client rTorrent"
+HOMEPAGE="https://github.com/Novik/ruTorrent"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Novik/ruTorrent.git"
+else
+ SRC_URI="https://github.com/Novik/ruTorrent/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+ S="${WORKDIR}/ruTorrent-${PV}"
+fi
+
+LICENSE="GPL-2+ MIT"
+
+RDEPEND="
+ dev-lang/php[xml,gd]
+ virtual/httpd-php
+"
+
+need_httpd_cgi
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ rm -r .github || die
+ find . \( -name .gitignore -o -name .gitmodules \) -type f -delete || die
+ if [[ ${PV} == 9999 ]]; then
+ rm -r .git .gitattributes || die
+ fi
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ # can not use fperms beacuse of globbing
+ chmod +x "${ED}${MY_HTDOCSDIR}"/plugins/*/*.sh \
+ "${ED}${MY_HTDOCSDIR}"/php/test.sh || die "chmod failed"
+
+ keepdir "${MY_HTDOCSDIR}"/conf/users
+ keepdir "${MY_HTDOCSDIR}"/share/settings
+ keepdir "${MY_HTDOCSDIR}"/share/torrents
+ keepdir "${MY_HTDOCSDIR}"/share/users
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/conf
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/share
+
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/.htaccess
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/config.php
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/access.ini
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/plugins.ini
+ webapp_configfile "${MY_HTDOCSDIR}"/share/.htaccess
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+
+ optfeature "Show audio file spectogram" media-sound/sox
+ optfeature "Display media file information" media-video/mediainfo
+ optfeature "Scrape Cloudflare based sites" dev-python/cloudscraper
+}