summaryrefslogtreecommitdiff
path: root/www-apps/rutorrent
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-01 19:26:48 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-01 19:26:48 +0000
commit93d7658008fb431ae469d5b6356fd53390998561 (patch)
tree0ba7ce8abb6392056459995442ae0e9e706c9364 /www-apps/rutorrent
parentc172714c13cbad928c88d1a98d01eeaa157b3504 (diff)
gentoo auto-resync : 01:03:2023 - 19:26:48
Diffstat (limited to 'www-apps/rutorrent')
-rw-r--r--www-apps/rutorrent/Manifest4
-rw-r--r--www-apps/rutorrent/rutorrent-4.0.2.ebuild71
-rw-r--r--www-apps/rutorrent/rutorrent-9999.ebuild54
3 files changed, 107 insertions, 22 deletions
diff --git a/www-apps/rutorrent/Manifest b/www-apps/rutorrent/Manifest
index 8439d90a13b4..f7e71e2cbbac 100644
--- a/www-apps/rutorrent/Manifest
+++ b/www-apps/rutorrent/Manifest
@@ -1,4 +1,6 @@
DIST rutorrent-3.8.tar.gz 1241643 BLAKE2B c432e8691d35447cd0698eee8edeee4060238dc39cc8cbb178c1169f166fa1d483493181ce0d2f468106ae01dd0f58d4fbb2f334de393fabb2b0aa73363e2b7f SHA512 ea3dfa74234a1eafcbc9e71d6c6d953a46fdf8e189237b8df0ec58cf46ac30404f7a15bb783ec7567ab6f28daa3987ee219039dd360e3c48d16aea244263c9b6
+DIST rutorrent-4.0.2.tar.gz 2221825 BLAKE2B 96867dbd818949388dedbfeee80ae85d22c9f3b04636d66797a96fc7b1de7541128445a989f642d711bd93aaf0840b56fe4e7bb7f29a02d122d939039eeff835 SHA512 f1f3cf7712246c02c73753e5ec8c3b5c0af4797699adeabc59822c165d06d7291d50a2d065b2d729273f907e1ec288391b1f02bc733a2b40d3e818a2de983528
EBUILD rutorrent-3.8-r1.ebuild 1459 BLAKE2B 579dc77ea961e691dbca5832ef86aab583d4fa94ff2242e04206cf0290be60e3f487c217d15baeba102826074f3af7362563bf47e4063497f613dbbbe5c10f9d SHA512 815ff584b0d4f633cc4f9b354cfa3015fb4ea94d543a9da61d022f5480061119550c1ac47aeec833856092937dbaa2e2ce3b9c35682f2f8cf5920c7a88ba74d5
-EBUILD rutorrent-9999.ebuild 1424 BLAKE2B f2f05d4074b21fe8fc3e65a9b7e89c5bb7dd0a1d90cd14e11d27b04a43979bef3e514e2dc00084f05ee4969e4d5942fcb2e1fb4fdbed3e13bb15a8507ef21eb0 SHA512 3266610883d418850c4f614b466cfd33f5ca02a4669ca7b0519a239287f8c4ab6b30e3322efc0e31af4074ffada19b627b24d8a708a9d960aaa2b89d4db9c57e
+EBUILD rutorrent-4.0.2.ebuild 1830 BLAKE2B 10c3015824921e3fc31ea96556f5aad6f1b14f4402908c493164f1246f5344105c9b07212f4e4ab04823845b80aecfbda94ab5cfa833d161bd41eed00e0d91c6 SHA512 78c7a623007cfedfca04866b080da88dd0bd8655c78900030fe5a06040b0a11b93bacc72426eb20abf909e76d2a8fd4bbaf35b5e500b0980aead05627eabf78b
+EBUILD rutorrent-9999.ebuild 1830 BLAKE2B 10c3015824921e3fc31ea96556f5aad6f1b14f4402908c493164f1246f5344105c9b07212f4e4ab04823845b80aecfbda94ab5cfa833d161bd41eed00e0d91c6 SHA512 78c7a623007cfedfca04866b080da88dd0bd8655c78900030fe5a06040b0a11b93bacc72426eb20abf909e76d2a8fd4bbaf35b5e500b0980aead05627eabf78b
MISC metadata.xml 409 BLAKE2B c76ee9c6b54abf93c317a9a167713ca78727352e24418339d20971b9d19b0d0f65482588a322a4614520c4315b8e53d2d73fdba1797ed8ac5f1bdfe4e8902e87 SHA512 30466e75d80306c53d1cf4270ccef16e6a35dca1db840217264df155c1b4a3be4b94e8d31d4262e79fee52a9f42c9c8b39f6b4ae27d05a48f32e65a73edeeb9c
diff --git a/www-apps/rutorrent/rutorrent-4.0.2.ebuild b/www-apps/rutorrent/rutorrent-4.0.2.ebuild
new file mode 100644
index 000000000000..f7dbb6ae40d3
--- /dev/null
+++ b/www-apps/rutorrent/rutorrent-4.0.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp optfeature
+
+DESCRIPTION="ruTorrent is a front-end for the popular Bittorrent client rTorrent"
+HOMEPAGE="https://github.com/Novik/ruTorrent"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Novik/ruTorrent.git"
+else
+ SRC_URI="https://github.com/Novik/ruTorrent/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+ S="${WORKDIR}/ruTorrent-${PV}"
+fi
+
+LICENSE="GPL-2+ MIT"
+
+RDEPEND="
+ dev-lang/php[xml,gd]
+ virtual/httpd-php
+"
+
+need_httpd_cgi
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ rm -r .github || die
+ find . \( -name .gitignore -o -name .gitmodules \) -type f -delete || die
+ if [[ ${PV} == 9999 ]]; then
+ rm -r .git .gitattributes || die
+ fi
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ # can not use fperms beacuse of globbing
+ chmod +x "${ED}${MY_HTDOCSDIR}"/plugins/*/*.sh \
+ "${ED}${MY_HTDOCSDIR}"/php/test.sh || die "chmod failed"
+
+ keepdir "${MY_HTDOCSDIR}"/conf/users
+ keepdir "${MY_HTDOCSDIR}"/share/settings
+ keepdir "${MY_HTDOCSDIR}"/share/torrents
+ keepdir "${MY_HTDOCSDIR}"/share/users
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/conf
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/share
+
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/.htaccess
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/config.php
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/access.ini
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/plugins.ini
+ webapp_configfile "${MY_HTDOCSDIR}"/share/.htaccess
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+
+ optfeature "Show audio file spectogram" media-sound/sox
+ optfeature "Display media file information" media-video/mediainfo
+ optfeature "Scrape Cloudflare based sites" dev-python/cloudscraper
+}
diff --git a/www-apps/rutorrent/rutorrent-9999.ebuild b/www-apps/rutorrent/rutorrent-9999.ebuild
index ad651140c198..f7dbb6ae40d3 100644
--- a/www-apps/rutorrent/rutorrent-9999.ebuild
+++ b/www-apps/rutorrent/rutorrent-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit webapp
+inherit webapp optfeature
DESCRIPTION="ruTorrent is a front-end for the popular Bittorrent client rTorrent"
HOMEPAGE="https://github.com/Novik/ruTorrent"
@@ -13,41 +13,45 @@ if [[ ${PV} == 9999 ]]; then
else
SRC_URI="https://github.com/Novik/ruTorrent/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+ S="${WORKDIR}/ruTorrent-${PV}"
fi
-LICENSE="GPL-2"
-IUSE=""
+LICENSE="GPL-2+ MIT"
-need_httpd_cgi
+RDEPEND="
+ dev-lang/php[xml,gd]
+ virtual/httpd-php
+"
-DEPEND="dev-lang/php[xml,gd]"
-RDEPEND="virtual/httpd-php"
+need_httpd_cgi
pkg_setup() {
webapp_pkg_setup
}
-src_prepare() {
- default
- find -name '\.gitignore' -type f -exec rm -rf {} \;
- if [[ ${PV} == 9999 ]]; then
- rm -rf .git
- fi
-}
-
src_install() {
webapp_src_preinst
+ rm -r .github || die
+ find . \( -name .gitignore -o -name .gitmodules \) -type f -delete || die
+ if [[ ${PV} == 9999 ]]; then
+ rm -r .git .gitattributes || die
+ fi
+
insinto "${MY_HTDOCSDIR}"
doins -r .
+ # can not use fperms beacuse of globbing
chmod +x "${ED}${MY_HTDOCSDIR}"/plugins/*/*.sh \
- "$ED${MY_HTDOCSDIR}"/php/test.sh || die "chmod failed"
+ "${ED}${MY_HTDOCSDIR}"/php/test.sh || die "chmod failed"
+
+ keepdir "${MY_HTDOCSDIR}"/conf/users
+ keepdir "${MY_HTDOCSDIR}"/share/settings
+ keepdir "${MY_HTDOCSDIR}"/share/torrents
+ keepdir "${MY_HTDOCSDIR}"/share/users
- webapp_serverowned "${MY_HTDOCSDIR}"/share
- webapp_serverowned "${MY_HTDOCSDIR}"/share/settings
- webapp_serverowned "${MY_HTDOCSDIR}"/share/torrents
- webapp_serverowned "${MY_HTDOCSDIR}"/share/users
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/conf
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/share
webapp_configfile "${MY_HTDOCSDIR}"/conf/.htaccess
webapp_configfile "${MY_HTDOCSDIR}"/conf/config.php
@@ -57,3 +61,11 @@ src_install() {
webapp_src_install
}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+
+ optfeature "Show audio file spectogram" media-sound/sox
+ optfeature "Display media file information" media-video/mediainfo
+ optfeature "Scrape Cloudflare based sites" dev-python/cloudscraper
+}