summaryrefslogtreecommitdiff
path: root/www-apps/rutorrent
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-21 08:09:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-21 08:09:25 +0000
commit5adb1b3ff590f0911922679849a7fdacc8b4f217 (patch)
tree8a471fe02dd3498487715d39f928b42017f24c99 /www-apps/rutorrent
parentafcb9236a72cf602364c28b9bde6648e4a7f1ca5 (diff)
gentoo auto-resync : 21:01:2024 - 08:09:25
Diffstat (limited to 'www-apps/rutorrent')
-rw-r--r--www-apps/rutorrent/Manifest2
-rw-r--r--www-apps/rutorrent/rutorrent-4.2.10.ebuild71
2 files changed, 73 insertions, 0 deletions
diff --git a/www-apps/rutorrent/Manifest b/www-apps/rutorrent/Manifest
index 2c4ca9ac3a7f..7d3eb9e479d0 100644
--- a/www-apps/rutorrent/Manifest
+++ b/www-apps/rutorrent/Manifest
@@ -1,4 +1,6 @@
+DIST rutorrent-4.2.10.tar.gz 2362233 BLAKE2B ea2b1b928e1a7c933ad6e85f5a18810d3f4bf11911da2926e26ba0329b54049dee24a456d0dedd98d106b3b9b460c791eae65a222cbe54ac0c2a49634b6b65a8 SHA512 b57e95591b835fd8d0c0e9acdf9c23dbaf6a37542c46397794da625edd02524af508510e0396308ddfe024d37c92e493134a13aae9dd28c5c642cdbd8d9264a5
DIST rutorrent-4.2.9.tar.gz 2361701 BLAKE2B 8383d49e7f7f8b2781e2d848fbcaf1607056c5f69bb677666fd2ce9c509bbe52d2c3dea04b68b5b2b9ef6801eb4b82ed80ce036298a4945daf8ce282da2d2dfb SHA512 cf7792e68006f60a99c903ca87f5e3f5f6d779874f2fb9d04e37c6283db9c5700e270f3d1c98557f9f971ec9c50cbb16a424f5acd50246212f7a016b2138359e
+EBUILD rutorrent-4.2.10.ebuild 1823 BLAKE2B 3ccbc5bce6c2bed8328f4911409350e50fda8dbe393069b857bc39ebf75368905dab5fdac75c5a2f2ca16b88bc67e801c029e02874182bfd26bb46c747ee0102 SHA512 35fe365ca6478306b9a15f3b24f8a89434b52bf788d53ff308907cb51bf7c2ca04ee0bf84f7c83dc41435b8f5a5d7027295457d77778b66d14742c7828865b9e
EBUILD rutorrent-4.2.9.ebuild 1823 BLAKE2B 3ccbc5bce6c2bed8328f4911409350e50fda8dbe393069b857bc39ebf75368905dab5fdac75c5a2f2ca16b88bc67e801c029e02874182bfd26bb46c747ee0102 SHA512 35fe365ca6478306b9a15f3b24f8a89434b52bf788d53ff308907cb51bf7c2ca04ee0bf84f7c83dc41435b8f5a5d7027295457d77778b66d14742c7828865b9e
EBUILD rutorrent-9999.ebuild 1823 BLAKE2B 3ccbc5bce6c2bed8328f4911409350e50fda8dbe393069b857bc39ebf75368905dab5fdac75c5a2f2ca16b88bc67e801c029e02874182bfd26bb46c747ee0102 SHA512 35fe365ca6478306b9a15f3b24f8a89434b52bf788d53ff308907cb51bf7c2ca04ee0bf84f7c83dc41435b8f5a5d7027295457d77778b66d14742c7828865b9e
MISC metadata.xml 532 BLAKE2B bda4bb0ebd276f6f799362f8057f849c53a3e13ea6f7884363ed4c56cd01f9c25b390fbb0f75741bc5fc20f07ef64a597e9b6179736eb91f1ba110473ff11763 SHA512 b828c0cf6eec5ea72e08388845affc378cd2c81571ad99dbe612b9a871434371ce3dfc4492a8b70645677eb17d324060b0de98bf6c112bd2da24f4d02b5f2552
diff --git a/www-apps/rutorrent/rutorrent-4.2.10.ebuild b/www-apps/rutorrent/rutorrent-4.2.10.ebuild
new file mode 100644
index 000000000000..9c59d3d50153
--- /dev/null
+++ b/www-apps/rutorrent/rutorrent-4.2.10.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp optfeature
+
+DESCRIPTION="ruTorrent is a front-end for the popular Bittorrent client rTorrent"
+HOMEPAGE="https://github.com/Novik/ruTorrent"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Novik/ruTorrent.git"
+else
+ SRC_URI="https://github.com/Novik/ruTorrent/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc ~x86"
+ S="${WORKDIR}/ruTorrent-${PV}"
+fi
+
+LICENSE="GPL-2+ MIT"
+
+RDEPEND="
+ dev-lang/php[xml,gd]
+ virtual/httpd-php
+"
+
+need_httpd_cgi
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ rm -r .github || die
+ find . \( -name .gitignore -o -name .gitmodules \) -type f -delete || die
+ if [[ ${PV} == 9999 ]]; then
+ rm -r .git .gitattributes || die
+ fi
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ # can not use fperms beacuse of globbing
+ chmod +x "${ED}${MY_HTDOCSDIR}"/plugins/*/*.sh \
+ "${ED}${MY_HTDOCSDIR}"/php/test.sh || die "chmod failed"
+
+ keepdir "${MY_HTDOCSDIR}"/conf/users
+ keepdir "${MY_HTDOCSDIR}"/share/settings
+ keepdir "${MY_HTDOCSDIR}"/share/torrents
+ keepdir "${MY_HTDOCSDIR}"/share/users
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/conf
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/share
+
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/.htaccess
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/config.php
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/access.ini
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/plugins.ini
+ webapp_configfile "${MY_HTDOCSDIR}"/share/.htaccess
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+
+ optfeature "Show audio file spectogram" media-sound/sox
+ optfeature "Display media file information" media-video/mediainfo
+ optfeature "Scrape Cloudflare based sites" dev-python/cloudscraper
+}