summaryrefslogtreecommitdiff
path: root/www-apps/roundup
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /www-apps/roundup
reinit the tree, so we can have metadata
Diffstat (limited to 'www-apps/roundup')
-rw-r--r--www-apps/roundup/Manifest5
-rw-r--r--www-apps/roundup/metadata.xml16
-rw-r--r--www-apps/roundup/roundup-1.5.1.ebuild39
3 files changed, 60 insertions, 0 deletions
diff --git a/www-apps/roundup/Manifest b/www-apps/roundup/Manifest
new file mode 100644
index 000000000000..805193780080
--- /dev/null
+++ b/www-apps/roundup/Manifest
@@ -0,0 +1,5 @@
+DIST roundup-1.5.1.tar.gz 2618886 SHA256 d5b915e57d33c302ca38a0f018032ac7842570a4d1a5ac3f04f6f07211f94a68 SHA512 d7cdeaafb682ce7f202cacddeb1a42312f22778a2c83b52b4e838c27b1e7141a94b2ac2b670b0edee0efcfe27d74e31e6f267ae1380e90359def27385ca68d58 WHIRLPOOL 093f3b7d202b04ab3e21f96a1fb0b900d24c5ff60a91a716ed96d0abb106d124b251440a4b5f449b82d2d986dbe860cc37fadd84630386d5e4f60861e1f2dbd6
+EBUILD roundup-1.5.1.ebuild 1227 SHA256 3ba493d120c889659f9cff5e1c5b1f6016edf269bf5fc03b75ce35475e8fa6c0 SHA512 fe8a296bbb8713e76cf34b1f8e1bb1dfa26c5c58d9c393893f1181b148237534ce4d88d520b3624b74d468ab6b01b464a85540fab55ad1b306e580257c410085 WHIRLPOOL 77282bceea3a89dbf2ee3e8a7af8cb0710dc551ffe59bdc26856518a83f85312f416991ea1ee089c532256fe6b361fc1c861e18f8c4f393d3244e4a9604d0e46
+MISC ChangeLog 3272 SHA256 58b066b920977bc989f11cf691d302c1a76b6fa1cb65de95dd1daf620b05440d SHA512 36f38aba3aac4047d9501930b013410e24a1159b938235cafb0a963bd1d156d1eb0ec51f65b78664c610603ee4400dec1e3c43984c46e85103f042a2a08214c3 WHIRLPOOL 26993b603977d79e99f1a67af5cc566d650e4c95dd0bcb434371212de111797b6e31588f3b7db21e8ab6c4594ec6dc84f02f238e82b504f85e716cf73dc491de
+MISC ChangeLog-2015 11365 SHA256 feb6bec2b2cc2727d7effc9a06543294b713ae79df76a46aa31774227d6015e7 SHA512 5727ca077f734ab039e1d151b061dd8abd3e40ede505085989ff493b106823e37e69359e715a568d8709e28a25c322bdfcb48a2da99fd03742b26e34f594c3bf WHIRLPOOL d7fca64b8dfad434ba1c48a92344d0a398097b6c0ac48e368345d8d9d5c1d196c792d7983b3d79b263f820e07a42b2c7c674f3ea103e32b5d46c88ddd2877250
+MISC metadata.xml 477 SHA256 d65faaf86fb9db15f2c340f551ddaebb6bf4c44c682eb56a58963559301ac57a SHA512 2a8912d94be88771ed0044ae823fb2027fb3f403256f8d3045b01a46f9595866a9129e85cdbc05e601a18d264b92c88648e8acc78a50ce52a4810ee7d5532999 WHIRLPOOL c2f2985119fe668910a75726da51b3fc62c9527ad0b43c67874cdde964bcd4c659b83486025d424cd8996814d291ce9bc5691575c819afe95442ef2b2c00c117
diff --git a/www-apps/roundup/metadata.xml b/www-apps/roundup/metadata.xml
new file mode 100644
index 000000000000..0942edd01872
--- /dev/null
+++ b/www-apps/roundup/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>web-apps@gentoo.org</email>
+ <name>Gentoo Webapps</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>cedk@gentoo.org</email>
+ <name>Cédric Krier</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">roundup</remote-id>
+ <remote-id type="sourceforge">roundup</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/www-apps/roundup/roundup-1.5.1.ebuild b/www-apps/roundup/roundup-1.5.1.ebuild
new file mode 100644
index 000000000000..dd40a00a4804
--- /dev/null
+++ b/www-apps/roundup/roundup-1.5.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Issue-tracking system with command-line, web, and e-mail interfaces"
+HOMEPAGE="http://roundup.sourceforge.net https://pypi.python.org/pypi/roundup"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT ZPL"
+SLOT="0"
+KEYWORDS="amd64 ppc ~sparc x86"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+DOCS="CHANGES.txt doc/*.txt"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ rm -r "${ED}"/usr/share/doc/${PN} || die
+ dohtml -r doc/*
+}
+
+pkg_postinst() {
+ ewarn "As a non privileged user! (not root)"
+ ewarn "Run 'roundup-admin install' to set up a roundup instance"
+ ewarn "Then edit your config.ini file in the tracker home you setup"
+ ewarn "Run 'roundup-admin initialise' to setup the admin pass"
+ ewarn "run /usr/bin/roundup start port host \"your tracker name\" [your tracker home], and all should work!"
+ ewarn "run /usr/bin/roundup stop [your tracker home] to stop the server"
+ ewarn "log is in [tracker home]/roundup.log"
+ ewarn "pid file is in [tracker home]/roundup.pid"
+ ewarn
+ ewarn "See upgrading.txt for upgrading instructions."
+}