summaryrefslogtreecommitdiff
path: root/www-apps/roundup/roundup-2.1.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /www-apps/roundup/roundup-2.1.0-r1.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'www-apps/roundup/roundup-2.1.0-r1.ebuild')
-rw-r--r--www-apps/roundup/roundup-2.1.0-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/www-apps/roundup/roundup-2.1.0-r1.ebuild b/www-apps/roundup/roundup-2.1.0-r1.ebuild
new file mode 100644
index 000000000000..46b7a8361e12
--- /dev/null
+++ b/www-apps/roundup/roundup-2.1.0-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+MY_P=${P/_/}
+
+DESCRIPTION="Issue-tracking system with command-line, web, and e-mail interfaces"
+HOMEPAGE="http://roundup.sourceforge.net https://pypi.org/project/roundup/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT ZPL"
+SLOT="0"
+KEYWORDS="amd64 ~ppc sparc x86"
+IUSE="+tz sqlite mysql postgres xapian whoosh ssl jinja pyjwt markdown"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ tz? ( dev-python/pytz[$PYTHON_USEDEP] )
+ sqlite? ( $(python_gen_impl_dep sqlite) )
+ mysql? ( dev-python/mysqlclient[$PYTHON_USEDEP] )
+ postgres? ( >=dev-python/psycopg-2.8:2[$PYTHON_USEDEP] )
+ xapian? ( >=dev-libs/xapian-bindings-1.0.0[python,$PYTHON_USEDEP] )
+ whoosh? ( >=dev-python/whoosh-2.5.7[$PYTHON_USEDEP] )
+ ssl? ( dev-python/pyopenssl[$PYTHON_USEDEP] )
+ jinja? ( dev-python/jinja[$PYTHON_USEDEP] )
+ pyjwt? ( dev-python/pyjwt[$PYTHON_USEDEP] )
+ markdown? (
+ || (
+ dev-python/markdown[$PYTHON_USEDEP]
+ dev-python/markdown2[$PYTHON_USEDEP]
+ dev-python/mistune[$PYTHON_USEDEP]
+ )
+ )"
+
+DOCS="CHANGES.txt doc/*.txt"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ rm -r "${ED}"/usr/share/doc/${PN} || die
+}
+
+pkg_postinst() {
+ ewarn "See installation.txt for initialisation instructions."
+ ewarn "See upgrading.txt for upgrading instructions."
+}