summaryrefslogtreecommitdiff
path: root/www-apps/readarr-bin/readarr-bin-0.4.12.2753.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-03-11 01:49:36 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-03-11 01:49:36 +0000
commitcf7807d7aea23a99a144afceaba961cfed652b5f (patch)
treeffd2c781c27e0b7e72152a685a04938a2b7966f0 /www-apps/readarr-bin/readarr-bin-0.4.12.2753.ebuild
parent7c5ebaf83da4c538dd11b56fdd5dfdf39dcbc096 (diff)
gentoo auto-resync : 11:03:2025 - 01:49:36HEADmaster
Diffstat (limited to 'www-apps/readarr-bin/readarr-bin-0.4.12.2753.ebuild')
-rw-r--r--www-apps/readarr-bin/readarr-bin-0.4.12.2753.ebuild76
1 files changed, 76 insertions, 0 deletions
diff --git a/www-apps/readarr-bin/readarr-bin-0.4.12.2753.ebuild b/www-apps/readarr-bin/readarr-bin-0.4.12.2753.ebuild
new file mode 100644
index 000000000000..e71a1b92c4dc
--- /dev/null
+++ b/www-apps/readarr-bin/readarr-bin-0.4.12.2753.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd
+
+DESCRIPTION="An ebook and audiobook collection manager for Usenet and BitTorrent users"
+HOMEPAGE="https://readarr.com/
+ https://github.com/Readarr/Readarr/"
+
+SRC_URI="
+ amd64? (
+ elibc_glibc? (
+ https://github.com/Readarr/Readarr/releases/download/v${PV}/Readarr.develop.${PV}.linux-core-x64.tar.gz
+ )
+ elibc_musl? (
+ https://github.com/Readarr/Readarr/releases/download/v${PV}/Readarr.develop.${PV}.linux-musl-core-x64.tar.gz
+ )
+ )
+ arm? (
+ elibc_glibc? (
+ https://github.com/Readarr/Readarr/releases/download/v${PV}/Readarr.develop.${PV}.linux-core-arm.tar.gz
+ )
+ elibc_musl? (
+ https://github.com/Readarr/Readarr/releases/download/v${PV}/Readarr.develop.${PV}.linux-musl-core-arm.tar.gz
+ )
+ )
+ arm64? (
+ elibc_glibc? (
+ https://github.com/Readarr/Readarr/releases/download/v${PV}/Readarr.develop.${PV}.linux-core-arm64.tar.gz
+ )
+ elibc_musl? (
+ https://github.com/Readarr/Readarr/releases/download/v${PV}/Readarr.develop.${PV}.linux-musl-core-arm64.tar.gz
+ )
+ )
+"
+S="${WORKDIR}/Readarr"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="bindist strip test"
+
+RDEPEND="
+ acct-group/readarr
+ acct-user/readarr
+ dev-libs/icu
+ dev-db/sqlite
+"
+
+QA_PREBUILT="*"
+
+src_prepare() {
+ default
+
+ # https://github.com/dotnet/runtime/issues/57784
+ find . -type f -iname libcoreclrtraceptprovider.so -delete || die
+}
+
+src_install() {
+ newinitd "${FILESDIR}/readarr.init" readarr
+
+ keepdir /var/lib/readarr
+ fowners -R readarr:readarr /var/lib/readarr
+
+ insinto /etc/logrotate.d
+ insopts -m0644 -o root -g root
+ newins "${FILESDIR}/readarr.logrotate" readarr
+
+ dodir "/opt/readarr"
+ cp -R "${S}/." "${D}/opt/readarr" || die "Install failed!"
+
+ systemd_dounit "${FILESDIR}/readarr.service"
+ systemd_newunit "${FILESDIR}/readarr.service" "readarr@.service"
+}