summaryrefslogtreecommitdiff
path: root/www-apps/radicale
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-14 11:06:13 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-14 11:06:13 +0100
commite000645bea7492c9f5277722c0ada7e1ee0b4833 (patch)
treea604499d25e682002ec55cc5e7d14e0c53809199 /www-apps/radicale
parentbe8708090362c01c6111c4b76f1e395c14d86e00 (diff)
gentoo auto-resync : 14:08:2024 - 11:06:13
Diffstat (limited to 'www-apps/radicale')
-rw-r--r--www-apps/radicale/Manifest2
-rw-r--r--www-apps/radicale/files/radicale-r4.init.d28
-rw-r--r--www-apps/radicale/radicale-3.1.9-r1.ebuild90
3 files changed, 120 insertions, 0 deletions
diff --git a/www-apps/radicale/Manifest b/www-apps/radicale/Manifest
index 786a46250eb7..9affaf21f3d8 100644
--- a/www-apps/radicale/Manifest
+++ b/www-apps/radicale/Manifest
@@ -1,5 +1,7 @@
AUX radicale-r3.init.d 531 BLAKE2B 2462a6a9cc3377d82f53f4add662f17dbb06c497876348baed61f12a0be4e1636ecf08059fa4d0d139bbc4e4e9476ff5db2436b23a780a9182ad59488fe1b934 SHA512 37d40c036cc76c12a37677bf14781582b754d17cfc25e56b642235b1ea8d7fd557550a4da595fd539349d33902a70810ebeacda00396767f3b2d12f48c6111e1
+AUX radicale-r4.init.d 601 BLAKE2B 5b25d1b22fd3b531ceee7318d6389c0bb8e31bd2a6b26d2f126b9d4dc1549d54ce6b42c58481278ebec7d328247c4841d58efd0a58c4e45e4937524c61f19931 SHA512 82c53c5974632ecd87c79a4d4120fbb932eaad2830eed20091bf439bd68b0a74d5217f586590404279a65011732bbac1a00eb973c6c7a00a6509ec4304a3ec9c
AUX radicale.service 546 BLAKE2B 6d43e9b9aec713a944259e6323442f6796068ede3da5399f9081692b55fa0edc7ec72b35d190ec68f14972374c4da23178e84c7f4ff6df611c1f82e1e0b3029d SHA512 94705c36ddd4de14b608fa71cb8ee4fff3f4f12cf90cfeb3863c334e98ac5d19b34134d26c319d5d05b61efba8370addb87b8b6a6ad7005a17f8bfb35ff9013b
DIST Radicale-3.1.9.gh.tar.gz 141258 BLAKE2B 6d74eabd7e09b1804a6a3c556a9f629fb72c4685fdf5d96d0d53ffaf5db712968b054678be866002ab4ceafaf1d3d8ad3f52aae7a9a4ecabbc129149c96ab9b6 SHA512 f4d0b26149c331b4bc02f01bb637cea1d29e1d563a4133c4293ec13990f1553988181582c2e726ce33b563403a14e9ec863403f86e66b13fd8cfd62cf74439e4
+EBUILD radicale-3.1.9-r1.ebuild 2016 BLAKE2B d9d2007fabbb91fb6d3817b52df3acb8b7dc15fce695c0991b8136eb49ff5e748e46be4d8e1b8472b96b74ff76b1f980503093e8824847722025fdd26619a259 SHA512 c7ffc745258b5a9314d915650c24c4a486e08e1c5d672a60f19f908beed827d140fcc15c443a42970c3fdb30991bec28f5ece2f3489be59ee97da76b22de945a
EBUILD radicale-3.1.9.ebuild 2016 BLAKE2B c48c9517dfa5b9070319d4b053f75911162b085e9bfe9b6b2f9643f430500bd5ca347a88efee12d5e7ef40949ad376b389ca546ce9f8c5499ff6134240c7b41f SHA512 7decf90ca0f5762899ff19f343f7666c70104112aca8db5e4afbea324c5cd1f75b4a00443af4d20ae60b933a09a57768fb7db4f26e949906d693944cda582544
MISC metadata.xml 499 BLAKE2B e8aa182ad9b9388d6bbb527bff646b1e816343ddcbc95f8a9ee2eede2272f6470e1d543745c8ab9b907259c3b880332fb6d281e9771ea63696812956195bb277 SHA512 bb9b0a207af851714831c2aca9d020bcc728094c82ad15d519578e31499ff1999741279725ab6c306a25f0e4ccfd8399e39f2b42ca4eb821e677395aea8be842
diff --git a/www-apps/radicale/files/radicale-r4.init.d b/www-apps/radicale/files/radicale-r4.init.d
new file mode 100644
index 000000000000..b83d91d79a04
--- /dev/null
+++ b/www-apps/radicale/files/radicale-r4.init.d
@@ -0,0 +1,28 @@
+#!/sbin/openrc-run
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+description="A simple CalDAV (calendar) and CardDAV (contact) server"
+PIDFILE=/run/radicale.pid
+
+depend() {
+ need localmount
+}
+
+start() {
+ ebegin "Starting radicale"
+ start-stop-daemon --start --quiet --background \
+ --user radicale \
+ --umask 0027 \
+ --stderr-logger /usr/bin/logger \
+ --pidfile ${PIDFILE} --make-pidfile \
+ --exec /usr/bin/radicale
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping radicale"
+ start-stop-daemon --stop --quiet \
+ --pidfile ${PIDFILE}
+ eend $?
+}
diff --git a/www-apps/radicale/radicale-3.1.9-r1.ebuild b/www-apps/radicale/radicale-3.1.9-r1.ebuild
new file mode 100644
index 000000000000..3ba042c24436
--- /dev/null
+++ b/www-apps/radicale/radicale-3.1.9-r1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 systemd
+
+MY_P=${P^}
+DESCRIPTION="A simple CalDAV calendar server"
+HOMEPAGE="https://radicale.org/"
+SRC_URI="
+ https://github.com/Kozea/Radicale/archive/refs/tags/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="
+ >=acct-user/radicale-0-r2
+ acct-group/radicale
+ dev-python/bcrypt[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/vobject[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ sys-apps/util-linux
+"
+
+BDEPEND="
+ test? (
+ <dev-python/pytest-8[${PYTHON_USEDEP}]
+ dev-python/waitress[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+RDIR=/var/lib/"${PN}"
+
+DOCS=( DOCUMENTATION.md CHANGELOG.md )
+
+python_test() {
+ epytest -o addopts= radicale/tests/
+}
+
+python_install_all() {
+ rm README* || die
+ # init file
+ newinitd "${FILESDIR}"/radicale-r4.init.d radicale
+ systemd_dounit "${FILESDIR}/${PN}.service"
+
+ # directories
+ keepdir "${RDIR}"
+ fperms 0750 "${RDIR}"
+ fowners "${PN}:${PN}" "${RDIR}"
+
+ # config file
+ insinto /etc/"${PN}"
+ doins config
+
+ # fcgi and wsgi files
+ exeinto /usr/share/"${PN}"
+ doexe radicale.wsgi
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ local _erdir="${EROOT}${RDIR}"
+
+ einfo "A sample WSGI script has been put into ${EROOT}/usr/share/${PN}."
+ einfo "You will also find there an example FastCGI script."
+ if [[ $(stat --format="%U:%G:%a" "${_erdir}") != "${PN}:${PN}:750" ]]
+ then
+ ewarn ""
+ ewarn "Unsafe file permissions detected on ${_erdir}."
+ ewarn "This probably comes from an earlier version of this ebuild."
+ ewarn "To fix run:"
+ ewarn "# \`chown -R ${PN}:${PN} ${_erdir}\`"
+ ewarn "# \`chmod 0750 ${_erdir}\`"
+ ewarn "# \`chmod -R o= ${_erdir}\`"
+ fi
+}