summaryrefslogtreecommitdiff
path: root/www-apps/postfixadmin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
commit066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (patch)
tree3cb05783d73b2c33589ba305144a31c718e123cd /www-apps/postfixadmin
parent16449a80e28af2209916cc66d19c9a44ca2b90d9 (diff)
gentoo resync : 03.03.2019
Diffstat (limited to 'www-apps/postfixadmin')
-rw-r--r--www-apps/postfixadmin/Manifest2
-rw-r--r--www-apps/postfixadmin/postfixadmin-3.2.ebuild100
2 files changed, 102 insertions, 0 deletions
diff --git a/www-apps/postfixadmin/Manifest b/www-apps/postfixadmin/Manifest
index df14816c2064..e9e602b28da5 100644
--- a/www-apps/postfixadmin/Manifest
+++ b/www-apps/postfixadmin/Manifest
@@ -1,4 +1,6 @@
AUX postinstall-en-2.3.txt 1827 BLAKE2B 49402566ddf6981cf0226f6a963fdd2c482957903583807f5c42731dfd5b4aea56de7d1ebd47ab6909f12492bd5e7a788322e0b2d80e15d883483a080f8fe11c SHA512 59e304d63830227b1619ed1299e9b61f5b6e534cb03da4d3a0e35a0fe727ccf2d994a034bd12d515bba4f8a6a8ca513cf2131c031fa63f85906639aca159993a
DIST postfixadmin-3.1.tar.gz 1279224 BLAKE2B f37fd9e34e5eb88a82c10a0b80d5593a7451f407948454a064209ba9150192b7026645774b97b0482488814d6abeb25b6a800c2f7fe12a7a768e711919b94852 SHA512 a3e1ecb3ac4ff4d604533bce532694bcc304b9b3d3e1b1ec840be6d007027705113f067393486f58908dd3846332ecf59c9c3c1a5123d03aa088f47593a75812
+DIST postfixadmin-3.2.tar.gz 1324335 BLAKE2B 39fe9174f9085b35a58cacac1e99cc1a9209dbb029c903dbbab4fc68f041687e94327ea379e11c6967810d786bae0758f77f5cc2359d82720bb8edada61717d5 SHA512 eca4903dc3a22e56585c6f1b028a0f93d2422574faf9458b369b071880af55b36cd52c5ff9b0438c2c129a561404414b5d1f926043b40700fb5e31bffffe6ec7
EBUILD postfixadmin-3.1.ebuild 2770 BLAKE2B 0515ec76d9cabdf0861c568ea3a2b2490a4dd385834638942fdda279f7a5a28868663e9936c6b6a9d5df006ddb78dd9e0a552eff51f8cc333f348d0e6b87b7e8 SHA512 7190fe45e795bf803a7ad1ba5ab5f45af065a1b6e3680476e0bcc13df2426b1040a014958fedc57a68b972c367f9145161d40e63d015bb94d783f8fc8518db1c
+EBUILD postfixadmin-3.2.ebuild 2735 BLAKE2B 20355240a654ec71d14a7595b0e11f3449e2ac0c95acab3f7d888b75dec70c7bb400ae6f6b2e200e99e44de85f0e853f361af937e53db50a81b05051b2c02e73 SHA512 aa0d855a181eb5b7f7fa660ba882a5773b6ffdc1bd7ee7af35a5f25ac350b5f90b603597747589ebb18d841f683bad3dc2e86c41128927826813b898fc03ce55
MISC metadata.xml 536 BLAKE2B 0ec01f47f106656e1b98ca14d8b531597a34cfb2fd261c93c775d7dd3b0a08155e9e912a20a2330946697418898ed08d9be6f8409edb5e1ef6009cafddde2437 SHA512 4657f3ae892ad55572ac39f23cebcef58480d4ff608150c75d2cf3f0046b5e0a2861f9bf8dfffd45aef580675feae11a05297a7a99f63997d43ab703372ddf4a
diff --git a/www-apps/postfixadmin/postfixadmin-3.2.ebuild b/www-apps/postfixadmin/postfixadmin-3.2.ebuild
new file mode 100644
index 000000000000..45f2da12339d
--- /dev/null
+++ b/www-apps/postfixadmin/postfixadmin-3.2.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit user webapp
+
+DESCRIPTION="Web Based Management tool for Postfix style virtual domains and users"
+HOMEPAGE="http://postfixadmin.sourceforge.net"
+SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+mysql postgres +vacation"
+REQUIRED_USE="|| ( mysql postgres )"
+
+DEPEND="
+ dev-lang/php:*[unicode,imap,postgres?]
+ vacation? (
+ dev-perl/DBI
+ dev-perl/Email-Sender
+ dev-perl/Email-Valid
+ dev-perl/Log-Dispatch
+ dev-perl/Log-Log4perl
+ dev-perl/MIME-Charset
+ dev-perl/MIME-EncWords
+ mysql? ( dev-perl/DBD-mysql )
+ postgres? ( dev-perl/DBD-Pg )
+ )
+"
+
+RDEPEND="${DEPEND}
+ virtual/httpd-php
+ mysql? ( || ( dev-lang/php[mysqli] dev-lang/php[mysql] ) )"
+
+need_httpd_cgi
+
+pkg_setup() {
+ webapp_pkg_setup
+
+ if use vacation; then
+ enewgroup vacation
+ enewuser vacation -1 -1 -1 vacation
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+
+ if use vacation; then
+ insinto /var/spool/vacation
+ newins VIRTUAL_VACATION/vacation.pl vacation.pl-${SLOT}
+ fowners vacation:vacation /var/spool/vacation/vacation.pl-${SLOT}
+ fperms 770 /var/spool/vacation/vacation.pl-${SLOT}
+ dodoc VIRTUAL_VACATION/FILTER_README
+ newdoc VIRTUAL_VACATION/INSTALL.md VIRTUAL_VACATION_INSTALL.md
+ rm -r VIRTUAL_VACATION/{vacation.pl,INSTALL.md,tests,FILTER_README} || die
+ fi
+
+ insinto /usr/share/doc/${PF}/
+ doins -r ADDITIONS
+
+ local docs="DOCUMENTS/*.txt INSTALL.TXT CHANGELOG.TXT"
+ dodoc ${docs}
+
+ rm -rf ${docs} DOCUMENTS/ GPL-LICENSE.TXT LICENSE.TXT debian/ tests/ ADDITIONS/
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config.inc.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-2.3.txt
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+ if use vacation; then
+ # portage does not update owners of directories (feature :)
+ chown vacation:vacation "${ROOT}"/var/spool/vacation/
+ einfo "/var/spool/vacation/vacation.pl symlink was updated to:"
+ einfo "/var/spool/vacation/vacation.pl-${SLOT}"
+ ln -sf "${ROOT}"/var/spool/vacation/vacation.pl{-${SLOT},} || die
+ fi
+}
+
+pkg_postrm() {
+ # Make sure we don't leave broken vacation.pl symlink
+ find -L "${ROOT}"/var/spool/vacation/ -type l -delete
+ local shopt_save=$(shopt -p nullglob)
+ shopt -s nullglob
+ local vacation=( "${ROOT}"/var/spool/vacation/vacation.pl-* )
+ ${shopt_save}
+ if [[ ! -e "${ROOT}"/var/spool/vacation/vacation.pl && -n ${vacation[@]} ]]; then
+ ln -s "${vacation[-1]}" "${ROOT}"/var/spool/vacation/vacation.pl || die
+ ewarn "/var/spool/vacation/vacation.pl was updated to point on most"
+ ewarn "recent verion, but please, do your own checks"
+ fi
+}