summaryrefslogtreecommitdiff
path: root/www-apps/piwigo/piwigo-14.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-31 23:49:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-31 23:49:10 +0000
commit262dea609d1cde1b7d3f556b5e77f6ba6f6d272b (patch)
treef86de9739ce396e697129ee9721861a395eac218 /www-apps/piwigo/piwigo-14.2.0.ebuild
parent88e6368ac393fb69b358b60fcedf125f4724172f (diff)
gentoo auto-resync : 31:01:2024 - 23:49:10
Diffstat (limited to 'www-apps/piwigo/piwigo-14.2.0.ebuild')
-rw-r--r--www-apps/piwigo/piwigo-14.2.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/www-apps/piwigo/piwigo-14.2.0.ebuild b/www-apps/piwigo/piwigo-14.2.0.ebuild
new file mode 100644
index 000000000000..6b766f9c42fd
--- /dev/null
+++ b/www-apps/piwigo/piwigo-14.2.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit webapp
+
+DESCRIPTION="a photo gallery software for the web"
+HOMEPAGE="http://piwigo.org/"
+SRC_URI="http://piwigo.org/download/dlcounter.php?code=${PV} -> ${P}.zip"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+exif +gd imagemagick"
+
+DEPEND=""
+RDEPEND="
+ imagemagick? ( virtual/imagemagick-tools )
+ dev-lang/php[ctype,exif?,gd?,filter,iconv,json(+),mysqli]
+ >=virtual/mysql-5.0
+ virtual/httpd-php"
+BDEPEND="app-arch/unzip"
+
+REQUIRED_USE="|| ( gd imagemagick )"
+
+S=${WORKDIR}/${PN}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ # Local configuration, and parts that can be updated
+ webapp_serverowned "${MY_HTDOCSDIR}"/_data
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/galleries
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/language
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/local
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/plugins
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/template-extension
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/themes
+ webapp_serverowned "${MY_HTDOCSDIR}"/upload
+
+ webapp_src_install
+}